<!doctype html>
<html>
<head>
<meta charset="UTF-8"/>
<title>Azealia Banks Says She Sacrifices Chickens</title>
<link rel="icon" href="http://assets.vibe.com/favicon.ico"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta name="viewport" content="width=device-width">
<link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.vibe.com/feed">
<link rel="stylesheet" href="http://www.vibe.com/wp-content/themes/vibe/assets/css/style.css?34665b63fdb18bcf80cf154251218b0326125a75" type="text/css" media="screen"/>
<script type="text/javascript">
        clarityPageData = {"site_code":"vibe_2016","zone":"article_page"};
    </script>
<script type="text/javascript">
    (function(){
        window.CLARITY = window.CLARITY || [];
        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.spinmediacdn.com/clarity-1482177550280.min.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>var dacBidRequestConfigs=[{"placement":4396331,"adContainerId":"leaderboard_top_1","alias":"leaderboard_top_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_top_1","alias":"leaderboard_top_1_970x250"},{"placement":4396331,"adContainerId":"leaderboard_bottom_lazy_1","alias":"leaderboard_bottom_lazy_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_bottom_lazy_1","alias":"leaderboard_bottom_lazy_1_970x250"},{"placement":4396330,"adContainerId":"medrec_top_1","alias":"medrec_top_1_300x250"},{"placement":4396332,"adContainerId":"medrec_top_1","alias":"medrec_top_1_300x600"},{"placement":4396330,"adContainerId":"medrec_bottom_lazy_1","alias":"medrec_bottom_lazy_1_300x250"},{"placement":4396332,"adContainerId":"medrec_bottom_lazy_1","alias":"medrec_bottom_lazy_1_300x600"},{"placement":4396331,"adContainerId":"leaderboard_bottom_first_1","alias":"leaderboard_bottom_first_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_bottom_first_1","alias":"leaderboard_bottom_first_1_970x250"},{"placement":4396330,"adContainerId":"medrec_bottom_first_1","alias":"medrec_bottom_first_1_300x250"},{"placement":4396332,"adContainerId":"medrec_bottom_first_1","alias":"medrec_bottom_first_1_300x600"}];</script>
<script>var OX_dfp_ads=[['/4700/vibe_2016/article_page/leaderboard_top',['728x90','970x250','970x90'],'leaderboard_top_1',{"pos":["leaderboard_top"],"pagetype":["article_page"]}],['/4700/vibe_2016/article_page/leaderboard_bottom_lazy',['728x90','970x250','970x90'],'leaderboard_bottom_lazy_1',{"pos":["leaderboard_bottom_lazy"],"pagetype":["article_page"]}],['/4700/vibe_2016/article_page/medrec_top',['300x250','300x600'],'medrec_top_1',{"pos":["medrec_top"],"pagetype":["article_page"]}],['/4700/vibe_2016/article_page/medrec_bottom_lazy',['300x250','300x600'],'medrec_bottom_lazy_1',{"pos":["medrec_bottom_lazy"],"pagetype":["article_page"]}],['/4700/vibe_2016/article_page/leaderboard_bottom_first',['728x90','970x250','970x90'],'leaderboard_bottom_first_1',{"pos":["leaderboard_bottom_first"],"pagetype":["article_page"]}],['/4700/vibe_2016/article_page/medrec_bottom_first',['300x250','300x600'],'medrec_bottom_first_1',{"pos":["medrec_bottom_first"],"pagetype":["article_page"]}],];</script><script>window.oxDone=function(){CLARITY.push({use:['header','logger'],run:function(header,logger){try{logger.log("Setting OX targeting from template Clarity push","header");header.partners.ox.setTargeting();}catch(e){logger.log("header.oxSetTargeting failed with error : "+e,"error");}}});};(function(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=(document.location.protocol==='https:'?'https:':'http:')+'//spinmedia-d.openx.net/w/1.0/jstag?nc=4700-vibe';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(s);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('openx');}});</script>
<script>var rubicon_ads=[['/4700/vibe_2016/article_page/leaderboard_top',[[728,90],[970,250],[970,90]],'leaderboard_top_1'],['/4700/vibe_2016/article_page/leaderboard_bottom_lazy',[[728,90],[970,250],[970,90]],'leaderboard_bottom_lazy_1'],['/4700/vibe_2016/article_page/medrec_top',[[300,250],[300,600]],'medrec_top_1'],['/4700/vibe_2016/article_page/medrec_bottom_lazy',[[300,250],[300,600]],'medrec_bottom_lazy_1'],];var rubicontag=rubicontag||{};rubicontag.cmd=rubicontag.cmd||[];(function(){var account_id=7952;var rct=document.createElement('script');rct.type='text/javascript';rct.async=true;rct.src=(document.location.protocol==='https:'?'https:':'http:')+'//ads.rubiconproject.com/header/'+account_id+'.js';var node=document.getElementsByTagName('script')[0];node.parentNode.appendChild(rct);})();CLARITY.push({use:['header'],run:function(header){header.skipJsInject('rubicon');}});</script>
<script>CLARITY.push({use:['header'],run:function(header){header.run({"aol":{"placements":[{"placement":4396331,"adContainerId":"leaderboard_top_1","alias":"leaderboard_top_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_top_1","alias":"leaderboard_top_1_970x250"},{"placement":4396331,"adContainerId":"leaderboard_bottom_lazy_1","alias":"leaderboard_bottom_lazy_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_bottom_lazy_1","alias":"leaderboard_bottom_lazy_1_970x250"},{"placement":4396330,"adContainerId":"medrec_top_1","alias":"medrec_top_1_300x250"},{"placement":4396332,"adContainerId":"medrec_top_1","alias":"medrec_top_1_300x600"},{"placement":4396330,"adContainerId":"medrec_bottom_lazy_1","alias":"medrec_bottom_lazy_1_300x250"},{"placement":4396332,"adContainerId":"medrec_bottom_lazy_1","alias":"medrec_bottom_lazy_1_300x600"},{"placement":4396331,"adContainerId":"leaderboard_bottom_first_1","alias":"leaderboard_bottom_first_1_728x90"},{"placement":4396333,"adContainerId":"leaderboard_bottom_first_1","alias":"leaderboard_bottom_first_1_970x250"},{"placement":4396330,"adContainerId":"medrec_bottom_first_1","alias":"medrec_bottom_first_1_300x250"},{"placement":4396332,"adContainerId":"medrec_bottom_first_1","alias":"medrec_bottom_first_1_300x600"}],"positions":["leaderboard_top","leaderboard_bottom_lazy","medrec_top","medrec_bottom_lazy","leaderboard_bottom_first","medrec_bottom_first"]},"openx":{"network_code":"4700-vibe","positions":{"leaderboard_top":"['728x90','970x250','970x90']","leaderboard_bottom_lazy":"['728x90','970x250','970x90']","medrec_top":"['300x250','300x600']","medrec_bottom_lazy":"['300x250','300x600']","leaderboard_bottom_first":"['728x90','970x250','970x90']","medrec_bottom_first":"['300x250','300x600']"}},"rubicon":{"account_id":7952,"positions":{"leaderboard_top":"[[728,90],[970,250],[970,90]]","leaderboard_bottom_lazy":"[[728,90],[970,250],[970,90]]","medrec_top":"[[300,250],[300,600]]","medrec_bottom_lazy":"[[300,250],[300,600]]"}},"yieldbot":{"desktop":"76c8","mobile":"b13d"}});}});</script> <script>
    if("I10C" in window && I10C.Morph == 1){
        window.CLARITY.push({
            use: ["instart"], 
            run: function(instart) { 
                instart.run({
                    'unblocked_ads': []
                });
            }
        });
        window.CLARITY.push({use: ["ads"],run: function(Ads) { Ads.zone = 'unblocked'; }});
    }
</script>
<meta name="description" content="Azealia Banks revealed her chicken sacrificing ritual on Instragram."/>
<meta name="keywords" content="azealia banks,chickens,sia"/>
<link rel="canonical" href="http://www.vibe.com/2016/12/azealia-banks-chickens/"/>
<meta property="og:title" content="Azealia Banks Says She Sacrifices Chickens"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="http://www.vibe.com/2016/12/azealia-banks-chickens/"/>
<meta property="og:image" content="http://static.vibe.com/files/2015/08/azealia-banks-black-media-twitter.png"/>
<meta property="og:image:width" content="596"/>
<meta property="og:image:height" content="593"/>
<meta property="og:site_name" content="Vibe"/>
<meta property="og:description" content="Azealia Banks revealed her chicken sacrificing ritual on Instragram. "/>
<meta property="article:published_time" content="2016-12-31T15:12:06Z"/>
<meta property="article:modified_time" content="2016-12-31T15:12:06Z"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:title" content="Azealia Banks Says She Sacrifices Chickens"/>
<meta name="twitter:description" content="Azealia Banks revealed her chicken sacrificing ritual on Instragram. "/>
<meta name="twitter:image" content="http://static.vibe.com/files/2015/08/azealia-banks-black-media-twitter-compressed.png"/>
<meta itemprop="image" content="http://static.vibe.com/files/2015/08/azealia-banks-black-media-twitter-compressed.png"/>
<link rel="alternate" type="application/rss+xml" title="Vibe &raquo; Azealia Banks Says She’s Been Sacrificing Chickens For Three Years Comments Feed" href="http://www.vibe.com/2016/12/azealia-banks-chickens/feed/"/>
<link rel='stylesheet' id='mobile-zoom-css' href='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/css/vendor/mobile-zoom.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<link rel='stylesheet' id='in-post-widget-css' href='http://assets.vibe.com/wp-content/plugins/wp-affiliate/css/affiliate.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<link rel='stylesheet' id='pi-gallery-css-css' href='http://assets.vibe.com/wp-content/plugins/wp-pi-gallery/css/style.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<link rel='stylesheet' id='icon-styles-css' href='http://www.vibe.com/wp-content/themes/wp-theme-base/assets/css/icons.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp/wp-includes/js/jquery/jquery-migrate.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp/wp-includes/js/underscore.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-widgets/js/ajax-widgets.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/js/jquery.lazyloadxt.extra.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/js/lazyloadxt.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var userSettings = {"url":"\/wp\/","uid":"0","time":"1483215127","secure":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vibe.com/wp/wp-includes/js/utils.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var settings = {"always":"http:\/\/c.spinmedia.com\/common\/abt\/a\/vb.png","always_pixel":"on","detected":"http:\/\/c.spinmedia.com\/common\/abt\/y\/vb.png","detected_pixel":"on","not_detected":"http:\/\/c.spinmedia.com\/common\/abt\/n\/vb.png","not_detected_pixel":"on","property_id":"UA-66258239-1","endpoint":"http:\/\/g.vibe.com\/c","clarity_path":"lib.spinmediacdn.com\/clarity-1482177550280.min.js"};
/* ]]> */
</script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-adblock-tracker/js/vendor/blockadblock.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gtm_data = {"gtm_id":"GTM-W3TLHV","gtm_env_params":"","gtm_pagetype":"article-page","gtm_author":"Latifah Muhammad","gtm_category":"music news","gtm_ptag":"none","gtm_date":"20161231","gtm_tags":"Azealia Banks","gtm_category_data":[{"term_id":4,"name":"Music News","slug":"music-news","term_group":0,"term_taxonomy_id":4,"taxonomy":"category","description":"","parent":2,"count":1569,"filter":"raw","cat_ID":4,"category_count":1569,"category_description":"","cat_name":"Music News","category_nicename":"music-news","category_parent":2}],"gtm_category_data_clean":"music news","gtm_ptags":[],"gtm_referrer":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-adblock-tracker/js/analytics.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-adblock-tracker/js/track.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<link rel='https://api.w.org/' href='http://www.vibe.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.vibe.com/wp/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.vibe.com/wp/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Waffle House Waitress Protects Restaurant By Pulling Out Gun On Suspected Robbers' href='http://www.vibe.com/2016/12/waffle-house-waitress-fires-gun-after-suspected-robbers/'/>
<meta name="generator" content="WordPress 4.5.2"/>
<link rel='shortlink' href='http://www.vibe.com/?p=477087'/>
<link rel="alternate" type="application/json+oembed" href="http://www.vibe.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.vibe.com%2F2016%2F12%2Fazealia-banks-chickens%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.vibe.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.vibe.com%2F2016%2F12%2Fazealia-banks-chickens%2F&#038;format=xml"/>
<meta property="fb:pages" content="123159412963"/><script>
    var ajax_url = 'http\x3A\x2F\x2Fwww.vibe.com\x2Fajax';
</script><link rel="amphtml" href="http://www.vibe.com/2016/12/azealia-banks-chickens?amp=1"/>
<link href='http://fonts.googleapis.com/css?family=Roboto+Slab:400,700,300' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=Roboto+Condensed:300italic,400italic,700italic,400,700,300' rel='stylesheet' type='text/css'>
</head>
<body itemscope itemtype="http://schema.org/Article" class="single single-post postid-477087 single-format-image">
<noscript>
<iframe src="//www.googletagmanager.com/ns.html?id=GTM-W3TLHV" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<script>
                dataLayer = [{"pagetype":"article-page","author":"Latifah Muhammad","category":"music news","published date":"20161231","parent tag":"none","tags":"Azealia Banks"}];
                                (function (w, d, s, l, i) {
                    w[l] = w[l] || [];
                    w[l].push({
                        'gtm.start': new Date().getTime(), event: 'gtm.js'
                    });
                    var f = d.getElementsByTagName(s)[0],
                        j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
                    j.async = true;
                    j.src =
                        '//www.googletagmanager.com/gtm.js?id=' + i + dl + '';
                    f.parentNode.insertBefore(j, f);
                })(window, document, 'script', 'dataLayer', 'GTM-W3TLHV');</script>
<script>(function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
            fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>
<div id="fb-root"></div>
<div id="menu" class="navbar navbar-default navbar-fixed-top" role="navigation">
<div class="container">
<div class="inner-nav-holder">
<div class="navbar-header">
<a href="/" class="navbar-brand" id="logo">
<span></span>
</a>
</div>
<div class="collapse navbar-collapse">
<ul class="main-nav nav navbar-nav">
<li class="dropdown dropdown-hover  menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-331092 menu-item-has-children">
<a href="http://www.vibe.com/category/news/" class="dropdown-toggle">
News
<span class="caret"></span>
</a>
<ul class="dropdown-menu" role="menu">
<li>
<a href="http://www.vibe.com/category/news/national/">
<span>
National
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/news/sports/">
<span>
Sports
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/news/events/">
<span>
Events
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/news/movies-tv/">
<span>
Movies & TV
</span>
</a>
</li>
</ul>
</li>
<li class="dropdown dropdown-hover  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-331101 menu-item-has-children">
<a href="http://www.vibe.com/category/music/" class="dropdown-toggle">
Music
<span class="caret"></span>
</a>
<ul class="dropdown-menu" role="menu">
<li>
<a href="http://www.vibe.com/category/music/videos/">
<span>
Videos
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/music/new-releases/">
<span>
New Releases
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/music/live-reviews/">
<span>
Live Reviews
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/music/album-reviews/">
<span>
Album Reviews
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/music/music-premieres/">
<span>
Music Premieres
</span>
</a>
</li>
</ul>
</li>
<li class="dropdown dropdown-hover  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-331107 menu-item-has-children">
<a href="http://www.vibe.com/category/features/" class="dropdown-toggle">
Features
<span class="caret"></span>
</a>
<ul class="dropdown-menu" role="menu">
<li>
<a href="http://www.vibe.com/category/features/digital-covers/">
<span>
Digital Covers
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/features/opinion/">
<span>
Opinion
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/features/lists/">
<span>
Lists
</span>
</a>
</li>
</ul>
</li>
<li class="dropdown dropdown-hover  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-331111 menu-item-has-children">
<a href="http://www.vibe.com/category/style/" class="dropdown-toggle">
Style
<span class="caret"></span>
</a>
<ul class="dropdown-menu" role="menu">
<li>
<a href="http://www.vibe.com/category/style/fashion/">
<span>
Fashion
</span>
</a>
</li>
<li>
<a href="http://www.vibe.com/category/style/lifestyle/">
<span>
Lifestyle
</span>
</a>
</li>
</ul>
</li>
<li class="  menu-item menu-item-type-taxonomy menu-item-object-category menu-item-331114">
<a href="http://www.vibe.com/category/vixen/">
Vixen
</a>
</li>
<li class="  viva">
<a href="http://www.vibe.com/category/viva/">
Viva
</a>
</li>
</ul>
<div class="social-and-search">
<ul class="social-links">
<li>
<a class="icon-facebook" href="http://www.facebook.com/vibe" target="_blank"></a>
</li>
<li>
<a class="icon-twitter" href="http://www.twitter.com/vibemagazine" target="_blank"></a>
</li>
<li class="more-social-icons">
<span class="icon-plus"></span>
<ul class="extra-3">
<li>
<a class="icon-instagram" href="http://www.instagram.com/VIBEmagazine" target="_blank"></a>
</li>
<li>
<a class="icon-pinterest" href="http://www.pinterest.com/vibemagazine" target="_blank"></a>
</li>
<li>
<a class="icon-google_plus" href="http://plus.google.com/+vibemedia" target="_blank"></a>
</li>
</ul>
</li>
</ul>
<div class="search">
<form role="search" action="/" method="GET" id="header-search">
<div class="query-holder">
<input type="text" name="s" placeholder="Search" autocomplete="off">
</div>
<span class="search-submit"></span>
</form>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="social-holder sticky-header">
<div class="social-icons">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-email" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-fb" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-tw" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-red" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Reddit"></div>
</div>
</div> </div>
<div class="container ad-container">
<div class="leaderboard_top-placeholder">
<div class="leaderboard_top-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_top' data-sizes='[[728,90],[970,250],[970,90]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='1' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="container main-container">
<div class="row">
<div class="col-sm-8 left-col">
<div class="article-body" itemScope itemType="https://schema.org/Article">
<div>
<h1 itemprop="name">
Azealia Banks Says She’s Been Sacrificing Chickens For Three Years
</h1>
</div>
<div itemprop="author" itemscope itemtype="http://schema.org/Person" class="author">
<h3 class="cat-badge cat-music news">
Music News
</h3>
<a href="http://www.vibe.com/author/thelatifah/">Latifah Muhammad</a>
<span class="twitter">
<a href="//twitter.com/thelatifah" class="twitter-handle" target="blank">@thelatifah</a>
</span>
<span class="date"> | December 31, 2016 - 3:12 pm</span>
</div>
<div class="social-holder">
<div class="social-icons post-header">
<div class="social-container">
<div class="logo"><a href="/"></a></div>
<div class="title">Share < br />this article:</div>
<div class="email sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-email" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Email"></div>
<div class="facebook sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-fb" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Share"></div>
<div class="twitter sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-tw" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Tweet"></div>
<div class="reddit sharrre" data-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-short-url="http://www.vibe.com/2016/12/azealia-banks-chickens/" data-utm-source="share-red" data-text="Azealia Banks Says She’s Been Sacrificing Chickens For Three Years" data-title="Reddit"></div>
</div>
</div> </div>
<div class="featured-embed-holder format-image">
<div class="article-image-holder">
<div itemscope itemtype="http://schema.org/ImageObject" class="mainembed photoembed mainembed-article-embed/large align-center">
<div class="img-wrap">
<img class="imageresource zoom-image" itemprop="image" src="http://static.vibe.com/files/2015/08/azealia-banks-black-media-twitter-compressed.png" data-img-zoom="http://static.vibe.com/files/2015/08/azealia-banks-black-media-twitter-compressed.png" data-img-zoom-w="596" data-img-zoom-h="593" alt="azealia banks black media twitter" width="596" height="593">
</div>
<div class="credit-wrapper">
<div class="credit"><small>CREDIT:</small> Instagram/azealiabanks</div>
</div>
</div>
</div>
</div>
<div class="article-content-holder">
<div itemprop="articleBody" class="single-content-holder">
<div class="article-content clearfix" itemprop="articleBody">
<p>There’s never a dull moment in the life of Azealia Banks.</p>
<p>Serving up a final <a href="http://www.vibe.com/2016/12/azealia-banks-nicki-minaj-open-letter/" target="_blank">slice of controversy</a> for 2016, Banks revealed that she’s been sacrificing chickens &#8212; in a closet &#8212; for the last three years.</p>
<p>“Three years worth of brujeria [witchcraft], you know I got to scrape all this sh*t up,&#8221; Banks says in a video showing off her blood-stained closet. &#8220;I’ve got my sandblaster, and my goggles — it’s about to go down, ”</p>
<p>&#8220;Real witches do real things,&#8221; she adds.</p>
<p class="speedbump"><strong>READ: <a href="http://www.vibe.com/2016/12/district-attorney-dismisses-azealia-banks-case-against-russell-crowe/" target="_blank">D.A. Dismisses Azealia Banks’ Case Against Russell Crowe</a></strong></p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">Azealia Banks via instagram, cleaning the closet she&#8217;s been performing brujeria for 3 years in. <a href="https://t.co/0OsoSdJynw">pic.twitter.com/0OsoSdJynw</a></p>
<p>— AZEALIA BANKS VIDEOS (@AzealiaVideos) <a href="https://twitter.com/AzealiaVideos/status/814847767063437312">December 30, 2016</a></p></blockquote>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<p>The clip went viral Friday (Dec. 30), and Banks found herself mixed up in a whirlwind of tweets. Sia even got in the drama, but the Harlem rapper was to clap back.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 658px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-version="7">
<div style="padding: 8px;">
<div style="background: #F8F8F8; line-height: 0; margin-top: 40px; padding: 50.0% 0; text-align: center; width: 100%;"></div>
<p><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/BOqDjKDAaUx/" target="_blank">I thought #AzealiaBanks was going to be nice now &#x1f629; #Sia</a></p>
<p>A photo posted by The Shade Room (@theshaderoom) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2016-12-30T21:54:53+00:00">Dec 30, 2016 at 1:54pm PST</time>
</div>
</blockquote>
<p><script src="//platform.instagram.com/en_US/embeds.js" async="" defer="defer"></script></p>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script>The Church of Satan felt the need to chime in, apparently distancing themselves from Banks&#8217; practices.</p>
<blockquote class="twitter-tweet" data-lang="en"><p>
We would like to clarify for the record that sacrifice, animal or otherwise, has no part of Satanism. <a href="https://twitter.com/hashtag/azealia?src=hash">#azealia</a> <a href="https://twitter.com/hashtag/azealiabanks?src=hash">#azealiabanks</a></p>
<p>— The Church Of Satan (@ChurchofSatan) <a href="https://twitter.com/ChurchofSatan/status/814929573037142016">December 30, 2016</a>
</p></blockquote>
<p class="speedbump"><strong>READ: <a href="http://www.vibe.com/2016/10/azealia-banks-apology-zayn-kills-so-ghetto-freestyle/" target="_blank">Make Azealia Great Again: Rapper Pens Apology To Zayn &amp; Kills “So Ghetto” Freestyle</a></strong></p>
<p>Peep more Twitter reactions below.</p>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-lang="en"><p>I thought I was losing it but then Azealia Banks showed us her blood-stained chicken sacrificing closet and now I don&#8217;t feel so bad</p>
<p>— ryanna (@ryanna_jordan) <a href="https://twitter.com/ryanna_jordan/status/814863173664772096">December 30, 2016</a></p></blockquote>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-lang="en"><p>
yall: azealia banks shouldnt be harming chickens!!! its wrong to hurt animals ☹️</p>
<p>yall, at mcdonalds: <a href="https://t.co/5yJtxhzGk0">pic.twitter.com/5yJtxhzGk0</a></p>
<p>— Ty (@STRAYEDAWAY) <a href="https://twitter.com/STRAYEDAWAY/status/814943798052683778">December 30, 2016</a>
</p></blockquote>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-lang="en"><p>Azealia Banks has been sacrificing chickens for 3 years. All that witchcraft and she still can&#8217;t conjure up a career</p>
<p>— Uma Kompton (@KomptonMusic) <a href="https://twitter.com/KomptonMusic/status/814884246359638016">December 30, 2016</a></p></blockquote>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-lang="en"><p>
azealia banks confessing 2 sacrificing chickens in her bedroom closet is the grand finale of 2016</p>
<p>— &#x1f624; (@tylerplanet8) <a href="https://twitter.com/tylerplanet8/status/814840763947294720">December 30, 2016</a>
</p></blockquote>
<p><script src="//platform.twitter.com/widgets.js" async="" charset="utf-8"></script></p>
<p class="speedbump"><strong>READ: <a href="http://www.vibe.com/2016/10/azealia-banks-not-voting-for-trump/" target="_blank">Azealia Banks Withdraws Trump Endorsement: “I Made A Major Mistake”</a></strong></p>
</div>
</div>
<div class="row tags-and-comments">
<div class="col-sm-9">
<div itemprop="keywords" class="tags">
<strong>Tags:</strong>
<a href="http://www.vibe.com/tag/azealia-banks/">azealia banks</a> </div>
</div>
<div class="col-sm-3">
<div itemprop="comment" class="comments right">
<a href="http://www.vibe.com/2016/12/azealia-banks-chickens/#respond"><span class="count disqus-comment-count" data-disqus-identifier="477087 http://www.vibe.com/?p=477087">0</span><span class="article-comment-bubble"></span></a>
</div>
</div>
</div>
</div>
</div>
<hr>
<div class="zergnet-holder">
<div class="zergnet-widget" id="zergnet-widget-33147"></div>
<script language="javascript" type="text/javascript">
        (function () {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript';
            zergnet.async = true;
            zergnet.src = 'http://www.zergnet.com/zerg.js?id=33147';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);

            zergnet.onload = function(){ 
                window.dataLayer = window.dataLayer || [];
                var zergnetId = '33147';

                if(zergnetId) {
                    window.dataLayer.push({
                        'event': 'zergnet',
                        'action': 'loaded',
                        'label': zergnetId
                    }); 
                }
            };
        })();
    </script>
</div>
<div class="link-exchanges">
<div class="recommended-module ">
<div class="title-holder">
<h2>Recommended for you</h2>
</div>
<div class="row">
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/12/azealia-banks-nicki-minaj-open-letter/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<img src="http://static.vibe.com/files/2016/12/azealia-banks-nicki-minaj-open-letter-1482264944-191x127.jpg" width="191" height="127" alt="Azealia Banks Writes Vicious And Crass Open Letter To Nicki Minaj, The Barbs Promptly Attack">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/12/azealia-banks-nicki-minaj-open-letter/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="1">
<h3>
Azealia Banks Writes Vicious And Crass Open Letter To Nicki Minaj, The Barbs Promptly Attack
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/12/district-attorney-dismisses-azealia-banks-case-against-russell-crowe/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<img src="http://static.vibe.com/files/2016/10/azealia-banks-russell-crowe-1476731205-191x127.png" width="191" height="127" alt="D.A. Dismisses Azealia Banks&#8217; Case Against Russell Crowe">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/12/district-attorney-dismisses-azealia-banks-case-against-russell-crowe/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="2">
<h3>
D.A. Dismisses Azealia Banks&#8217; Case Against Russell Crowe
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-russell-crowe-access-hollywood-interview/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<img src="http://static.vibe.com/files/2016/10/azealia-banks-access-hollywood-russell-crowe-1477672083-191x127.png" width="191" height="127" alt="Azealia Banks Emotionally Speaks Out On Reported Altercation With Russell Crowe">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-russell-crowe-access-hollywood-interview/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="3">
<h3>
Azealia Banks Emotionally Speaks Out On Reported Altercation With Russell Crowe
</h3>
</a>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-russell-crowe-no-security-footage/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<img src="http://static.vibe.com/files/2016/10/azealia-banks-russell-crowe-1476731205-640x4801-1477318535-191x127.png" width="191" height="127" alt="Police Unable To Dig Up Security Footage Of Azealia Banks, Russell Crowe Incident">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-russell-crowe-no-security-footage/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="4">
<h3>
Police Unable To Dig Up Security Footage Of Azealia Banks, Russell Crowe Incident
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-apology-zayn-kills-so-ghetto-freestyle/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<img src="http://static.vibe.com/files/2015/06/6-azealia-banks-reality-show-191x127.jpg" width="191" height="127" alt="Make Azealia Great Again: Rapper Pens Apology To Zayn &#038; Kills &#8220;So Ghetto&#8221; Freestyle">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/10/azealia-banks-apology-zayn-kills-so-ghetto-freestyle/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="5">
<h3>
Make Azealia Great Again: Rapper Pens Apology To Zayn &#038; Kills &#8220;So Ghetto&#8221; Freestyle
</h3>
</a>
</div>
</div>
<div class="col-sm-4">
<div class="image-holder">
<a href="http://www.vibe.com/2016/10/rza-azealia-banks-facebook/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<img src="http://static.vibe.com/files/2016/10/rza-azealia-banks-facebook-post-1476992461-191x127.jpg" width="191" height="127" alt="RZA Details Altercation Between Russell Crowe And Azealia Banks">
</a>
</div>
<div class="preview-holder">
<a href="http://www.vibe.com/2016/10/rza-azealia-banks-facebook/" class="ga-product-impression" data-list-name="Recommended - Article" data-list-position="6">
<h3>
RZA Details Altercation Between Russell Crowe And Azealia Banks
</h3>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="comments-wrapper">
<h3>Comments</h3>
<div class="comments">
<a id="comments"></a>
<div id="disqus_thread">
</div>
</div>
</div>
</div>
<div class="col-sm-4 sidebar">
<div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_top' data-sizes='[[300,250],[300,600]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='2' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div><div id="text-8" class="widget_text"> <div class="textwidget"><style>#zergnet-widget-29425 .zergentity a{font-weight:normal!important;font-size:15px;line-height:1.4em;}</style>
<div class="sidebar-module">
<div class="title-holder clearfix">
<div class="title left"><h3>Around The Web</h3></div>
</div>
<div id="zergnet-widget-29425"></div>
</div></div>
</div><div class="sidebar-mobule sm-widget sm-widget-campaign-monitor">
<div class="widget-head">
<h3>The VIBE Mix Newsletter</h3>
</div>
<div class="widget-content">
<div class="success hidden">
Thank you for signing up for our newsletter. You will receive a confirmation shortly.
</div>
<form action="http://spinmedia1.createsend.com/t/i/s/jtjlo/" method="post" class="cm-form">
<input id="fieldEmail" name="cm-jtjlo-jtjlo" type="email" required placeholder="Enter Your Email"/>
<button type="submit" name="cm_submit">Sign Up</button>
<div class="error" class="hidden">
</div>
</form>
</div>
</div>
<div id="text-10" class="widget_text"> <div class="textwidget"><div class="link-exchanges"><div class="pub-exchange feed-split-image"><div class="pubexchange_module" id="pubexchange_rail" data-pubexchange-module-id="1932"></div></div></div></div>
</div><div class="sidebar-module ajax-widget" data-widget-id="spinmedia_widgets_mostrecent-10"></div><div class="sidebar-module ajax-widget" data-widget-id="spinmedia_widgets_mostrecent-11"></div><div class="sm-widget sm-widget-ad-holder"><div class="sm-widget-ad"> <div class="ad_desktop" data-position='medrec_bottom_first' data-sizes='[[300,250],[300,600]]' data-lazy-load='0' data-refresh='1' data-refresh-timer='0' data-swap='{"position":"medrec_bottom_lazy","refresh":1,"refreshTimer":15,"refreshLock":5}' data-load-order='' data-in-view='0' data-refresh-lock='0' style="min-width: 300px; min-height: 250px; box-sizing: content-box;">
</div>
</div></div>
</div>
</div>
</div>
<div class="container footer-ad-holder">
<div class="leaderboard-wrapper">
<div class="ad_desktop leaderboard" data-position='leaderboard_bottom_first' data-sizes='[[728,90],[970,250],[970,90]]' data-lazy-load='0' data-refresh='1' data-refresh-timer='0' data-swap='{"position":"leaderboard_bottom_lazy","refresh":0}' data-load-order='' data-in-view='0' data-refresh-lock='0' style="min-width: 728px; min-height: 90px; box-sizing: content-box;">
</div>
</div>
</div>
<div class="footer-recommended">
<div class="container">
<h3>
Featured Stories </h3>
<div class="row">
<a href="http://www.vibe.com/2016/11/lil-kim-hard-core-album-anniversary/">
<div class="post col-sm-3">
<div class="img-wrap">
<img src="http://static.vibe.com/files/2016/11/lil-kim-hard-core-album-cover-1478958479-200x133.jpg" alt="A Definitive Track Ranking Of Lil Kim's 'Hard Core' Album">
</div>
<div class="title">
<div>A Definitive Track Ranking Of Lil Kim's 'Hard Core' Album</div>
</div>
</div>
</a>
<a href="http://www.vibe.com/2016/11/tupac-2pacalypse-now-anniversary/">
<div class="post col-sm-3">
<div class="img-wrap">
<img src="http://static.vibe.com/files/2016/11/2pac-2pacalypse-now-1478897309-200x133.jpg" alt="How '2Pacalypse Now' Marked The Birth Of A Rap Revolutionary">
</div>
<div class="title">
<div>How '2Pacalypse Now' Marked The Birth Of A Rap Revolutionary</div>
</div>
</div>
</a>
<a href="http://www.vibe.com/2016/11/next-lady-leshurr-interview/">
<div class="post col-sm-3">
<div class="img-wrap">
<img src="http://static.vibe.com/files/2016/07/Lady-Leshurr-VIBE-Next-1-200x133.jpg" alt="NEXT: Lady Leshurr Is Birmingham, UK's Dose Of Rap Girl Magic">
</div>
<div class="title">
<div>NEXT: Lady Leshurr Is Birmingham, UK's Dose Of Rap Girl Magic</div>
</div>
</div>
</a>
<a href="http://www.vibe.com/2016/10/a-boogie-don-q-vibetribe-podcast/">
<div class="post col-sm-3">
<div class="img-wrap">
<img src="http://static.vibe.com/files/2016/10/a-boogie-don-q-1477930588-200x133.jpg" alt="VIBETRIBE Podcast: A Boogie & Don Q Are Playing For Keeps This Year">
</div>
<div class="title">
<div>VIBETRIBE Podcast: A Boogie & Don Q Are Playing For Keeps This Year</div>
</div>
</div>
</a>
</div>
</div>
</div>
<footer id="footer">
<div class="container">
<div class="comscore">
<div class="comscore-header clearfix">
<div class="right">
<div class="mobile-site-footer">
<a class="toggle-mobile comscore--link comscore--header-link" rel="alternate" href="#" data-toggle-mobile-site="">MOBILE SITE</a> </div>
<div class="footer-logo">
<a href="/">
<span></span>
</a>
</div>
</div>
<div class="left">
<span class="site-name">Vibe</span> is part of SpinMedia
<div class="comscore-header-links">
<a class="comscore--link comscore--header-link" href="http://www.spinmedia.com/#who-we-are" rel="nofollow" target="_blank">About <span class="comscore--bold">SpinMedia</span></a>
<a class="comscore--link comscore--header-link" href="http://www.spinmedia.com/#products" rel="nofollow" target="_blank">Advertise</a>
<a class="comscore--link comscore--header-link" href="http://www.spinmedia.com/" rel="nofollow" target="_blank">Contact SpinMedia</a>
<a class="comscore--link comscore--header-link" href="http://www.spinmedia.com/privacy-policy" rel="nofollow" target="_blank">Privacy Policy</a>
<a class="comscore--link comscore--header-link" href="http://www.spinmedia.com/about-our-ads" rel="nofollow" target="_blank" class="cs_aboutBug">
<img src="http://lib.spinmediacdn.com/choices/collisionadmarkerwht.png" alt="adChoices" class="comscore--img">
</a>
<a class="comscore--link" href="http://spinmedia.com/copyright" rel="nofollow" target="_blank">Copyright</a>
</div>
</div>
</div>
<div class="comscore--body">
<a class="comscore--bold comscore--link" href="http://www.spinmedia.com" target="_blank">SpinMedia</a> |
<a class="comscore--link" href="http://www.spin.com/" target="_blank" rel="nofollow">SPIN</a> /
<a class="comscore--link" href="http://www.vibe.com/" target="_blank" rel="nofollow">VIBE</a> /
<a class="comscore--link" href="http://www.celebuzz.com/" target="_blank" rel="nofollow">Celebuzz</a> /
<a class="comscore--link" href="http://www.thesuperficial.com/" target="_blank" rel="nofollow">The Superficial</a> /
<a class="comscore--link" href="http://www.thefrisky.com/" target="_blank" rel="nofollow">The Frisky</a> /
<a class="comscore--link" href="http://www.deathandtaxesmag.com/" target="_blank" rel="nofollow">Death and Taxes</a> /
<a class="comscore--link" href="http://www.stereogum.com/" target="_blank" rel="nofollow">Stereogum</a> /
<a class="comscore--link" href="http://www.gofugyourself.com/" target="_blank" rel="nofollow">Go Fug Yourself</a> /
<a class="comscore--link" href="http://celebslam.celebuzz.com/" target="_blank" rel="nofollow">Celebslam</a> /
<a class="comscore--link" href="http://www.soundslikenashville.com/" target="_blank" rel="nofollow">Sounds Like Nashville</a>
</div>
</div>
</div>
</footer>
<script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>
<script id="ad_slot" type="text/template">
            <div class="ad_desktop" data-sizes="[[160,600],[300,250],[300,600]]" data-position="300c"></div>
        </script>
<div id="hidden_div" class="hidden"></div>
<div id="ad_native_instream" class="ad_desktop" data-sizes="[2,2]" data-position="native_instream_lazy"></div>
<div id="ad_native_rightrail" class="ad_desktop" data-sizes="[2,2]" data-position="native_detail_lazy"></div><script type="text/html" id="sc_interrupter_template">
<div class="post row wp-pi-sponsored-content-interrupter">
    <div class="posts-holder"> 
                    <div class="interrupter-post"> 
            <div class="image-holder"> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <img src="<% if(typeof post_images == "object") { print(post_images.feed.split) } %>"> 
            </a> 
            <div class="text-overlay">
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>>
                    <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                </a>
            </div> 
        </div> 
        <div class="preview-holder"> 
                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                <div class="shared-by">
                    <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                </div>
            <% } %>    
                <h2> 
            <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %> target="_blank" <% } %>> 
                <% if(typeof post_title !== "undefined") { print(post_title) } %>
            </a> 
        </h2> 
        <% if(typeof sponsor_image !== "undefined") { %>
            <div class="sponsor"> 
                                <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %>

                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                    <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                </a> 
                
                                <% if((typeof show_sponsor === "undefined" || show_sponsor )
                        && typeof sponsor_name !== "undefined") { %>
                    <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %>
                    <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                        <span>
                            <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                        </span>
                    </a> 
                <% } %>
            </div> 
        <% } %>
                <div class="preview"> 
            <% if(typeof post_preview !== "undefined") { print(post_preview) } %>
        </div> 
            </div> 
</div>            </div> 
</div>
</script><script type="text/html" id="sc_interrupter_template_sidebar">
<div class="sidebar-module wp-pi-sponsored-content-interrupter"> 
    <div class="title-holder clearfix"> 
                    <div class="title left"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                    <h3>
                        <% if(typeof promoted_text !== "undefined") { print(promoted_text) } else { print('Promoted') } %>
                    </h3>
                </a>
            </div> 
            </div> 
    <div class="posts-holder"> 
        <div class="interrupter-post"> 
            <div class="image-holder"> 
                <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>> 
                    <img src="<% if(typeof post_images == "object") { print(post_images.sidebar) } %>">
                </a> 
            </div> 
            <div class="preview-holder"> 
                                    <% if(open_blank_links && typeof shared_from_site !== "undefined" && shared_from_site) { %>
                        <div class="shared-by">
                            <% if(typeof shared_from_text !== "undefined") { print(shared_from_text) } %> <a href="<% if(typeof shared_from_link !== "undefined") { print(shared_from_link) } %>" target="_blank"><% if(typeof shared_from_site !== "undefined") { print(shared_from_site) } %></a>
                        </div>
                    <% } %>    
                                <h2> 
                    <a href="<% if(typeof post_link !== "undefined") { print(post_link) } %>" <% if(open_blank_links) { %>target="_blank"<% } %>>
                        <% if(typeof post_title !== "undefined") { print(post_title) } %>
                    </a> 
                </h2> 
                <% if(typeof sponsor_image !== "undefined") { %>
                     
                        <div class="sponsor">
                                                        <% if(typeof show_sponsor !== "undefined" && !show_sponsor && typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                            
                            <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                <img src="<% if(typeof sponsor_image !== "undefined") { print(sponsor_image) } %>" alt="">
                            </a> 
                            <% if((typeof show_sponsor === "undefined" || show_sponsor)
                                    && typeof sponsor_name !== "undefined") { %>
                                <% if(typeof sponsor_text !== "undefined") { print(sponsor_text) } %> 
                                <a href="<% if(typeof sponsor_link !== "undefined") { print(sponsor_link) } %>" target="_blank">
                                    <span>
                                        <% if(typeof sponsor_name !== "undefined") { print(sponsor_name) } %>
                                    </span>
                                </a> 
                            <% } %>
                        </div> 
                     
                <% } %>
            </div> 
        </div> 
    </div> 
</div>
</script><script type="text/javascript">
    var disqus_config = function () {
        this.callbacks.onNewComment = [function () {
            dataLayer.push({
               'event': 'disqus-event',
               'category': 'Comments',
               'action': 'New Comment',
               'label': '/2016/12/azealia-banks-chickens/'
            });
        }];

        this.callbacks.onPaginate = [function (e) {
            dataLayer.push({
               'event': 'disqus-event',
               'category': 'Comments',
               'action': 'Pagination',
               'label': '/2016/12/azealia-banks-chickens/'
            });
        }];
    };
</script> <div class="ad_desktop" data-position='out_of_page' data-sizes='[[1,1]]' data-lazy-load='0' data-refresh='0' data-refresh-timer='0' data-swap='' data-load-order='3' data-out-of-page='true' style="display: none;">
</div>
<script>CLARITY.push({use:['ads'],run:function(Ads){Ads.site_code="vibe_2016";if(!Ads.zone){Ads.zone="article_page";}
var keywords=[];keywords.push({keywords:"",keyvalues:"category=music-news",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"tag=azealia-banks",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"post_id=477087",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"url=50c446d5",paths:"",positions:"all"});keywords.push({keywords:"",keyvalues:"pagetype=article_page",paths:"",positions:"all"});Ads.keywords=keywords;Ads.optionDefaults=Ads.optionDefaults||{};Ads.autoPopulate();}});</script> <script type="text/html" id="pe_zoom_overlay">
        <div class="pe-zoom-overlay scroll-<%= scroll_dir %>">
            <div class="image-holder">
                <img itemprop="image"
                     src="<%= img_src %>">
            </div>
            <div class="pe-zoom-close-x"></div>
        </div>
    </script><link rel='stylesheet' id='ad-css-css' href='http://assets.vibe.com/wp-content/plugins/wp-pi-clarity/css/clarity.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<link rel='stylesheet' id='zergnet-article-css-css' href='http://assets.vibe.com/wp-content/plugins/wp-pi-zergnet/css/article.css?ver=34665b63fdb18bcf80cf154251218b0326125a75' type='text/css' media='all'/>
<script type='text/javascript'>
/* <![CDATA[ */
var mobileDetect = {"isMobile":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/plugins/wp-pi-mobile-theme/js/mobile_detect.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/plugins/wp-ooyala-video/js/ooyala-posts.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/img-touch-canvas.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vibe.com/wp/wp-includes/js/wp-util.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/js/mobile-zoom.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-affiliate/js/amazon-widget.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-sponsored-content/js/interrupter/interrupter.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-spinmedia-core/js/vendor/lodash.2.4.1.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/themes/wp-theme-base/assets/js/all.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/themes/vibe/assets/js/all.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp/wp-includes/js/wp-embed.min.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/plugins/wp-pi-sharrre/js/jquery.sharrre.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-clarity/js/sticky.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-mainembed/js/photo-zoom.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.5.2","language":""},"disqusIdentifier":"477087 http:\/\/www.vibe.com\/?p=477087","disqusShortname":"vibe-spinmedia","disqusTitle":"Azealia Banks Says She\u2019s Been Sacrificing Chickens For Three Years","disqusUrl":"http:\/\/www.vibe.com\/2016\/12\/azealia-banks-chickens\/","options":{"manualSync":false},"postId":"477087"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript' src='http://assets.vibe.com/wp-content/plugins/wp-pi-campaign-monitor/js/campaign_monitor.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"vibe-spinmedia"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.vibe.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=34665b63fdb18bcf80cf154251218b0326125a75'></script>
</body>
</html>
