<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<title>
                            Waka Flocka Tells Daniel Caesar Never to Talk About Black American Again | Vibe
                    </title>
<meta name="article:modified_time" property="article:modified_time" content="2019-03-21T18:45:11-04:00" />
<meta name="article:published_time" property="article:published_time" content="2019-03-21T18:45:11-04:00" />
<meta name="description" property="description" content="Wak Flocka blasted Daniel Caesar for his viral race video and told him never to talk about black Americans again. " />
<meta name="og:description" property="og:description" content="Wak Flocka blasted Daniel Caesar for his viral race video and told him never to talk about black Americans again. " />
<meta name="og:image" property="og:image" content="https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079.jpg" />
<meta name="og:image:height" property="og:image:height" content="834" />
<meta name="og:image:width" property="og:image:width" content="1024" />
<meta name="og:title" property="og:title" content="Waka Flocka Tells Daniel Caesar Never to Talk About Black American Again" />
<meta name="og:type" property="og:type" content="article" />
<meta name="og:url" property="og:url" content="https://www.vibe.com/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people" />
<meta name="twitter:card" property="twitter:card" content="summary" />
<meta name="twitter:description" property="twitter:description" content="Wak Flocka blasted Daniel Caesar for his viral race video and told him never to talk about black Americans again. " />
<meta name="twitter:image" property="twitter:image" content="https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079.jpg" />
<meta name="twitter:title" property="twitter:title" content="Waka Flocka Calls Daniel Caesar &quot;Stupid&quot; For Viral Race Video" />
<meta name="twitter:site" content="@vibemagazine" />
<meta property="og:site_name" content="Vibe" />
<link href="https://fonts.googleapis.com/css?family=Barlow+Condensed:400,500,600|Barlow:400,700|Lora:400,400i,700,700i" rel="stylesheet">
<link rel="canonical" href="https://www.vibe.com/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people">
<link rel="amphtml" href="https://www.vibe.com/amp/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people">
<link rel="icon" href="/assets/images/favicon.ico?49607422109d1fafcc72" />
<link rel="shortcut icon" href="/assets/images/favicon.ico?49607422109d1fafcc72" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="/assets/images/favicon152.png?49607422109d1fafcc72">
<script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": "https://www.vibe.com/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people",
            "headline": "Waka Flocka Calls Daniel Caesar &quot;Stupid&quot; For Viral Race Video"
                            ,
                "image": {
                    "@type": "ImageObject",
                    "url": "https://static.vibe.com/files2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079.jpg",
                    "height": 834,
                    "width": 1024
                }
                        ,
            "publisher": {
                "@type": "Organization",
                "name": ""
                            },
            "author": [
                                    {
                    "@type": "Person",
                    "name": "Jessica McKinney"
                    }
                            ],
            "datePublished": "2019-03-21T18:45:11-04:00",
            "dateModified": "2019-03-21T18:45:11-04:00",
            "description": "&lt;p&gt;&quot;Don&#039;t you ever in your life talk about black people like that.&quot;&lt;/p&gt;
"
        }
    </script>
<script type="text/javascript">
        var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        contentHost: "https://www.vibe.com",
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.resolveOptAnon = (function() {
        var q = [], roa = function resolveOptAnon() { q.push(arguments) };
        roa.dump = function() {return q;};
        return roa;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "";
    PGM.blockScripts = false;

        PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1064px)"
    };
    PGM.social = {"facebook":{"site_name":"Vibe","account":"vibe"},"instagram":{"account":"vibemagazine"},"pinterest":{"account":"vibemagazine"},"snapchat":{"account":"vibemagazine"},"twitter":{"account":"vibemagazine"},"youtube":{"account":"vibemedia"}};
</script>
<script src="https://lib.pgmcdn.com/advertisement.js"></script>

<script type="text/javascript">
		    window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"valence.vibe\/%%device%%","zone":"","single_request_mode":false};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/clarity-1551363569129.min.js'; s.parentNode.insertBefore(ns, s);
})();
</script>
<script type="text/javascript">
    (function(){
    	// queue this up in case moat comes back before clarity loads
    	window.moatYieldReady = function() {
            CLARITY.push({
                use: ['header', 'logger'],
                run: function(header, logger) {
                    try {
                        header.partners.moat.setTargeting();
                    } catch (e) {
                        console.log(e);
                    }
                }
            });
        };

        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//sejs.moatads.com/billboardprebidheader946633233358/yi.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    apstag.init({
        pubID: 3125,
        adServer: 'googletag',
        videoAdServer: 'DFP',
        bidTimeout: 1000
    });

    // Tell Clarity not to load a9
    CLARITY.push({
        use: ['header'],
        run: function(header) {
            header.skipJsInject('a9');
        }
    });
</script>
<script>
            var rubicontag = rubicontag || {};
                rubicontag.cmd = rubicontag.cmd || [];

            // Load rubicon
            (function() {
                var account_id = 11872;
                var rct = document.createElement('script');
                    rct.type = 'text/javascript';
                    rct.async = true;
                    rct.src = (document.location.protocol === 'https:' ? 'https:' : 'http:') + '//ads.rubiconproject.com/header/' + account_id + '.js';
                var node = document.getElementsByTagName('script')[0];
                    node.parentNode.appendChild(rct);
            })();

            // Tell Clarity not to load Rubicon
            CLARITY.push({
                use: ['header'],
                run: function(header) {
                    header.skipJsInject('rubicon');
                }
            });
        </script>
<script>
                CLARITY.push({
                    use: ['header'],
                    run: function(header) {
                                                    var slotData = [
                                                                    ["leaderboard_atf_1", "6419/valence.vibe/%%device%%/", [[728,90],[970,250],[970,90]], "leaderboard_atf_1", {"1064":[[728,90],[970,250],[970,90]],"0":[[320,100],[320,50]],"768":[[728,90]]}, 0],                                                                    ["medrec_atf_1", "6419/valence.vibe/%%device%%/", [[300,250],[300,600]], "medrec_atf_1", {"0":[[300,250]],"768":[[300,250]],"1064":[]}, 0],                                                                    ["medrec_btf_1", "6419/valence.vibe/%%device%%/", [[300,250]], "medrec_btf_1", {"0":[[300,250]],"768":[[300,250]]}, 0],                                                                    ["medrec_atf_2", "6419/valence.vibe/%%device%%/", [[300,250],[300,600]], "medrec_atf_2", {"0":[],"768":[],"1064":[[300,250],[300,600]]}, 0],                                                                    ["medrec_btf_2", "6419/valence.vibe/%%device%%/", [[300,250]], "medrec_btf_2", {"0":[[300,250]],"768":[],"1064":[]}, 0],                                                                    ["medrec_btf_3", "6419/valence.vibe/%%device%%/", [[300,250]], "medrec_btf_3", {"0":[],"768":[],"1064":[[300,250]]}, 0]                                                            ];

                            // Add header slots then run,
                            // any slots added after initial run will be processed differently
                            for(var i=0; i<slotData.length; i++) {
                                header.addHeaderSlot.apply(header, slotData[i]);
                            }
                        
                        header.run({"a9":{"account_id":3125},"facebook":{"placementIds":{"^MB_[0-9]+":"367129333816375_367130120482963","^M_[0-9]+":"367129333816375_367129973816311"}},"moat":true,"rubicon":{"account_id":11872}});
                    }
                });
            </script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = {"ad_zone":"","targeting":{"env":"prod","ptype":"article","url":"1901480b","PID":"640540","keywords":"music-news,news,daniel-caesar,waka-flocka"},"slots":{"leaderboard_atf":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"leaderboard_atf","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]],"0":[[320,100],[320,50]],"768":[[728,90],[728,91]]},"defaultSizes":[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"0\":1,\"768\":1}"},"medrec_atf":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"medrec_atf","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[300,250],[300,251],[300,600]],"0":[[300,250],[300,251]],"768":[[300,250],[300,251]]},"defaultSizes":[[300,250],[300,251],[300,600]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"0\":1,\"768\":1}"},"medrec_btf":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"medrec_btf","outOfBody":null,"responsive":true,"sizeMapping":{"0":[[300,250]],"768":[[300,250]]},"defaultSizes":[[300,250]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":1,\"768\":1}"},"out_of_page":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"out_of_page","outOfBody":"1","responsive":false,"sizeMapping":{"0":[[1,1]]},"defaultSizes":[[1,1]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"},"promo":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"promo","outOfBody":null,"responsive":false,"sizeMapping":{"0":[[2,2],[3,3]]},"defaultSizes":[[2,2],[3,3]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"},"zergnet":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"zergnet","outOfBody":null,"responsive":false,"sizeMapping":{"0":[[4,4]]},"defaultSizes":[[4,4]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"}}};
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":1125911414,"default_player":"default"};

window.CLARITY = window.CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){
        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>

<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                        , 'contentId': '640540'

                    , 'contentType': 'article'

                    , 'author': 'Jessica McKinney'

                    , 'category': 'Music News'

                    , 'tags': 'daniel-caesar, waka-flocka'

                    , 'publishDate': '2019032118'

            
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-W3TLHV');
    </script>


<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<link rel="stylesheet" type="text/css" href="/assets/css/article.css?49607422109d1fafcc72">
<script type='text/javascript'>
                        var VB = VB || {};
            VB.config = VB.config || {
                contentHost: "https://www.vibe.com",
                mediaHost: "https://static.vibe.com/files"
            };
        </script>
</head>
<body class="page--article">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<div class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="/assets/images/logo/white.svg?49607422109d1fafcc72" alt="Vibe">
<span class="site-header__brand-name">Vibe</span>
</a>
</div>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item collapsed ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header__nav-link>News</a><span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header__subnav-link>Entertainment</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header__subnav-link>National</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header__subnav-link>Sports</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header__subnav-link>Events</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header__subnav-link>Movies &amp; TV</a> </li>
</ul>
</li>
<li class="site-header__nav-item collapsed ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header__nav-link>Music</a><span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header__subnav-link>Videos</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header__subnav-link>New Releases</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header__subnav-link>Live Reviews</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header__subnav-link>Album Reviews</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header__subnav-link>Music Premieres</a> </li>
</ul>
</li>
<li class="site-header__nav-item collapsed ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header__nav-link>Features</a><span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header__subnav-link>Digital Covers</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header__subnav-link>Opinion</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header__subnav-link>Lists</a> </li>
</ul>
</li>
<li class="site-header__nav-item collapsed ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style class=site-header__nav-link>Style</a><span class="carat"></span><ul class="site-header__subnav-items">
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;fashion class=site-header__subnav-link>Fashion</a> </li>
<li class="site-header__subnav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lifestyle class=site-header__subnav-link>Lifestyle</a> </li>
</ul>
</li>
<li class="site-header__nav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen class=site-header__nav-link>Vixen</a><span class="carat"></span> </li>
<li class="site-header__nav-item  ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva class=site-header__nav-link>Viva</a><span class="carat"></span> </li>
</ul>
<div class="site-header-search site-header-search--mobile js-search-form">
<form class="site-header-search__form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header-search__input js-search-input" placeholder="Search For..." name="keys" maxlength="255">
<input type="submit" value="GO" id="site-header-search__submit" class="site-header-search__submit js-search-submit">
</form>
</div>
<div class="site-header__follow-newsletter-holder">
<div class="site-header-follow">
<h3 class="site-header-follow__title">Follow Vibe</h3>
<ul class="header__social-links">
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<div class="email-subscribe-holder email-subscribe--wide" data-content-type="emailSubscribe">
<div class="email-subscribe email-subscribe--wide email-subscribe--has-title">
<h3 class="email-subscribe__title">
The Vibe Mix Newsletter
</h3>
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<strong>Whoops!</strong>
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="customerId" value="1c863b713365e9d3e9efb90fcc6c4fc5" />
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-menu" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </div>
</div>
</nav>
<form class="site-header__search-form site-header__search-form--main js-search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input js-search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit js-search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<nav class="site-header-links">
<div class="site-header-links__contents">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header-links__link>Entertainment</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header-links__link>National</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header-links__link>Sports</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header-links__link>Events</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header-links__link>Movies &amp; TV</a> </div>
</nav>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-leaderboard_atf ' id="leaderboard_atf_1" data-position='leaderboard_atf_1' data-slot-name="leaderboard_atf" data-sizes='[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]]' data-size-mapping='{"1064":[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]],"0":[[320,100],[320,50]],"768":[[728,90],[728,91]]}' data-lazy-load='{&quot;1064&quot;:1,&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;1064&quot;:0,&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;1064&quot;:0,&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Top Banner Ad" data-tracklabel="Ad Click">
</div>
<div class='ad_desktop dfp-ad dfp-ad-out_of_page ' id="out_of_page_1" data-position='out_of_page_1' data-slot-name="out_of_page" data-sizes="[[1,1]]" data-out-of-page="true" data-lazy-load='{&quot;0&quot;:0}' data-refresh='{&quot;0&quot;:0}' data-refresh-timer='{&quot;0&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="" data-tracklabel="Ad Click">
</div>
</div>
</div>
</div>
</div>
<main id="main" class="container container--article">
<div class="section-holder col-holder">
<section class="main-well col-holder__left-col js-mainWell">
<article class="article__content-well article__content-well--  js-revarticle url-breadcrumb is-active " data-id="640540" data-url-breadcrumb="/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people" data-content-type="article" data-page-title="Waka&#x20;Flocka&#x20;Tells&#x20;Daniel&#x20;Caesar&#x20;Never&#x20;to&#x20;Talk&#x20;About&#x20;Black&#x20;American&#x20;Again&#x20;&#x7C;&#x20;Vibe" data-canonical="https://www.vibe.com/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people" data-chartbeatSection="" data-analytics-category="Music News" data-analytics-tags="Daniel Caesar, waka flocka">
<figure class="main-media main-media--videoEmbed  main-media--" data-media-type="videoEmbed" data-media-id="" data-content-type="expandableImage">
<div class="main-media__video-embed">
<iframe width="560" height="315" data-src="https://www.youtube.com/embed/s1WxMDsGKfw" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</figure>
<div class="article__header">
<h1 class="article__headline">Waka Flocka Calls Daniel Caesar &quot;Stupid&quot; For Viral Race Video</h1>
<p class="article__meta">
<span class="js-publish-date article__publish-date" data-pubdate-value="2019032118">
March 21, 2019 - 6:45 pm
</span>
by
<span class="js-authors-list">
<span class="author">
<a href="/author/jmckinney" class="article__author-link">Jessica McKinney</a>
</span> <span class="social-share">
<span class="social-share__item">
<a class="social-share__link social-share__link--twitter fa fa-twitter" target="_blank" href="https://www.twitter.com/@jigga_jess">
<span>TWITTER</span>
</a>
</span>
</span>
</span>
</p>
</div>
<div class="article__body js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-medrec_atf ' id="medrec_atf_1" data-position='medrec_atf_1' data-slot-name="medrec_atf" data-sizes='[[300,250],[300,251],[300,600]]' data-size-mapping='{"0":[[300,250],[300,251]],"768":[[300,250],[300,251]],"1064":[]}' data-lazy-load='{&quot;1064&quot;:1,&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;1064&quot;:1,&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;1064&quot;:30,&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Medrec ATF" data-tracklabel="Ad Click">
</div>
<div class="article__deck">
<p>"Don't you ever in your life talk about black people like that."</p>
</div>
<p><a href="https://www.vibe.com/tag/daniel-caesar" target="_blank" rel="noopener">Daniel Caesar</a> landed in the hot seat this week when he shared a video on Instagram Live that appeared to reprimand black people for being "too sensitive."  Many critics had plenty of rebuttals to Caesar's comments, but according to <a href="https://www.vibe.com/tag/waka-flocka" target="_blank">Waka Flocka</a> and his wife Tammy Rivera, it's pretty simple: don't talk about black people ever again.</p>
<p><em>TMZ</em> caught up with the couple on Wednesday (Mar. 20). "He said 'get over it'? Yo, make sure you stay the fuck away from me because we might 'get over' on yo' ass. Don't you ever in your life talk about black people like that. You stupid," Waka said. The rapping was referring to Caesar's nationality.</p>
<div class="embedded-content" data-template="readmore" data-amp-enabled="1"><script type="application/json">{"nid":"640174","type":"post","title":"Daniel Caesar Questions Why Are &quot;We Being So Mean To Julz?&quot; On IG Live","relative_path":"\/2019\/03\/daniel-caesar-defends-yes-julz\/","media":{"width":5098,"height":3399,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/03\/daniel-caesar-defends-yes-juelz-ig-live-1553092567.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/daniel-caesar-defends-yes-juelz-ig-live-1553092567-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/daniel-caesar-defends-yes-juelz-ig-live-1553092567-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"640200","caption":null,"credit":null}}</script></div>
<p>Rivera then chimed in: "He's from Canada, okay so he doesn't know what's going on. He's Canadian. Tell him to drive down the street in a car and speed and get pulled over by two white cops then he'll figure out why."</p>
<p>As previously reported, Caesar's <a href="https://www.vibe.com/2019/03/daniel-caesar-defends-yes-julz/" target="_blank" rel="noopener">livestream</a> specifically addressed the recent conversation surrounding social media star YesJulz and her position in hip-hop culture (she was criticized for mentioning black professionals including Scottie Beam and Karen Civil during an interview). In the video, the "Best Part" singer seemingly defended YesJulz and suggested that the black people learn how to take a joke.</p>
<div class='ad_desktop dfp-ad dfp-ad-medrec_btf ' id="medrec_btf_1" data-position='medrec_btf_1' data-slot-name="medrec_btf" data-sizes='[[300,250]]' data-size-mapping='{"0":[[300,250]],"768":[[300,250]]}' data-lazy-load='{&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="" data-tracklabel="Ad Click">
</div>
<p>"Why is it that we're allowed to be disrespectful and rude to everybody else and when anybody else returns any type of energy to us—that's not equality," he said in the livestream. "I don't wanna be treated like I can't take a joke."</p>
<p>Watch Waka Flocka and Tammy Riveras' comments on Daniel Caesar in the video above.</p>
</div>
<div class="article__bottom">
<div class="article__bottom-left">
<div class="article__tags">
<span class="article__tags-pre">In This Story:</span>
<ul class="article__tags-holder">
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;daniel-caesar>Daniel Caesar</a>, </li>
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;waka-flocka>waka flocka</a> </li>
</ul>
</div>
</div>
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa fa-facebook" data-pgm-share="facebook" data-pgm-title="Waka&#x20;Flocka&#x20;Calls&#x20;Daniel&#x20;Caesar&#x20;&quot;Stupid&quot;&#x20;For&#x20;Viral&#x20;Race&#x20;Video" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2019&#x2F;03&#x2F;waka-flocka-tells-daniel-caesar-never-talk-black-people" href="javascript:void(0);">
<span>FACEBOOK</span>
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa fa-twitter" data-pgm-share="twitter" data-pgm-title="Waka&#x20;Flocka&#x20;Calls&#x20;Daniel&#x20;Caesar&#x20;&quot;Stupid&quot;&#x20;For&#x20;Viral&#x20;Race&#x20;Video" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2019&#x2F;03&#x2F;waka-flocka-tells-daniel-caesar-never-talk-black-people" href="javascript:void(0);">
<span>TWITTER</span>
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa fa-envelope" data-pgm-title="Waka&#x20;Flocka&#x20;Calls&#x20;Daniel&#x20;Caesar&#x20;&quot;Stupid&quot;&#x20;For&#x20;Viral&#x20;Race&#x20;Video" href="/cdn-cgi/l/email-protection#f5ca979a918cc89d81818586d3d68dc6b4ced3d68dc7b3ced3d68dc7b3ce828282db839c9790db969a98d3d68dc7b3cec7c5c4ccd3d68dc7b3cec5c6d3d68dc7b3ce82949e94d893999a969e94d88190999986d891949b9c9099d8969490869487d89b90839087d88194999ed8979994969ed885909a859990d38680979f909681c8a2949e94d3d68dc7c5ceb3999a969e94d3d68dc7c5ceb694999986d3d68dc7c5ceb1949b9c9099d3d68dc7c5ceb69490869487d3d68dc7c5ced384809a81cea68180859c91d384809a81ced3d68dc7c5ceb39a87d3d68dc7c5cea39c879499d3d68dc7c5cea7949690d3d68dc7c5cea39c91909a">
<span>EMAIL ME</span>
</a>
</li>
</ul>
</div>

<div class="js-ad-pageTargeting">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json">
        {
                            "env": "prod",
                            "ptype": "article",
                            "url": "1901480b",
                            "PID": "640540",
                            "keywords": "music-news,news,daniel-caesar,waka-flocka"
                    }
        </script>
</div>
</article>
</section>
<section class="col-holder__right-col hide-small hide-medium" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-medrec_atf ' id="medrec_atf_2" data-position='medrec_atf_2' data-slot-name="medrec_atf" data-sizes='[[300,250],[300,251],[300,600]]' data-size-mapping='{"0":[],"768":[],"1064":[[300,250],[300,251],[300,600]]}' data-lazy-load='{&quot;1064&quot;:1,&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;1064&quot;:1,&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;1064&quot;:30,&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Medrec ATF" data-tracklabel="Ad Click">
</div>
</div>
<div class="section-title-holder ">
<h2 class="section-title">
Popular
</h2>
</div>
<div class="feed feed--sidebar">
<div class="feed-post-sidebar
    
    feed-post--article
    ">
<a href="/2019/03/jay-z-blueprint-inducted-library-congress-recording-registry" alt="Jay-Z&#039;s &#039;The Blueprint&#039; Album To Be Inducted Into The Library Of Congress" class="feed-post__image-holder feed-post-sidebar__image-holder">
<img src="https://static.vibe.com/files/2019/03/Blueprint-1553095178-300x169.jpg" srcset="https://static.vibe.com/files/2019/03/Blueprint-1553095178-300x169.jpg 300w, https://static.vibe.com/files/2019/03/Blueprint-1553095178-602x339.jpg 602w" class="feed-post-sidebar__image" alt="">
</a>
<div class="feed-post-sidebar__info">
<a href="/2019/03/jay-z-blueprint-inducted-library-congress-recording-registry" class="feed-post-sidebar__title-link">
<h2 class="feed-post-sidebar__title">
Jay-Z&#039;s &#039;The Blueprint&#039; Album To Be Inducted Into The Library Of Congress
</h2>
</a>
</div>
</div>
</div>
</div>
<div class="email-subscribe-holder " data-content-type="emailSubscribe">
<div class="section-title-holder ">
<h2 class="section-title">
The Vibe Mix Newsletter
</h2>
</div>
<div class="email-subscribe  ">
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<strong>Whoops!</strong>
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="customerId" value="1c863b713365e9d3e9efb90fcc6c4fc5" />
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-article" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </section>
</div>
<div class="section-holder col-holder section-holder--next-up">
<section class="col-holder__left-col left-col--next-up">
<div class='ad_desktop dfp-ad dfp-ad-zergnet ' id="zergnet_1" data-position='zergnet_1' data-slot-name="zergnet" data-sizes='[[4,4]]' data-size-mapping='[[[4,4]]]' data-lazy-load='{&quot;0&quot;:0}' data-refresh='{&quot;0&quot;:0}' data-refresh-timer='{&quot;0&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Zergnet" data-tracklabel="Ad Click">
</div>
<div class="section-title-holder section-title-holder--zergnet">
<h2 class="section-title">
From the Web
</h2>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="next-up-holder">
<div class="section-title-holder section-title-holder--next-up">
<h2 class="section-title">
More on Vibe
</h2>
</div>
<div class="article-next-up">
<figure class="main-media main-media--videoEmbed  main-media--" data-media-type="videoEmbed" data-media-id="">
<div class="main-media__video-embed">
<iframe width="560" height="315" data-src="https://www.youtube.com/embed/1p6h6xykERM" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</figure>
<div class="article-next-up__header">
<a href="/2019/03/kodak-black-just-bullshittin-young-ma-comments" class="article-next-up__link">
<h2 class="article-next-up__title">
Kodak Black Says He Was &quot;Just Bullsh*ttin&#039;&quot; About Young M.A. Comments
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Kodak Black received backlash earlier this week after he attempted to make advances at Young M.A. After she rejected him, he then appeared to take jabs at her sexual orientation. Now, the Florida native has come forward, stating that he was "just bullsh*ttin'" about his previous comments.</p>
<p>"Bruh, be realistic. I am too fly for that shit. And I got too much 'resources' to go that route," Kodak said addressing the controversy on Instagram Live on Thursday (Mar. 21). "I was just bullshittin', man," the rapper joked. "I know I be jiving. I be jiving around and shit like that y'all know me. And leave her alone!.. Lot of people be sensitive on the internet and in life. People go to saying crazy shit... like come on now."</p>
<script type="application/json">{"nid":"640420","type":"post","title":"Kodak Black Says We Need To Put Him Among The Greats Like Tupac, Biggie And Nas","relative_path":"\/2019\/03\/kodak-black-tupac-biggie-nas-comments\/","media":{"width":8256,"height":5504,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/03\/kodak-black-same-level-as-tupac-1553181861.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/kodak-black-same-level-as-tupac-1553181861-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/kodak-black-same-level-as-tupac-1553181861-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"640426","caption":null,"credit":null}}</script>
<p>As previously reported, Kodak was accused of sexual harassment for making suggesting comments about Young M.A. on his song "Pimpin' Ain't Easy." After the Brooklyn artist responded, he questioned her sexual preferences. "How you a girl but don't want your p***y penetrated? How?" He asked. "Don't be mad at me because I want you, baby. Don't be mad at me cuz I want you."</p>
<p>Kodak didn't waste any time moving on to the next troll though. The rapper recorded a new Instagram Live earlier claiming to be on the same level as Biggi, Tupac, and Nas. "I'm the hardest rapper in the game I promise," Kodak said. "Like, when you talk 'bout me, you should put me in a category of like 'Pac, B.I.G, Nas, them n***s, you feel me? Like really listen to my shit. I don't care about how I act, like, on the 'gram."</p>
<p>Watch his latest comments in the video above.</p>
</div>
<a class="article-next-up__continue" href="/2019/03/kodak-black-just-bullshittin-young-ma-comments">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame" alt="Michael Jackson Will Remain In Rock And Roll Hall Of Fame Despite Allegations">
<img src="https://static.vibe.com/files/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame-1553206565-650x366.jpg" srcset="https://static.vibe.com/files/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame-1553206565-650x366.jpg 650w, https://static.vibe.com/files/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame-1553206565-768x432.jpg 768w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Michael Jackson HIStory World Tour">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Phil Walter</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Michael Jackson HIStory World Tour"></div> </figure>
<div class="article-next-up__header">
<a href="/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame" class="article-next-up__link">
<h2 class="article-next-up__title">
Michael Jackson Will Remain In Rock And Roll Hall Of Fame Despite Allegations
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Michael Jackson will remain in the Rock &amp; Roll Hall of Fame, despite the child abuse allegations that recently resurfaced as part of HBO's Leaving Neverland documentary, TMZ reports.</p>
<p>MJ's name or memorabilia will not be removed from the Ohio exhibit, according to the celebrity site.</p>
<script type="application/json">{"nid":"639913","type":"post","title":"Michael Jackson Artifacts Removed From World&#x27;s Largest Children&#x27;s Museum","relative_path":"\/2019\/03\/michael-jackson-childrens-museum-removal\/","media":{"width":3000,"height":2032,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/03\/mj-artifacts-childrens-museum-1552951854.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/mj-artifacts-childrens-museum-1552951854-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/mj-artifacts-childrens-museum-1552951854-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"639914","caption":null,"credit":null}}</script>
<p>A committee of historians, musicians, and music executives voted Jackson into the hall of fame twice. He was voted in as a member of the Jackson 5 in 1997 and again as a solo artist in 2001.  Sources close to the committee said the late entertainer was recognized for his musical excellence and talent; his personal life does not play a factor in his standing with the hall of fame.</p>
<p>While his legacy will remain intact at the Rock &amp; Roll of Fame, other organizations, exhibits, fashion brands, and radio stations have already begun pulling Jackson's content. Just recently, the Children’s Museum of Indianapolis withdrew three artifacts from its exhibit in the wake of Leaving Neverland's testimonies from alleged victims Wade Robson and James Safechuck.</p>
<p>Janet Jackson, Michael little sister, will be inducted into the hall of fame later this month, and there's speculation about whether she will mention her MJ during her acceptance speech. The induction ceremony will take place on Mar. 29.</p>
</div>
<a class="article-next-up__continue" href="/2019/03/michael-jackson-to-remain-rock-roll-hall-of-fame">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-medrec_btf ' id="medrec_btf_2" data-position='medrec_btf_2' data-slot-name="medrec_btf" data-sizes='[[300,250]]' data-size-mapping='{"0":[[300,250]],"768":[],"1064":[]}' data-lazy-load='{&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Medrec BTF" data-tracklabel="Ad Click">
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2019/03/r-kelly-travel-to-dubai-perform-child-suppoprt" alt="R. Kelly Is Seeking Permission To Perform Overseas In Order To Pay Child Support">
<img src="https://static.vibe.com/files/2019/03/rkelly-requesting-travel-pay-child-support-1553182872-650x366.jpg" srcset="https://static.vibe.com/files/2019/03/rkelly-requesting-travel-pay-child-support-1553182872-650x366.jpg 650w, https://static.vibe.com/files/2019/03/rkelly-requesting-travel-pay-child-support-1553182872-1500x844.jpg 1500w, https://static.vibe.com/files/2019/03/rkelly-requesting-travel-pay-child-support-1553182872-768x432.jpg 768w, https://static.vibe.com/files/2019/03/rkelly-requesting-travel-pay-child-support-1553182872-1536x864.jpg 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="rkelly-appearing-chicago-court">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Nuccio DiNuzzo</div>
</figcaption>
<div class="expanded-image__target" data-sources='[{"size":"320x213","url":"https:\/\/static.vibe.com\/files\/2019\/03\/rkelly-requesting-travel-pay-child-support-1553182872-320x213.jpg"}]' data-alt-text="rkelly-appearing-chicago-court"></div> </figure>
<div class="article-next-up__header">
<a href="/2019/03/r-kelly-travel-to-dubai-perform-child-suppoprt" class="article-next-up__link">
<h2 class="article-next-up__title">
R. Kelly Is Seeking Permission To Perform Overseas In Order To Pay Child Support
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>R. Kelly's legal team is hoping a Cook County judge will grant the singer permission to travel overseas and perform in order to pay off his child support fees.</p>
<p>According to the Chicago Tribune, the 52-year-old singer signed a contract prior to his recent arrest, which outlined Kelly would perform three to five shows in Dubai and travel by private jet. He's slated to meet the royal family and the concert promoter is paying the expenses. Since being charged with 10 counts of aggravated criminal sexual abuse, Kelly cannot leave Illinois and has handed over his passport.</p>
<p>The singer's lawyer argues Kelly isn't a flight risk and as an entertainer should be granted permission to still work in order to pay off his debt.</p>
<p>“Mr. Kelly has a job that requires he be allowed to travel,” Steven Greenberg argued in Wednesday's court filing. “He cannot work, and consequently cannot make a living if he is confined to Illinois or even the United States.”</p>
<p>Greenberg noted Kelly isn't a flight risk and appeared in court in 2008 when he faced child pornography charges. The singer was found not guilty in that case.</p>
<p>“Denying him the opportunity to work would be a hardship on his children,” Greenberg later wrote.</p>
<p>In January, Lifetime aired a searing docuseries titled Surviving R. Kelly, which detailed years of sexual assault allegations from several of his alleged victims including Lisa Van Allen and ex-wife Andrea Kelly.</p>
<p>Kelly reportedly owes $161,000 in child support and alleges to have fallen on hard times due to renewed attacks. Last month the Grammy-award winner was indicted on charges he abused three girls and one woman over the span of a decade. The singer vehemently denied the accusations and pled not guilty.</p>
<p>Greenberg also attacked State's Attorney Kim Foxx's intentions behind pursuing Kelly's 10 counts.</p>
<p>“Most if not all of these allegations were all investigated years ago, and charges were not brought,” Greenberg wrote. “There is little if anything that has changed other than State’s Attorney’s desire to thrust herself into the spotlight of the #metoo movement.”</p>
<script type="application/json">{"nid":"639400","type":"post","title":"R. Kelly&#x27;s Request To Reduce Child Support Payments Denied","relative_path":"\/2019\/03\/r-kelly-child-support-reduction-denied\/","media":{"width":3000,"height":2003,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/03\/r-kelly-child-support-payments-reduction-deny-1552507883.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/r-kelly-child-support-payments-reduction-deny-1552507883-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/03\/r-kelly-child-support-payments-reduction-deny-1552507883-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"639405","caption":null,"credit":null}}</script>
</div>
<a class="article-next-up__continue" href="/2019/03/r-kelly-travel-to-dubai-perform-child-suppoprt">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
</div>
</section>
<section class="col-holder__right-col" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-medrec_btf ' id="medrec_btf_3" data-position='medrec_btf_3' data-slot-name="medrec_btf" data-sizes='[[300,250]]' data-size-mapping='{"0":[],"768":[],"1064":[[300,250]]}' data-lazy-load='{&quot;0&quot;:1,&quot;768&quot;:1}' data-refresh='{&quot;0&quot;:0,&quot;768&quot;:0}' data-refresh-timer='{&quot;0&quot;:0,&quot;768&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="Medrec BTF" data-tracklabel="Ad Click">
</div>
</div>
</div>
</section>
</div>
<div class="section-holder">
<div class="section-title-holder ">
<h2 class="section-title">
Top Stories
</h2>
</div>
<div class="feed feed--one-third feed--footer-recommended">

<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people/" alt="Waka Flocka Calls Daniel Caesar &quot;Stupid&quot; For Viral Race Video" class="feed-post__image-holder feed-post-third__image-holder">
<img src="https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079-240x135.jpg" srcset="https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079-240x135.jpg 240w, https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079-602x339.jpg 602w, https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079-320x180.jpg 320w, https://static.vibe.com/files/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people-1553208079-650x366.jpg 650w" class="feed-post-third__image" alt="">
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-news>Music News</a> </h3>
<span class="feed-post-third__date">
8h ago
</span>
<a href="/2019/03/waka-flocka-tells-daniel-caesar-never-talk-black-people/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Waka Flocka Calls Daniel Caesar &quot;Stupid&quot; For Viral Race Video
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2019/03/elton-john-a-tribe-called-quest-fan/" alt="Sir Elton John Dubs Q-Tip A Hip-Hop Legend: Listen" class="feed-post__image-holder feed-post-third__image-holder">
<img src="https://static.vibe.com/files/2019/03/elton-john-a-tribe-called-quest-fan-1553121592-240x135.jpg" srcset="https://static.vibe.com/files/2019/03/elton-john-a-tribe-called-quest-fan-1553121592-240x135.jpg 240w, https://static.vibe.com/files/2019/03/elton-john-a-tribe-called-quest-fan-1553121592-602x339.jpg 602w, https://static.vibe.com/files/2019/03/elton-john-a-tribe-called-quest-fan-1553121592-320x180.jpg 320w, https://static.vibe.com/files/2019/03/elton-john-a-tribe-called-quest-fan-1553121592-650x366.jpg 650w" class="feed-post-third__image" alt="">
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </h3>
<span class="feed-post-third__date">
1d ago
</span>
<a href="/2019/03/elton-john-a-tribe-called-quest-fan/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Sir Elton John Dubs Q-Tip A Hip-Hop Legend: Listen
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2019/03/kevin-hart-netflix-special-trailer/" alt="Kevin Hart Debuts Trailer For Netflix Comedy Special &#039;Irresponsible&#039;" class="feed-post__image-holder feed-post-third__image-holder">
<img src="https://static.vibe.com/files/2019/03/kevin-hart-stand-up-netflix-1553183713-240x135.jpg" srcset="https://static.vibe.com/files/2019/03/kevin-hart-stand-up-netflix-1553183713-240x135.jpg 240w, https://static.vibe.com/files/2019/03/kevin-hart-stand-up-netflix-1553183713-602x339.jpg 602w, https://static.vibe.com/files/2019/03/kevin-hart-stand-up-netflix-1553183713-320x180.jpg 320w, https://static.vibe.com/files/2019/03/kevin-hart-stand-up-netflix-1553183713-650x366.jpg 650w" class="feed-post-third__image" alt="">
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv>Movies &amp; TV</a> </h3>
<span class="feed-post-third__date">
15h ago
</span>
<a href="/2019/03/kevin-hart-netflix-special-trailer/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Kevin Hart Debuts Trailer For Netflix Comedy Special &#039;Irresponsible&#039;
</h2>
</a>
</div>
</div>
</div>
</div>
</main>
<footer class="page-footer">
<div class="container">
<div class="footer__header">
<div class="footer__social-holder">
<ul class="footer__social-links">
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<a href="/" class="footer__logo-holder">
</a>
</div>
<ul class="footer__main-menu">
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news>News</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features>Features</a> </li>
 <li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style>Style</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen>Vixen</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva>Viva</a> </li>
<li class="footer__main-menu-link-holder">
<a href=mailto&#x3A;tips&#x40;vibe.com>Contact Us</a> </li>
</ul>
<p class="footer__member">
Vibe.com is an affiliate site of Billboard, a subsidiary of Prometheus Global Media, LLC. </p>
<ul class="footer__secondary-menu">
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;privacy-policy&#x2F;>Privacy Policy</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;about-our-ads&#x2F;>Ad Choices</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;copyright&#x2F;>Copyright</a> </li>
</ul>
<ul class="footer__site-links">
<li class="footer__site-links-link-holder">
<a href="https://www.billboard.com/" target="_blank">Billboard</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a>
</li>
<li class="footer__site-links--mobile-separator"></li>
<li class="footer__site-links-link-holder">
<a href="https://www.spin.com/" target="_blank">SPIN</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.vibe.com/">VIBE</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.stereogum.com/" target="_blank">Stereogum</a>
</li>
</ul>
</div>
</footer>
<div class='ad_desktop dfp-ad dfp-ad-promo ' id="promo_1" data-position='promo_1' data-slot-name="promo" data-sizes='[[2,2],[3,3]]' data-size-mapping='[[[2,2],[3,3]]]' data-lazy-load='{&quot;0&quot;:0}' data-refresh='{&quot;0&quot;:0}' data-refresh-timer='{&quot;0&quot;:0}' data-targeting='null' data-ad-unit='6419/valence.vibe/%%device%%/' data-trackaction="" data-tracklabel="Ad Click">
</div>
<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    CLARITY.push({
        use: ['ads', 'cookies', 'header'],
        run: function(Ads, cookies, header) {
            Ads.site_code = "valence.vibe/%%device%%";
            Ads.zone = "";

            var keywords = [];
            var region = cookies.get('PGMCC') ? cookies.get('PGMCC') : '';

            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "ptype=article",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "url=1901480b",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "PID=640540",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "keywords=music-news,news,daniel-caesar,waka-flocka",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.vibe.com",
                    paths: "",
                    positions: "all"
                });
            
            keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            })

            Ads.keywords = keywords;

            Ads.autoPopulate();

                    }
    });
</script>
<script type="text/javascript" src="/assets/js/commons.bundle.js?49607422109d1fafcc72"></script>
<script type="text/javascript" src="/assets/js/article.bundle.js?49607422109d1fafcc72"></script>
<script type="text/javascript" src="/assets/js/legacy.js?49607422109d1fafcc72"></script>
</body>
</html>
