<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<title>
                            BET Invites Donald Trump, Joe Biden To Juneteenth Forum | Vibe
                    </title>
<meta name="article:modified_time" property="article:modified_time" content="2020-06-06T10:02:43-04:00" />
<meta name="article:published_time" property="article:published_time" content="2020-06-05T20:44:16-04:00" />
<meta name="description" property="description" content="The TV special is scheduled to air on June 19, and will discuss a range of topics including systematic racism and the &quot;concerns of Black America.&quot; " />
<meta name="og:description" property="og:description" content="The TV special is scheduled to air on June 19, and will discuss a range of topics including systematic racism and the &quot;concerns of Black America.&quot; " />
<meta name="og:image" property="og:image" content="https://static.vibe.com/files/2020/06/trump-biden-1591403246-1024x951.jpg" />
<meta name="og:image:height" property="og:image:height" content="951" />
<meta name="og:image:width" property="og:image:width" content="1024" />
<meta name="og:title" property="og:title" content="BET Invites Donald Trump And Joe Biden To Appear In Juneteenth Special" />
<meta name="og:type" property="og:type" content="article" />
<meta name="og:url" property="og:url" content="https://www.vibe.com/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special" />
<meta name="twitter:card" property="twitter:card" content="summary" />
<meta name="twitter:description" property="twitter:description" content="The TV special is scheduled to air on June 19, and will discuss a range of topics including systematic racism and the &quot;concerns of Black America.&quot; " />
<meta name="twitter:image" property="twitter:image" content="https://static.vibe.com/files/2020/06/trump-biden-1591403246-1024x951.jpg" />
<meta name="twitter:title" property="twitter:title" content="BET Invites Donald Trump And Joe Biden To Appear In Juneteenth Special" />
<meta name="twitter:site" content="@vibemagazine" />
<meta property="og:site_name" content="Vibe" />
<link href="https://fonts.googleapis.com/css?family=Barlow+Condensed:400,500,600|Barlow:400,700|Lora:400,400i,700,700i" rel="stylesheet">
<link rel="canonical" href="https://www.vibe.com/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special">
<link rel="amphtml" href="https://www.vibe.com/amp/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special">
<link rel="icon" href="/assets/images/favicon.ico?0cd0b31e24683c892ef3" />
<link rel="shortcut icon" href="/assets/images/favicon.ico?0cd0b31e24683c892ef3" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="/assets/images/favicon152.png?0cd0b31e24683c892ef3">
<link rel="dns-prefetch" href="https://www.google-analytics.com/">
<link rel="dns-prefetch" href="https://www.googletagservices.com/">
<link rel="dns-prefetch" href="https://www.googletagmanager.com/">
<link rel="dns-prefetch" href="https://www.instagram.com/">
<link rel="dns-prefetch" href="https://www.zergnet.com/">
<link rel="dns-prefetch" href="https://players.brightcove.net/">
<link rel="dns-prefetch" href="https://platform.zig.com/">
<link rel="dns-prefetch" href="https://www.googleadservices.com">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com/">
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net/">
<link rel="dns-prefetch" href="https://cdn.krxd.net/">
<link rel="dns-prefetch" href="https://beacon.krxd.net/">
<link rel="dns-prefetch" href="https://a.quora.com/">
<link rel="dns-prefetch" href="https://connect.facebook.net/">
<link rel="dns-prefetch" href="https://s0.2mdn.net/">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com">
<link rel="dns-prefetch" href="https://sejs.moatads.com/">
<link rel="dns-prefetch" href="https://mb.moatads.com/">
<link rel="dns-prefetch" href="https://tags.bluekai.com/">
<link rel="dns-prefetch" href="https://platform.twitter.com/">
<link rel="dns-prefetch" href="https://analytics.twitter.com/">
<link rel="dns-prefetch" href="https://lib.pgmcdn.com">
<script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": "https://www.vibe.com/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special",
            "headline": "BET Invites Donald Trump And Joe Biden To Appear In Juneteenth Special"
                            ,
                "image": {
                    "@type": "ImageObject",
                    "url": "https://static.vibe.com/files2020/06/trump-biden-1591403246.jpg",
                    "height": 3030,
                    "width": 3264
                }
                        ,
            "publisher": {
                "@type": "Organization",
                "name": ""
                            },
            "author": [
                                    {
                    "@type": "Person",
                    "name": "VIBE Staff"
                    }
                            ],
            "datePublished": "2020-06-05T20:44:16-04:00",
            "dateModified": "2020-06-06T10:02:43-04:00",
            "description": "The special forum will discuss a range of topics including systematic racism."
        }
    </script>
<script type="text/javascript">
        var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        assetHost: "/assets",
        contentHost: "https://www.vibe.com",
        sailthruCustomerId: ""
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.resolveOptAnon = (function() {
        var q = [], roa = function resolveOptAnon() { q.push(arguments) };
        roa.dump = function() {return q;};
        return roa;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.enableDeferredAds = false;
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "";
    PGM.blockScripts = false;

        PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1064px)"
    };
    PGM.social = {"facebook":{"site_name":"Vibe","account":"vibe"},"instagram":{"account":"vibemagazine"},"pinterest":{"account":"vibemagazine"},"snapchat":{"account":"vibemagazine"},"twitter":{"account":"vibemagazine"},"youtube":{"account":"vibemedia"}};

    PGM.greCaptchaSiteKey = "6Lfc66MUAAAAAA3lW9bTwbc_vy17EsFlueLHQjze";
</script>
<script src="https://lib.pgmcdn.com/advertisement.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js" async defer></script>

<script type="text/javascript">
    window.top.DarkMatter = window.top.DarkMatter || {};
    window.top.DarkMatter.cmd = window.top.DarkMatter.cmd || [];

            window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"valence.vibe\/%%device%%","zone":"news","single_request_mode":true};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//lib.pgmcdn.com/dark-matter-03a8b13.min.js'; s.parentNode.insertBefore(ns, s);
})();
</script>
<script type="text/javascript">
    (function(){
    	// queue this up in case moat comes back before clarity loads
    	window.moatYieldReady = function() {
            CLARITY.push({
                use: ['header', 'logger'],
                run: function(header, logger) {
                    try {
                        header.partners.moat.setTargeting();
                    } catch (e) {
                        console.log(e);
                    }
                }
            });
        };

        var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
        ns.async = true; ns.type = 'text/javascript'; ns.src = '//sejs.moatads.com/billboardprebidheader946633233358/yi.js'; s.parentNode.insertBefore(ns, s);
    })();
</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    apstag.init({
        pubID: 3125,
        adServer: 'googletag',
        videoAdServer: 'DFP',
        bidTimeout: 1000
    });

    // Tell Clarity not to load a9
    CLARITY.push({
        use: ['header'],
        run: function(header) {
            header.skipJsInject('a9');
        }
    });
</script>
<script>
                CLARITY.push({
                    use: ['header'],
                    run: function(header) {
                                                    var slotData = [
                                                                    ["leaderboard_ad_1", "6419/valence.vibe/%%device%%/", [[728,90],[970,250],[970,90]], "leaderboard_ad_1", {"1064":[[728,90],[970,250],[970,90]],"0":[[320,100],[320,50]],"768":[[728,90]]}, 0],                                                                    ["contentwell_ad_1", "6419/valence.vibe/%%device%%/", [[300,250]], "contentwell_ad_1", {"1064":[[300,250]],"0":[[300,250]],"768":[[300,250]]}, 0],                                                                    ["contentwell_ad_2", "6419/valence.vibe/%%device%%/", [[300,250]], "contentwell_ad_2", {"1064":[[300,250]],"0":[[300,250]],"768":[[300,250]]}, 0],                                                                    ["rightrail_ad_1", "6419/valence.vibe/%%device%%/", [[300,250]], "rightrail_ad_1", {"1064":[[300,250]],"0":[],"768":[]}, 0],                                                                    ["contentwell_ad_3", "6419/valence.vibe/%%device%%/", [[300,250]], "contentwell_ad_3", {"1064":[[300,250]],"0":[[300,250]],"768":[[300,250]]}, 0],                                                                    ["rightrail_ad_2", "6419/valence.vibe/%%device%%/", [[300,250]], "rightrail_ad_2", {"1064":[[300,250]],"0":[],"768":[]}, 0],                                                                    ["adhesion_1", "6419/valence.vibe/%%device%%/", [[320,50]], "adhesion", {"1064":[],"0":[[320,50]]}, 0]                                                            ];

                            // Add header slots then run,
                            // any slots added after initial run will be processed differently
                            for(var i=0; i<slotData.length; i++) {
                                header.addHeaderSlot.apply(header, slotData[i]);
                            }
                        
                        header.run({"a9":{"account_id":3125},"facebook":{"placementIds":["367129333816375_367129973816311","367129333816375_367130120482963","367129333816375_507302253132415","367129333816375_507302356465738","367129333816375_507302423132398","367129333816375_507302523132388","367129333816375_507302613132379","367129333816375_507302766465697","367129333816375_507302856465688","367129333816375_507302953132345","367129333816375_507303013132339"]},"moat":true});
                    }
                });
            </script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = {"ad_zone":"news","targeting":{"env":"prod","ptype":"article","url":"73b803d6","PID":"681262","keywords":"news,bet,donald-trump,joe-biden"},"slots":{"adhesion":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"adhesion","refresh":"{\"1064\":0,\"0\":1}","refreshTimer":"{\"1064\":0,\"0\":30}","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[],"0":[[320,50]]},"defaultSizes":[[320,50]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":0,\"0\":0}"},"contentwell_ad":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"contentwell_ad","refresh":"{\"1064\":1,\"0\":1,\"768\":1}","refreshTimer":"{\"1064\":30,\"0\":30,\"768\":30}","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[300,250],[300,251]],"0":[[300,250],[300,251]],"768":[[300,250],[300,251]]},"defaultSizes":[[300,250],[300,251]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"0\":1,\"768\":1}"},"footerboard_ad":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"footerboard_ad","refresh":"{\"1064\":1,\"768\":1}","refreshTimer":"{\"1064\":30,\"768\":30}","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[728,90],[728,92],[970,90],[970,92]],"768":[[728,90],[728,92],[970,90],[970,92]]},"defaultSizes":[[728,90],[728,92],[970,90],[970,92]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"768\":1}"},"leaderboard_ad":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"leaderboard_ad","refresh":"{\"1064\":1,\"0\":1,\"768\":1}","refreshTimer":"{\"1064\":30,\"0\":30,\"768\":30}","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]],"0":[[320,100],[320,50]],"768":[[728,90],[728,91]]},"defaultSizes":[[728,90],[728,91],[970,250],[970,251],[970,90],[970,91]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"0\":1,\"768\":1}"},"rightrail_ad":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"rightrail_ad","refresh":"{\"1064\":1,\"0\":1,\"768\":1}","refreshTimer":"{\"1064\":30,\"0\":30,\"768\":30}","outOfBody":null,"responsive":true,"sizeMapping":{"1064":[[300,250],[300,251]],"0":[],"768":[]},"defaultSizes":[[300,250],[300,251]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"1064\":1,\"0\":1,\"768\":1}"},"out_of_page":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"out_of_page","refresh":"{\"0\":0}","refreshTimer":"{\"0\":0}","outOfBody":"1","responsive":false,"sizeMapping":{"0":[[1,1]]},"defaultSizes":[[1,1]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"},"parallax_ad":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"parallax_ad","refresh":"{\"0\":1}","refreshTimer":"{\"0\":30}","outOfBody":null,"responsive":false,"sizeMapping":{"0":[[300,600]]},"defaultSizes":[[300,600]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":1}"},"promo":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"promo","refresh":"{\"0\":0}","refreshTimer":"{\"0\":0}","outOfBody":null,"responsive":false,"sizeMapping":{"0":[[2,2],[3,3]]},"defaultSizes":[[2,2],[3,3]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"},"zergnet":{"adUnit":"6419\/valence.vibe\/%%device%%\/","slotName":"zergnet","refresh":"{\"0\":0}","refreshTimer":"{\"0\":0}","outOfBody":null,"responsive":false,"sizeMapping":{"0":[[4,4]]},"defaultSizes":[[4,4]],"targetingParameters":[],"chartLine":null,"lazyLoad":"{\"0\":0}"}}};
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":1125911414,"default_player":"default"};

window.CLARITY = window.CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){

        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>

<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                                        , 'contentId': '681262'
                                                , 'contentType': 'article'
                                                , 'author': 'VIBE Staff'
                                                , 'category': 'News'
                                                , 'tags': 'bet, donald-trump, joe-biden'
                                                , 'publishDate': '2020060520'
                        
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-W3TLHV');
    </script>


<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<link rel="stylesheet" type="text/css" href="/assets/css/article.css?0cd0b31e24683c892ef3">
<script type='text/javascript'>
                        var VB = VB || {};
            VB.config = VB.config || {
                contentHost: "https://www.vibe.com",
                mediaHost: "https://static.vibe.com/files"
            };
        </script>
</head>
<body class="page--article">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
 <div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<div class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="/assets/images/logo/white.svg?0cd0b31e24683c892ef3" alt="Vibe">
<span class="site-header__brand-name">Vibe</span>
</a>
</div>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item collapsed active site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header__nav-link>News</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header__subnav-link>Entertainment</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header__subnav-link>National</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header__subnav-link>Sports</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header__subnav-link>Events</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header__subnav-link>Movies &amp; TV</a>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header__nav-link>Music</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header__subnav-link>Videos</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header__subnav-link>New Releases</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header__subnav-link>Live Reviews</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header__subnav-link>Album Reviews</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header__subnav-link>Music Premieres</a>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header__nav-link>Features</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header__subnav-link>Digital Covers</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header__subnav-link>Opinion</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header__subnav-link>Lists</a>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style class=site-header__nav-link>Style</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;fashion class=site-header__subnav-link>Fashion</a>
</li>
<li class="site-header__subnav-item   ">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lifestyle class=site-header__subnav-link>Lifestyle</a>
</li>
</ul>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen class=site-header__nav-link>Vixen</a>
<span class="carat"></span>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva class=site-header__nav-link>Viva</a>
<span class="carat"></span>
</li>
</ul>
<div class="site-header-search site-header-search--mobile js-search-form">
<form class="site-header-search__form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header-search__input js-search-input" placeholder="Search For..." name="keys" maxlength="255">
<input type="submit" value="GO" id="site-header-search__submit" class="site-header-search__submit js-search-submit">
</form>
</div>
<div class="site-header__follow-newsletter-holder">
<div class="site-header-follow">
<h3 class="site-header-follow__title">Follow Vibe</h3>
<ul class="header__social-links">
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<div class="email-subscribe-holder email-subscribe--wide" data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="email-subscribe email-subscribe--wide email-subscribe--has-title">
<h3 class="email-subscribe__title">
The Vibe Mix Newsletter
</h3>
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-menu" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </div>
</div>
</nav>
<form class="site-header__search-form site-header__search-form--main js-search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input js-search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit js-search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<nav class="site-header-links">
<div class="site-header-links__contents">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header-links__label>News</a>
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header-links__link>Entertainment</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header-links__link>National</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header-links__link>Sports</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header-links__link>Events</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header-links__link>Movies &amp; TV</a> </div>
</nav>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-leaderboard_ad ' id="leaderboard_ad_1" data-position='leaderboard_ad_1' data-slot-name="leaderboard_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<div class='ad_desktop dfp-ad dfp-ad-out_of_page ' id="out_of_page_1" data-position='out_of_page_1' data-slot-name="out_of_page" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<main id="main" class="container container--article">
<div class="section-holder col-holder">
<section class="main-well col-holder__left-col js-mainWell">
<article class="article__content-well js-main-article-content article__content-well--landscape  js-revarticle url-breadcrumb is-active " data-id="681262" data-url-breadcrumb="/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special" data-content-type="article" data-page-title="BET&#x20;Invites&#x20;Donald&#x20;Trump,&#x20;Joe&#x20;Biden&#x20;To&#x20;Juneteenth&#x20;Forum&#x20;&#x7C;&#x20;Vibe" data-canonical="https://www.vibe.com/2020/06/bet-invites-donald-trump-joe-biden-juneteenth-special" data-chartbeatSection="" data-analytics-category="News" data-analytics-tags="BET, Donald Trump, Joe Biden">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="" data-content-type="expandableImage">
<div class="main-media__image-holder">
<img src="https://static.vibe.com/files/2020/06/trump-biden-1591403246-e1591403901578-650x366.jpg" srcset="https://static.vibe.com/files/2020/06/trump-biden-1591403246-e1591403901578-650x366.jpg 650w, https://static.vibe.com/files/2020/06/trump-biden-1591403246-e1591403902594-1500x844.jpg 1500w, https://static.vibe.com/files/2020/06/trump-biden-1591403246-e1591403896665-768x432.jpg 768w, https://static.vibe.com/files/2020/06/trump-biden-1591403246-e1591403898964-1536x864.jpg 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class="main-media__image--expandable main-media__image" alt="trump-biden--1591403246">
</div>
<figcaption class="media__details-text">
<div class="media__credit">Chip Somodevilla/JIM WATSON/AFP/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="trump-biden--1591403246"></div> </figure>
<div class="article__header">
<h1 class="article__headline">BET Invites Donald Trump And Joe Biden To Appear In Juneteenth Special</h1>
<p class="article__meta">
<span class="article__publish-date-and-by">
<span class="js-publish-date article__publish-date" data-pubdate-value="2020060520">
June 5, 2020 - 8:44 pm
</span>
<span class="article__by">
by
</span>
</span>
<span class="js-authors-list">
<span class="author">
VIBE Staff
</span> <span class="social-share">
</span>
</span>
</p>
</div>
<div class="article__body article-overlay-handle js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' id="contentwell_ad_1" data-position='contentwell_ad_1' data-slot-name="contentwell_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<div class="article__deck">
The special forum will discuss a range of topics including systematic racism.
</div>
<p>BET wants Donald Trump and Joe Biden to participate in an upcoming forum set to air on Juneteenth, the network <a href="https://www.betpressroom.com/press-release/bet-unveils-series-of-programming-addressing-systemic-racism-the-violence-faced-by-black-people-in-a/" target="_blank" rel="noopener">announced</a> on Tuesday (June 2). The POTUS and presidential hopeful are invited to appear on an episode of, <em>Justice Now: A BET News Special</em>, where they will “directly address the concerns of Black America” and share their plans to move the country forward.</p>
<p>Trump and Biden would be interviewed separately for the “Presidential Forum.” They will be asked to “address a range of critical issues, including the institutional racism that has led to disparities” in housing, health, income, law enforcement, and the criminal justice system.</p>
<p>“We stand in steadfast solidarity with George Floyd’s family, the many victims of racist brutality, and those who are using their voices and platforms to challenge it,” said President of BET, Scott Mills. “There are no easy solutions for these systemic issues of racism, injustice, and trauma. BET is leveraging every platform and resource at our disposal to support and inform our community and help identify strategies and viable solutions in this time of crisis.”</p>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' id="contentwell_ad_2" data-position='contentwell_ad_2' data-slot-name="contentwell_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<p>Hosted by Marc Lamont Hill, the first installment of <em>Justice Now</em>, debuted on Tuesday night and featured conversations with George Floyd’s family, former NBA player Stephen Jackson (who was friends with Floyd), John Legend, T.I, Pulitzer Prize-winning journalist Nikole Hannah-Jones, activist Tamika Mallory, NAACP President Derrick Johnson, Senator Cory Booker and more.</p>
<div class="embedded-content" data-template="readmore" data-amp-enabled="1"><script type="application/json">{"nid":"680784","type":"post","title":"BET Awards Switches To Virtual Format For 2020 Ceremony","relative_path":"\/2020\/05\/2020-bet-awards-virtual-ceremony\/","media":{"width":2726,"height":1725,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/05\/BET-awards-GettyImages-1157892576-1590019466-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/BET-awards-GettyImages-1157892576-1590019466-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/BET-awards-GettyImages-1157892576-1590019466-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"680786","caption":null,"credit":null}}</script></div>
</div>

<div class="pi-list-item-blocks item-blocks">
<ul class="item-block-wrapper list-None" style="counter-reset: item 1">
</ul>
</div>
<div class="article__bottom">
<div class="article__bottom-left">
<div class="article__tags">
<span class="article__tags-pre">In This Story:</span>
<ul class="article__tags-holder">
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;bet>BET</a>, </li>
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;donald-trump>Donald Trump</a>, </li>
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;joe-biden>Joe Biden</a> </li>
</ul>
</div>
</div>
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa fa-facebook" data-pgm-share="facebook" data-pgm-title="BET&#x20;Invites&#x20;Donald&#x20;Trump&#x20;And&#x20;Joe&#x20;Biden&#x20;To&#x20;Appear&#x20;In&#x20;Juneteenth&#x20;Special" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;06&#x2F;bet-invites-donald-trump-joe-biden-juneteenth-special" href="javascript:void(0);">
<span>FACEBOOK</span>
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa fa-twitter" data-pgm-share="twitter" data-pgm-title="BET&#x20;Invites&#x20;Donald&#x20;Trump&#x20;And&#x20;Joe&#x20;Biden&#x20;To&#x20;Appear&#x20;In&#x20;Juneteenth&#x20;Special" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;06&#x2F;bet-invites-donald-trump-joe-biden-juneteenth-special" href="javascript:void(0);">
<span>TWITTER</span>
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa fa-envelope" data-pgm-title="BET&#x20;Invites&#x20;Donald&#x20;Trump&#x20;And&#x20;Joe&#x20;Biden&#x20;To&#x20;Appear&#x20;In&#x20;Juneteenth&#x20;Special" href="/cdn-cgi/l/email-protection#09366b666d7034617d7d797a2f2a713a48322f2a713b4f322f2a713b4f327e7e7e277f606b6c276a66642f2a713b4f323b393b392f2a713b4f32393f2f2a713b4f326b6c7d2460677f607d6c7a246d666768656d247d7b7c64792463666c246b606d6c6724637c676c7d6c6c677d61247a796c6a6068652f7a7c6b636c6a7d344b4c5d2f2a713b393240677f607d6c7a2f2a713b39324d666768656d2f2a713b39325d7b7c64792f2a713b393248676d2f2a713b393243666c2f2a713b39324b606d6c672f2a713b39325d662f2a713b39324879796c687b2f2a713b393240672f2a713b3932437c676c7d6c6c677d612f2a713b39325a796c6a606865">
<span>EMAIL ME</span>
</a>
</li>
</ul>
</div>

<div class="js-ad-pageTargeting">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json">
        {
                            "env": "prod",
                            "ptype": "article",
                            "url": "73b803d6",
                            "PID": "681262",
                            "keywords": "news,bet,donald-trump,joe-biden"
                    }
        </script>
</div>
</article>
</section>
<section class="col-holder__right-col hide-small hide-medium" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' id="rightrail_ad_1" data-position='rightrail_ad_1' data-slot-name="rightrail_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
</div>
<div class="section-title-holder ">
<h2 class="section-title">
Popular
</h2>
</div>
<div class="feed feed--sidebar">
<div class="feed-post-sidebar
    
    feed-post--article
    ">
<a href="/2020/06/trina-apology-comments-about-protestors" alt="Trina Apologizes For Comments About Protestors After Receiving Backlash" class="feed-post__image-holder feed-post-sidebar__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2019/10/trina-GettyImages-1133347199-1571200567-300x169.jpg" srcset="https://static.vibe.com/files/2019/10/trina-GettyImages-1133347199-1571200567-300x169.jpg 300w, https://static.vibe.com/files/2019/10/trina-GettyImages-1133347199-1571200567-602x339.jpg 602w" class="feed-post-sidebar__image" alt="">
</figure>
</a>
<div class="feed-post-sidebar__info">
<a href="/2020/06/trina-apology-comments-about-protestors" class="feed-post-sidebar__title-link">
<h2 class="feed-post-sidebar__title">
Trina Apologizes For Comments About Protestors After Receiving Backlash
</h2>
</a>
</div>
</div>
</div>
</div>
<div class="email-subscribe-holder " data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="section-title-holder ">
<h2 class="section-title">
The Vibe Mix Newsletter
</h2>
</div>
<div class="email-subscribe  ">
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-article" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </section>
</div>
<div class="section-holder col-holder section-holder--next-up">
<section class="col-holder__left-col left-col--next-up">
<div class='ad_desktop dfp-ad dfp-ad-zergnet ' id="zergnet_1" data-position='zergnet_1' data-slot-name="zergnet" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<div class="section-title-holder section-title-holder--zergnet">
<h2 class="section-title">
From the Web
</h2>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="next-up-holder">
<div class="section-title-holder section-title-holder--next-up">
<h2 class="section-title">
More on Vibe
</h2>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/06/taleb-kweli-says-new-black-star-album-almost-done" alt="Talib Kweli Says New Black Star Album Is Almost Done">
<img src="https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-650x366.jpg" srcset="https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-650x366.jpg 650w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-1500x844.jpg 1500w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-768x432.jpg 768w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-1536x864.jpg 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Talib Kweli Mos Def Rock the Bells 2011 - Mountain View, CA">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Tim Mosenfelder/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Talib Kweli Mos Def Rock the Bells 2011 - Mountain View, CA"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/06/taleb-kweli-says-new-black-star-album-almost-done" class="article-next-up__link">
<h2 class="article-next-up__title">
Talib Kweli Says New Black Star Album Is Almost Done
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Talib Kweli made a major announcement about the forthcoming Black Star album with Yasiin Bey (a.k.a Mos Def) during Wednesday’s (June 3) episode of The Tonight Show with Jimmy Fallon. Kweli appeared on the late night talks show to discuss social justice topics such as activism, racism, reparations, and police brutality.</p>
<p>In between discussing current events and his solo album, the Brooklyn native dropped a few details about the progress of the Black Star project.</p>
<p>“A lot of people have been hitting me up like 'We need that Black Star album, we need that Black Star album.' Me and Mos Def are in the final stages of the Black Star album,” he revealed. “It's produced completely by Madlib, so shoutout to Madlib and everybody at Oxnard. The new Black Star album is dealing with a lot of this subject matter. I'm working hard to get it out to the people."</p>
<p>The album will be the long-awaited follow-up to the hip-hop duo’s critically acclaimed 1998 debut LP, Mos Def &amp; Talib Kweli Are Black Star.  This isn't the first time that Black Star has made mention of the album. In 2018, Yasiin announced that the album was “coming soon.”</p>
<p>Watch Talib’s full interview below.</p>
<script type="application/json">{"nid":"679705","type":"post","title":"Post DJ Premier Battle, Wu-Tang Clan&#x27;s RZA Speaks To Talib Kweli On The People&#x27;s Party Podcast Live","relative_path":"\/2020\/04\/post-dj-premier-battle-wu-tang-clans-rza-speaks-to-talib-kweli-on-the-peoples-party-podcast-live\/","media":{"width":1606,"height":746,"extension":"png","mime_type":"image\/png","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/04\/Screen-Shot-2020-04-20-at-3.14.14-PM-1587410123-compressed.png","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/04\/Screen-Shot-2020-04-20-at-3.14.14-PM-1587410123-156x88.png","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/04\/Screen-Shot-2020-04-20-at-3.14.14-PM-1587410123-320x180.png","width":320,"height":180}],"orientation":"landscape","id":"679706","caption":null,"credit":null}}</script>
</div>
<a class="article-next-up__continue" href="/2020/06/taleb-kweli-says-new-black-star-album-almost-done">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/06/kanye-west-attends-protest-for-george-floyd-following-2-million-donation" alt="Kanye West Attends Protest For George Floyd Following $2 Million Donation">
<img src="https://static.vibe.com/files/2020/06/kanye-west-GettyImages-1186140734-1591408280-650x366.jpg" srcset="https://static.vibe.com/files/2020/06/kanye-west-GettyImages-1186140734-1591408280-650x366.jpg 650w, https://static.vibe.com/files/2020/06/kanye-west-GettyImages-1186140734-1591408280-1500x844.jpg 1500w, https://static.vibe.com/files/2020/06/kanye-west-GettyImages-1186140734-1591408280-768x432.jpg 768w, https://static.vibe.com/files/2020/06/kanye-west-GettyImages-1186140734-1591408280-1536x864.jpg 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="kanye-west-GettyImages-1186140734-1591408280">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Brad Barket/Getty Images for Fast Company</div>
</figcaption>
<div class="expanded-image__target" data-sources='[{"size":"650x366","url":"https:\/\/static.vibe.com\/files\/2020\/06\/kanye-west-GettyImages-1186140734-1591408280-650x366.jpg"},{"size":"602x339","url":"https:\/\/static.vibe.com\/files\/2020\/06\/kanye-west-GettyImages-1186140734-1591408280-602x339.jpg"},{"size":"300x169","url":"https:\/\/static.vibe.com\/files\/2020\/06\/kanye-west-GettyImages-1186140734-1591408280-300x169.jpg"},{"size":"238x134","url":"https:\/\/static.vibe.com\/files\/2020\/06\/kanye-west-GettyImages-1186140734-1591408280-238x134.jpg"},{"size":"156x88","url":"https:\/\/static.vibe.com\/files\/2020\/06\/kanye-west-GettyImages-1186140734-1591408280-156x88.jpg"}]' data-alt-text="kanye-west-GettyImages-1186140734-1591408280"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/06/kanye-west-attends-protest-for-george-floyd-following-2-million-donation" class="article-next-up__link">
<h2 class="article-next-up__title">
Kanye West Attends Protest For George Floyd Following $2 Million Donation
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Kanye West popped up at a “Justice for George Floyd” rally in Chicago, hours after his $2 million donation to the families of Floyd, Breonna Taylor, and Ahmaud Arbery was announced. West was spotted marching alongside demonstrators on the city’s South Side on Thursday (June 4).</p>
<p>The Chicago native contacted organizers with GoodKids MadCity to participate in the march, USA Today reports.</p>
<p>Yeezy didn’t stay for very long but he attempted to remain lowkey in a black mask and hoodie. According to reports, the peaceful march became somewhat chaotic as the press swarmed his black SUV.</p>
<p>In addition to showing support for the protest and donating money to cover legal bills and other expenses for Taylor, Arbery's and Floyd's families, the Grammy-winning rapper created a college fund for Floyd’s 6-year-old daughter.</p>
<p>See photos and video of West below.</p>
<p dir="ltr" lang="und">pic.twitter.com/X6paTKsAZe</p>
<p>— TeamKanyeDaily (@TeamKanyeDaily) June 6, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">Not only did Kanye West donate $2 million, he also joined protests today in Chicago. pic.twitter.com/bTeFPFNAGz</p>
<p>— Talking Rap &#x270a;&#x1f3fe; (@talking_rap) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">Kanye West joins Protest in Chicago pic.twitter.com/174MwBuN8h</p>
<p>— Kollege Kidd (@KollegeKidd) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">“I am one with the people.” pic.twitter.com/1h2deUAov2</p>
<p>— TeamKanyeDaily (@TeamKanyeDaily) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">Kanye at a protest on the South Side of Chicago tonight. #BlackLivesMatter pic.twitter.com/8qZVOumvPa</p>
<p>— TeamKanyeDaily (@TeamKanyeDaily) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&nbsp;</p>
</div>
<a class="article-next-up__continue" href="/2020/06/kanye-west-attends-protest-for-george-floyd-following-2-million-donation">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' id="contentwell_ad_3" data-position='contentwell_ad_3' data-slot-name="contentwell_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/06/solange-emotional-tribute-to-breonna-taylor" alt="Solange Knowles Pens Emotional Birthday Tribute To Breonna Taylor">
<img src="https://static.vibe.com/files/2020/06/GettyImages-1209368500-1591398851-650x366.jpg" srcset="https://static.vibe.com/files/2020/06/GettyImages-1209368500-1591398851-650x366.jpg 650w, https://static.vibe.com/files/2020/06/GettyImages-1209368500-1591398851-1500x844.jpg 1500w, https://static.vibe.com/files/2020/06/GettyImages-1209368500-1591398851-768x432.jpg 768w, https://static.vibe.com/files/2020/06/GettyImages-1209368500-1591398851-1536x864.jpg 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Solange Knowles - The Lena Horne Prize For Artists Creating Social Impact">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Dia Dipasupil/WireImage</div>
</figcaption>
<div class="expanded-image__target" data-sources='[{"size":"320x213","url":"https:\/\/static.vibe.com\/files\/2020\/06\/GettyImages-1209368500-1591398851-320x213.jpg"}]' data-alt-text="Solange Knowles - The Lena Horne Prize For Artists Creating Social Impact"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/06/solange-emotional-tribute-to-breonna-taylor" class="article-next-up__link">
<h2 class="article-next-up__title">
Solange Knowles Pens Emotional Birthday Tribute To Breonna Taylor
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Solange Knowles joined the chorus of beautiful tributes to Breonna Taylor on what should have been her 27th birthday on Friday (June 5).</p>
<p>“I want to be more like you Breonna Taylor. A better sister, friend, and human. More kind. More positive. More intentional,” wrote Solo. “Less judgmental. Less phased by shit that doesn’t matter. More dependable and moving with more care, light, and love.</p>
<p>“Your friends and cousin say that you were the ‘show up and never disappoint’ friend...that you would throw all negativity out the door. I wish you were there with them all today celebrating. You should be with them all here celebrating in all your radiance. I don’t know WHERE [the f**k] I’d be without my sisters and reading about your life, I know you were all their rock.”</p>
<script type="application/json">{"nid":"681093","type":"post","title":"Breonna Taylor\u2019s Family Vows To Continue To Fight For Justice: \u201cPlease Keep Saying Her Name\u201d","relative_path":"\/2020\/05\/breonna-taylor-family-please-keep-saying-her-name\/","media":{"width":744,"height":419,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/05\/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"680599","caption":null,"credit":null}}</script>
<p>In closing, the “Cranes in the Sky” singer shouted out Taylor’s mother, Tamika Palmer, as well as her sister, relatives, and friends to thank them “for sharing her with the world today.” Solo also thanked and Eva Lewis for writing a Teen Vogue story where Taylor’s loved ones opened up about her life and legacy.</p>
<p>“She always said she was destined for greatness, and now she will be a part of history,” said Palmer.</p>
<p>Taylor was murdered by officers from the Louisville Police Department on March 13.  None of the officers have been arrested.</p>
<p>In commemoration of her birthday, social media has been flooded with tributes and calls for justice. A Change.org petition demanding the arrest of Louisville officers John Mattingly, Brett Hankison, Myles Cosgrove, and any other “involved in the death and coverup” of her death has reached 4.5 million signatures.</p>
<p>A GoFundMe page launched by Taylor’s family has raised over $4 million and counting, and multiple demonstrations are scheduled to be held this weekend in Taylor's honors.</p>
<p>Check below for tributes from Solange, Megan Thee Stallion, Beyonce, Cardi B, Janelle Monae, Taraji P. Henson, Tika Sumpter, and more.</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">I want to be more like you Breonna Taylor. A better sister, friend, and human. More kind. More positive. More intentional. Less judgmental. Less phased by shit that doesn’t matter. More dependable and moving with more care, light, and love. Your friends and cousin say that you were the “show up and never disappoint” friend...that you would throw all negativity out the door. I wish you were there with them all today celebrating. You should be with them all here celebrating in all your radiance. I don’t know WHERE tf I’d be with out my sisters and reading about your life, I know you were all their rock. Ms. Tamika Palmer, Ju’Niyah ,Katrina ,Alena ,Erinicka ,Clarissa, Preonia, Shatanis.... thank you all for sharing her with the world today. I hope we are all doing due justice by lifting her spirit up in light today. Thank you Eva Lewis for writing a piece that illustrated her beautiful power. I want to be more like you Breonna. Happy Birthday beautiful one &#x1f339;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by @ saintrecords on Jun 5, 2020 at 3:18pm PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">Happy birthday breonna &#x1f499; #breonnataylor</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Hot Girl Meg (@theestallion) on Jun 5, 2020 at 8:16am PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">Breonna Taylor would be 27 today. Her life was taken to soon. Officers must be held accountable. These no-knock warrants are dangerous. #happybirthdaybreonna You deserve so much more. #blm #breonnataylor @gracieleeart</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Tika Sumpter (@tikasumpter) on Jun 5, 2020 at 9:03am PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">Let’s give #breonnataylor #Justice for her birthday!!! JESUS....she was asleep in her own bed getting her rest to wake up and save lives (as a first responder studying to be a nurse) and her precious life was taken by systemic racism and negligence by the police dept that OUR tax dollars pay for to SERVE AND PROTECT US!!!! NO ONE has been arrested!!!! NO ONE IS BEING HELD ACCOUNTABLE FOR THE LOSS OF PRECIOUS LIFE!!!!#BLACKLIVESMATTER RIGHT TF NOW!!!!!!!!!!!!!!!!!!!!!!! #LetMyPeopleGo #GODIS #NOTMAN I don’t care how things are looking right now. #GODIS #DarknessNEVERwins #TheTruthALWAYScomesToLight and #TheDevilCantStandIt &#x1f64f;&#x1f3fe;&#x1f64f;&#x1f3fe;&#x1f64f;&#x1f3fe;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by taraji p henson (@tarajiphenson) on Jun 5, 2020 at 10:55am PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">&#x1f5e3;Today would’ve been Breonna Taylor’s 27th birthday &#x1f5e3;She was a full-time EMT at TWO hospitals in Louisville, KY &#x1f5e3;She was an essential worker&#x1f5e3;She was an aspiring nurse &amp; dedicated her life at an early age to helping others &#x1f5e3;HER KILLERS police officers Jon Mattingly, Brett Hankison, Myles Cosgrove have not been arrested or fired &#x1f5e3;She was shot to death in her own home asleep! &#x1f5e3;Her killers claim “they had the wrong house” &#x1f5e3;the suspect they were looking for was already in Custody &#x1f5e3;The police did not knock and were not in uniform &#x1f5e3;Please help her family get justice &#x1f5e3;Call 502-696-5300 and tell Kentucky attorney general Daniel Cameron that your birthday wish for Breonna is that the officers are arrested, charged, and convicted of the murder of BREONNA TAYLOR &#x1f5e3;SPEAK UP FOR BLACK WOMEN &#x1f5e3;#SAYHERNAME #justiceforbreonnataylor #defundthepolice sign:standwithbre.com</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Janelle Monáe (@janellemonae) on Jun 5, 2020 at 10:36am PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p dir="ltr" lang="en">Today is #BreonnaTaylor’s birthday.#SayHerName. Think of and pray for those closest to her. Dedicate time to work for #JusticeforBreonnaTaylor. Here’s how. RT. Share. #JusticeForBreonna, @GovAndyBeshear @louisvillemayor @LMPD. pic.twitter.com/ee2ZsqyENK</p>
<p>— Be A King (@BerniceKing) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">Breonna Taylor would have been 27 years old today. On her social media she talks abou 2020 being her year. Instead her loved ones mourn and her killers haven’t been charged. We will never stop fighting for #JusticeForBreonna. #SayHerName! pic.twitter.com/7D4XeqFpus</p>
<p>— SisterSong (@SisterSong_WOC) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">It’s the Doll’s Birthday. We love you Breonna and we’ll never forget you &#x1f5a4;&#x1f98b; pic.twitter.com/desgduXosh</p>
<p>— Sean Garrette (@sgarretteskin) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">Happy Birthday #BreonnaTaylor .She looks so pretty and fine in this pic.Her story it’s so sad and unfair and it almost didn’t get picked up by the media.Kentuky police department really tried to sweep her case under the rug,but got is BIG.The fight ain’t over till you get justice pic.twitter.com/LuZFu4tlFF</p>
<p>— iamcardib (@iamcardib) June 5, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">Justice for Breonna. Click the link in my bio to take action.</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Beyoncé (@beyonce) on Jun 5, 2020 at 5:53pm PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
</div>
<a class="article-next-up__continue" href="/2020/06/solange-emotional-tribute-to-breonna-taylor">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
</div>
</section>
<section class="col-holder__right-col" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' id="rightrail_ad_2" data-position='rightrail_ad_2' data-slot-name="rightrail_ad" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
</div>
</div>
</section>
</div>
<div class="section-holder">
<div class="section-title-holder ">
<h2 class="section-title">
Top Stories
</h2>
</div>
<div class="feed feed--one-third feed--footer-recommended">
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/05/breonna-taylor-family-please-keep-saying-her-name/" alt="Breonna Taylor’s Family Vows To Continue Fight For Justice: “Please Keep Saying Her Name”" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/05/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-240x135.jpg" srcset="https://static.vibe.com/files/2020/05/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-240x135.jpg 240w, https://static.vibe.com/files/2020/05/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-602x339.jpg 602w, https://static.vibe.com/files/2020/05/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-320x180.jpg 320w, https://static.vibe.com/files/2020/05/breonna-taylor-black-emt-killed-wrongfully-killed-1589495982-650x366.jpg 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national>National</a> </h3>
<span class="feed-post-third__date">
1w ago
</span>
<a href="/2020/05/breonna-taylor-family-please-keep-saying-her-name/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Breonna Taylor’s Family Vows To Continue Fight For Justice: “Please Keep Saying Her Name”
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/06/taleb-kweli-says-new-black-star-album-almost-done/" alt="Talib Kweli Says New Black Star Album Is Almost Done" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-240x135.jpg" srcset="https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-240x135.jpg 240w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-602x339.jpg 602w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-320x180.jpg 320w, https://static.vibe.com/files/2020/06/GettyImages-122594553-1591412112-650x366.jpg 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-news>Music News</a> </h3>
<span class="feed-post-third__date">
15h ago
</span>
<a href="/2020/06/taleb-kweli-says-new-black-star-album-almost-done/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Talib Kweli Says New Black Star Album Is Almost Done
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2019/02/six-things-to-know-about-mysterious-death-of-tamla-horsford-list/" alt="Tamla Horsford: 6 Things To Know About Her Mysterious Death " class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2019/02/Tamla-Horosford-1550694539-240x135.jpeg" srcset="https://static.vibe.com/files/2019/02/Tamla-Horosford-1550694539-240x135.jpeg 240w, https://static.vibe.com/files/2019/02/Tamla-Horosford-1550694539-320x180.jpeg 320w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists>Lists</a> </h3>
<span class="feed-post-third__date">
February 20, 2019
</span>
<a href="/2019/02/six-things-to-know-about-mysterious-death-of-tamla-horsford-list/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Tamla Horsford: 6 Things To Know About Her Mysterious Death
</h2>
</a>
</div>
</div>
</div>
</div>
</main>
<footer class="page-footer">
<div class="container">
<div class="footer__header">
<div class="footer__social-holder">
<ul class="footer__social-links">
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<a href="/" class="footer__logo-holder">
</a>
</div>
<ul class="footer__main-menu">
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news>News</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features>Features</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style>Style</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen>Vixen</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva>Viva</a> </li>
<li class="footer__main-menu-link-holder">
<a href=mailto&#x3A;tips&#x40;vibe.com>Contact Us</a> </li>
</ul>
<p class="footer__member">
Vibe.com is an affiliate site of Billboard, a subsidiary of Prometheus Global Media, LLC. </p>
<ul class="footer__secondary-menu">
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;privacy-policy&#x2F;>Privacy Policy</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;about-our-ads&#x2F;>Ad Choices</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;copyright&#x2F;>Copyright</a> </li>
</ul>
<ul class="footer__site-links">
<li class="footer__site-links-link-holder">
<a href="https://www.billboard.com/" target="_blank">Billboard</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a>
</li>
<li class="footer__site-links--mobile-separator"></li>
<li class="footer__site-links-link-holder">
<a href="https://www.spin.com/" target="_blank">SPIN</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.vibe.com/">VIBE</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.stereogum.com/" target="_blank">Stereogum</a>
</li>
</ul>
</div>
<container>
<div class='ad_desktop dfp-ad dfp-ad-adhesion ' id="adhesion_1" data-position='adhesion' data-slot-name="adhesion" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
</container>
</footer>
<div class='ad_desktop dfp-ad dfp-ad-promo ' id="promo_1" data-position='promo_1' data-slot-name="promo" data-ad-unit='6419/valence.vibe/%%device%%/' data-dark-matter-is-processed="false">
</div>
<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    var darkMatterCMD = function() {
        this.darkMatterCall(function () {

            var keywords = [];

            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

            var pageMeta = {
                    pageKeywordData: keywords,
                    adTargetingData: PGM.ads.data,
                    iuData: {
                        iu: '6419/valence.vibe/%%device%%/',
                        site_code: 'valence.vibe/%%device%%',
                        zone: 'news'
                    }
                },
                region = this.getUtilities().getSetCookie('PGMCC') || '';

                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "ptype=article",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "url=73b803d6",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "PID=681262",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "keywords=news,bet,donald-trump,joe-biden",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.vibe.com",
                    paths: "",
                    positions: "all"
                });
            
            keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            });

            this.setMetaDataFromPage(pageMeta);
        })
    };

    window.top.DarkMatter.cmd.push([darkMatterCMD]);

    CLARITY.push({
        use: ['ads', 'cookies', 'header'],
        run: function(Ads, cookies, header) {
            // @TODO can remove try/catch after this release; wrapping it for now in site/Clarity deploys are out of
            // sync.
            try {
                // Since we have the ad unit available, let Clarity know about it so we don't have to keep passing that
                // in.
                header.setAdUnit('6419/valence.vibe/%%device%%/');
            } catch(err) {
            }
            Ads.site_code = "valence.vibe/%%device%%";
            Ads.zone = "news";
            var keywords = [];
            var region = cookies.get('PGMCC') ? cookies.get('PGMCC') : '';
            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }
                        keywords.push({
                keywords: "",
                keyvalues: "env=prod",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "ptype=article",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "url=73b803d6",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "PID=681262",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "keywords=news,bet,donald-trump,joe-biden",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "domain=www.vibe.com",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            })
            Ads.keywords = keywords;
                                }
    });

        
</script>
<script>
    CLARITY.push({
        use: ['ads'],
        run: function(Ads){
            Ads.populate('.dfp-ad:not([data-paywall-defer="true"])');
        }
    });
</script>
<script src="/assets/js/vendors_/article_/fee_06ff0549.bundle.js?40a3e55cb93216e01d74?0cd0b31e24683c892ef3"></script><script src="/assets/js/default_/article_/fee_3c36d112.bundle.js?40a3e55cb93216e01d74?0cd0b31e24683c892ef3"></script><script src="/assets/js//article.bundle.js?40a3e55cb93216e01d74?0cd0b31e24683c892ef3"></script>
<script type="text/javascript" src="/assets/js/legacy.js?0cd0b31e24683c892ef3"></script>
</body>
</html>
