<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<title>
                            Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture
                    </title>
<meta name="article:modified_time" property="article:modified_time" content="2020-09-22T11:56:12-04:00" />
<meta name="article:published_time" property="article:published_time" content="2020-09-22T11:00:29-04:00" />
<meta name="description" property="description" content="One-third of the hip-hop trio talks team talks football team ownership, how FCF differs from the NFL, his foray into TV and film, and more." />
<meta name="og:description" property="og:description" content="One-third of the hip-hop trio talks team talks football team ownership, how FCF differs from the NFL, his foray into TV and film, and more." />
<meta name="og:image" property="og:image" content="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1950x1097.jpg" />
<meta name="og:image:height" property="og:image:height" content="1097" />
<meta name="og:image:width" property="og:image:width" content="1950" />
<meta name="og:title" property="og:title" content="Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture: Interview" />
<meta name="og:type" property="og:type" content="article" />
<meta name="og:url" property="og:url" content="https://www.vibe.com/2020/09/quavo-fcf-league-interview" />
<meta name="twitter:card" property="twitter:card" content="summary_large_image" />
<meta name="twitter:description" property="twitter:description" content="One-third of the hip-hop trio talks team talks football team ownership, how FCF differs from the NFL, his foray into TV and film, and more." />
<meta name="twitter:image" property="twitter:image" content="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1950x1097.jpg" />
<meta name="twitter:title" property="twitter:title" content="Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture" />
<meta name="twitter:site" content="@vibemagazine" />
<meta property="og:site_name" content="Vibe" />
<link href="https://fonts.googleapis.com/css?family=Barlow+Condensed:400,500,600|Barlow:400,700|Lora:400,400i,700,700i" rel="stylesheet">
<link rel="canonical" href="https://www.vibe.com/2020/09/quavo-fcf-league-interview">
<link rel="amphtml" href="https://www.vibe.com/amp/2020/09/quavo-fcf-league-interview">
<link rel="icon" href="/assets/images/favicon.ico?c9882160987783148cf8" />
<link rel="shortcut icon" href="/assets/images/favicon.ico?c9882160987783148cf8" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="/assets/images/favicon152.png?c9882160987783148cf8">
<link rel="dns-prefetch" href="https://www.google-analytics.com/">
<link rel="dns-prefetch" href="https://www.googletagservices.com/">
<link rel="dns-prefetch" href="https://www.googletagmanager.com/">
<link rel="dns-prefetch" href="https://www.instagram.com/">
<link rel="dns-prefetch" href="https://www.zergnet.com/">
<link rel="dns-prefetch" href="https://players.brightcove.net/">
<link rel="dns-prefetch" href="https://platform.zig.com/">
<link rel="dns-prefetch" href="https://www.googleadservices.com">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com/">
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net/">
<link rel="dns-prefetch" href="https://cdn.krxd.net/">
<link rel="dns-prefetch" href="https://beacon.krxd.net/">
<link rel="dns-prefetch" href="https://a.quora.com/">
<link rel="dns-prefetch" href="https://connect.facebook.net/">
<link rel="dns-prefetch" href="https://s0.2mdn.net/">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com">
<link rel="dns-prefetch" href="https://sejs.moatads.com/">
<link rel="dns-prefetch" href="https://mb.moatads.com/">
<link rel="dns-prefetch" href="https://tags.bluekai.com/">
<link rel="dns-prefetch" href="https://platform.twitter.com/">
<link rel="dns-prefetch" href="https://analytics.twitter.com/">
<link rel="dns-prefetch" href="https://lib.pgmcdn.com">
<script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": "https://www.vibe.com/2020/09/quavo-fcf-league-interview",
            "headline": "Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture"
                            ,
                "image": {
                    "@type": "ImageObject",
                    "url": "https://static.vibe.com/files2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277.jpg",
                    "height": 4914,
                    "width": 8736
                }
                        ,
            "publisher": {
                "@type": "Organization",
                "name": ""
                            },
            "author": [
                                    {
                    "@type": "Person",
                    "name": "Preezy Brown"
                    }
                            ],
            "datePublished": "2020-09-22T11:00:29-04:00",
            "dateModified": "2020-09-22T11:56:12-04:00",
            "description": ""
                    }
    </script>
<script type="text/javascript">
        var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        assetHost: "/assets",
        contentHost: "https://www.vibe.com",
        sailthruCustomerId: ""
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.resolveOptAnon = (function() {
        var q = [], roa = function resolveOptAnon() { q.push(arguments) };
        roa.dump = function() {return q;};
        return roa;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.enableDeferredAds = false;
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "";
    PGM.blockScripts = false;

        PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1064px)"
    };
    PGM.social = {"facebook":{"site_name":"Vibe","account":"vibe"},"instagram":{"account":"vibemagazine"},"pinterest":{"account":"vibemagazine"},"snapchat":{"account":"vibemagazine"},"twitter":{"account":"vibemagazine"},"youtube":{"account":"vibemedia"}};

    PGM.greCaptchaSiteKey = "6Lfc66MUAAAAAA3lW9bTwbc_vy17EsFlueLHQjze";
</script>
<script src="https://lib.pgmcdn.com/advertisement.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js" async defer></script>

<script type="text/javascript">
    window.top.DarkMatter = window.top.DarkMatter || {};
    window.top.DarkMatter.cmd = window.top.DarkMatter.cmd || [];

            window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"valence.vibe\/%%device%%","zone":"features","single_request_mode":true};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//darkmatter.billboard.com/wp-content/uploads/ad-tech/dark-matter-vibe-com.js'; s.parentNode.insertBefore(ns, s);
})();
</script>


<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = null;
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":1125911414,"default_player":"default"};

window.CLARITY = window.CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){

        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>

<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                                        , 'contentId': '683822'
                                                , 'contentType': 'article'
                                                , 'author': 'Preezy Brown'
                                                , 'category': 'Features'
                                                , 'tags': 'migos, quavo'
                                                , 'publishDate': '2020092211'
                        
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-W3TLHV');
    </script>


<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<link rel="stylesheet" type="text/css" href="/assets/css/article.css?c9882160987783148cf8">
<script type='text/javascript'>
                        var VB = VB || {};
            VB.config = VB.config || {
                contentHost: "https://www.vibe.com",
                mediaHost: "https://static.vibe.com/files"
            };
        </script>
</head>
<body class="page--article">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<div class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="/assets/images/logo/white.svg?c9882160987783148cf8" alt="Vibe">
<span class="site-header__brand-name">Vibe</span>
</a>
</div>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header__nav-link>News</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header__subnav-link>Entertainment</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header__subnav-link>National</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header__subnav-link>Sports</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header__subnav-link>Events</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header__subnav-link>Movies &amp; TV</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header__nav-link>Music</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header__subnav-link>Videos</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header__subnav-link>New Releases</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header__subnav-link>Live Reviews</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header__subnav-link>Album Reviews</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header__subnav-link>Music Premieres</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed active site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header__nav-link>Features</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header__subnav-link>Digital Covers</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header__subnav-link>Opinion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header__subnav-link>Lists</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style class=site-header__nav-link>Style</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;fashion class=site-header__subnav-link>Fashion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lifestyle class=site-header__subnav-link>Lifestyle</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen class=site-header__nav-link>Vixen</a>
<span class="carat"></span>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva class=site-header__nav-link>Viva</a>
<span class="carat"></span>
</li>
</ul>
 <div class="site-header-search site-header-search--mobile js-search-form">
<form class="site-header-search__form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header-search__input js-search-input" placeholder="Search For..." name="keys" maxlength="255">
<input type="submit" value="GO" id="site-header-search__submit" class="site-header-search__submit js-search-submit">
</form>
</div>
<div class="site-header__follow-newsletter-holder">
<div class="site-header-follow">
<h3 class="site-header-follow__title">Follow Vibe</h3>
<ul class="header__social-links">
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<div class="email-subscribe-holder email-subscribe--wide" data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="email-subscribe email-subscribe--wide email-subscribe--has-title">
<h3 class="email-subscribe__title">
The Vibe Mix Newsletter
</h3>
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-menu" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </div>
 </div>
</nav>
<form class="site-header__search-form site-header__search-form--main js-search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input js-search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit js-search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<nav class="site-header-links">
<div class="site-header-links__contents">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header-links__label>Features</a>
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header-links__link>Digital Covers</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header-links__link>Opinion</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header-links__link>Lists</a> </div>
</nav>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-leaderboard_ad ' data-position="leaderboard_ad" data-dark-matter-is-processed="false">
</div>
<div class='ad_desktop dfp-ad dfp-ad-out_of_page ' data-position="out_of_page" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<main id="main" class="container container--article">
<div class="section-holder col-holder">
<section class="main-well col-holder__left-col js-mainWell">
<article class="article__content-well js-main-article-content article__content-well--landscape  js-revarticle url-breadcrumb is-active  " data-id="683822" data-url-breadcrumb="/2020/09/quavo-fcf-league-interview" data-content-type="article" data-page-title="Quavo&#x20;Is&#x20;Introducing&#x20;&#x27;Fan&#x20;Controlled&#x20;Football&#x27;&#x20;To&#x20;The&#x20;Culture" data-canonical="https://www.vibe.com/2020/09/quavo-fcf-league-interview" data-chartbeatSection="" data-analytics-category="Features" data-analytics-tags="Migos, Quavo">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="" data-content-type="expandableImage">
<div class="main-media__image-holder">
<img src="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-650x366.jpg" srcset="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-650x366.jpg?1 650w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-768x432.jpg?1 768w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class="main-media__image--expandable main-media__image" alt="Quavo-Migos-FCF-Football-League-Interview-5-1600748277">
</div>
<figcaption class="media__details-text">
<div class="media__credit">Courtesy of Biz 3 / FCF</div>
</figcaption>
<div class="expanded-image__target" data-sources='[{"size":"3000x1688","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-3000x1688.jpg"},{"size":"2048x1152","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-2048x1152.jpg"},{"size":"1536x864","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1536x864.jpg"},{"size":"1500x844","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1500x844.jpg"},{"size":"1600x900","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1600x900.jpg"},{"size":"1024x576","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-1024x576.jpg"},{"size":"800x450","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-800x450.jpg"},{"size":"768x432","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-768x432.jpg"},{"size":"676x380","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-676x380.jpg"},{"size":"650x366","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-650x366.jpg"},{"size":"602x339","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-602x339.jpg"},{"size":"320x180","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-320x180.jpg"},{"size":"300x169","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-300x169.jpg"},{"size":"272x153","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-272x153.jpg"},{"size":"240x135","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-240x135.jpg"},{"size":"238x134","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-238x134.jpg"},{"size":"224x126","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-224x126.jpg"},{"size":"156x88","url":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-156x88.jpg"}]' data-alt-text="Quavo-Migos-FCF-Football-League-Interview-5-1600748277"></div> </figure>
<div class="article__header">
<h1 class="article__headline">Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture</h1>
<p class="article__meta">
<span class="article__publish-date-and-by">
<span class="js-publish-date article__publish-date" data-pubdate-value="2020092211">
September 22, 2020 - 11:00 am
</span>
<span class="article__by">
by
</span>
</span>
<span class="js-authors-list">
<span class="author"><a href="/author/preezy-brown" class="article__author-link">Preezy Brown</a></span> <span class="social-share">
<span class="social-share__item">
<a class="social-share__link social-share__link--twitter fa fa-twitter" target="_blank" href="https://www.twitter.com/crooklynsdodger">
<span>TWITTER</span>
</a>
</span>
</span>
</span>
</p>
</div>
<div class="article__body article-overlay-handle js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<p>From their penchant for popping tags and name-dropping designer brands in their rhymes to the obsession with diamond-encrusted neckwear, the <a href="https://www.vibe.com/tag/migos" target="_blank" rel="noopener">Migos</a> are the modern-day poster-children for decadence and opulence. But when it comes to balling, group member <a href="https://www.vibe.com/tag/quavo" target="_blank" rel="noopener">Quavo</a> is a seasoned veteran, literally and figuratively. Notorious for his appearances in <a href="https://www.nba.com/hawks/quavo-2020-celebrity-game" target="_blank" rel="noopener">NBA all-star celebrity games</a>, where he routinely dominates the competition, Huncho has built a rep as one of the athletically gifted hit-makers in music today.</p>
<p>Although he's known for his skills on the hardwood, football is definitely among his passions. His newest endeavor, an ownership stake in <a href="https://www.fcf.io/home" target="_blank" rel="noopener">Fan Controlled Football (FCF)</a>, the first professional sports league to put the viewer in the coach's seat and the general manager's office, in live time, finds him putting his focus back on the gridiron. Having inked an exclusive, multi-year streaming broadcast partnership with Twitch, the FCF will be the first professional sports league to be fully integrated with the streaming platform with the potential to explode in the digital age, where user interest and participation is the main recipe for success.</p>
<p>Having tossed the pigskin around as a Georgia high school football star, to Quavo, it was a no-brainer to get involved with the innovative league on the ground level. “We are building a brand and something different in our league – with the fans. They are in control and get to pick the team names, colors, logos, and more,” said Quavo said in a press release. “I’m really excited because FCF is fast-paced, high-scoring 7v7 football and you are in control. You go from sitting on the couch watching TV and pressing buttons on the remote to actually pressing the buttons on the plays.”</p>
<p>Played on "a 35-yard x 50-yard field with 10-yard end zones,” the Fan Controlled Football league will kick off in February 2021, with a four-week regular season, one week of playoffs, and a Championship week. The league will consist of former elite D-1 athletes, the CFL, XFL, and the Indoor Football League. Broadcasted live from the FCF’s state-of-the-art facility in Atlanta, each game will be 60 minutes in length and will allow the viewers to play a hand in the final outcome on Twitch.</p>
<p>Aside from sports, Quavo has been relatively lowkey on the musical tip as of late, with two years having passed since a solo release or a Migos album. However, according to him, this delay can be considered the calm before the storm, as he assures him and his brethren are primed for one of their biggest years yet. <em>VIBE</em> hopped on the line with Quavo to talk Fan Controlled Football, what he's got cooking in the studio, and his foray into TV and film.</p>
<div class="mainembed videoembed mainembed-full_width align-center no-image">
<div class="video-embed-code horizontal">
<iframe width="" height="" data-src="https://www.youtube.com/embed/icLaxjHqfoc" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</div>
<p style="text-align: center;">---</p>
<p><strong>You're the newest team owner at Fan Controlled Football (FCF). What about the league piqued your interest and made you wanna get involved?</strong></p>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<p>It's just showing my interest in the game of football and just trying to put a twist to where it's fan-controlled, fan-involved. A lot of times we watch the game, you watch the game, you just have some concerns. Sometimes you feel you can make the plays or call the play, [with FCF], you can sit on the couch and make the play. I just think we came together to make something crazy like that. I feel like it's something hard, it's something new, it's something fresh. It's a new beginning to something, like giving ni**as a chance. Giving D-1 players who couldn't make it to the league a chance, giving ex-NFL ni**as a chance if they still got it, [and] to go with the fans. When we saw the Falcons lose the Superbowl LI, we [fans] just knew what plays to call, we knew to run the ball. We were up 28-3. All we had to do was hold the ball, but we wanted to air it out and we made a mistake and lost to Tom Brady. Just like when Marshawn could've won a Superbowl. If they'd have given him the ball on the two-yard line. We knew that Marshawn Lynch was supposed to get the ball, [but] they wanted Russell Wilson to win it and the New England Patriots caught an interception. So that's how we're trying to shape it, we're trying to make something new.</p>
<p><strong>The FCF will be live-streamed <a href="https://www.twitch.tv/fcf" target="_blank" rel="noopener">exclusively on Twitch</a>, which has become one of the leading platforms for eSports live-streaming and will kick off in February 2021. Do you feel the FCF has the opportunity to fill that NFL void during the spring, particularly given the fan engagement that FCF enables?</strong></p>
<p>Most definitely, cause after the Super Bowl, it just feels like you just want another game. You feel like you want one more game. and coming from something [where it's] eleven on eleven players to seven on seven, I feel [there’s] still a difference. After coming from watching the game and the regular politics, the regular structure of the game, now you're getting to be involved in a game that you can control. You can pick the jersey, you can pick the helmets, you can pick the jerseys, you can pick the coaches, you can pick the plays. I just feel there are two different dynamics [between the NFL and FCF). You come from sitting on the couch and pressing the remote to actually pressing the button on the plays."</p>
<p><strong>Speaking of fan engagement, the FCF is the only professional sports league that enables fans to call the plays in real-time and puts the viewer in control of a game’s outcome like never before. Have you ever had that experience, as far as fantasy football? </strong></p>
<p>Nah, but I'm into <em>Madden</em>. You can sit at home and pick your plays [with FCF], it's just like the lifestyle of <em>Madden</em>. It's like a reality of <em>Madden</em>. You're playing with people at home, with these unique athletes, and it's seven-on-seven.</p>
<p><strong>As an Atlanta native, how significant was the FCF’s state-of-the-art facility being in your hometown in your decision to come on board as an owner? </strong></p>
<p>It's very important. We got top-tier talent here, so it's opening up opportunities for a lot of guys. We're just glad it's in the south, it's like a hub. Everybody loves Atlanta and everybody wanna be here. Everybody wanna play and the weather is good.</p>
<div class="embedded-content" data-template="image"><script type="application/json">{"width":11648,"height":8736,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-1600746973-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-1600746973-650x488.jpg","width":650,"height":488},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-1600746973-1600x1200.jpg","width":1600,"height":1200},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-1600746973-2048x1536.jpg","width":2048,"height":1536},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-1600746973-3000x2250.jpg","width":3000,"height":2250}],"size":"full_width","alignment":"center","orientation":"landscape","id":"683828","caption":"","credit":"Courtesy of Biz 3 \/ FCF","altText":"","title":"Quavo-Migos-FCF-Football-League-Interview-1600746973"}</script></div>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<p><strong>NFL Super Bowl Champions Richard Sherman and Marshawn Lynch, boxing legend Mike Tyson, and YouTuber and podcaster empire Greg Miller are among the FCF's team owners. How does it feel to be competing against some of the most accomplished athletes and entertainers in the world? Have you had the opportunity to meet with any of them?</strong></p>
<p>Most definitely. I have a good relationship with Mike Tyson. I've met Marshawn Lynch, it's a blessing. I feel like we're not competing right now, I feel like we're building a brand. I feel like we're building a league. I feel like we're trying to make the world understand what we're bringing to the table and what type of game we bring to the table, you feel me? I feel we're trying to create something different. Once we get the ball rolling, it's all together and moving into a real FCF league, then we'll get to compete. Of course, we all wanna win, but right now, we're just trying to get the foundation and the basics going and letting the strength of the owners and the relationships show on the field.</p>
<p><strong>Being that you'll all be working with your respective fan bases in shaping your team’s personality and identity, any thoughts about what the team’s name will be? </strong></p>
<p>Man, I wish I did, but it's so straight strictly fans that you never know. Just like with music, can have an idea that is a smash, and then the fans don't think it is. You gotta strictly listen to the fans on this one. You gotta listen strictly to how they want it because it's the point of the game, that's the point of the league. We gotta let them control this game and then we the players and we the people that's listening to the people, the culture. FCF stands for culture, too, you feel what I'm saying? We listen to the culture, we're letting the culture run the field.</p>
<p><strong>How involved will you be in the drafting and scouting process for your squad? </strong></p>
<p>The fans make the draft, fans get to see everything. Open books, everything. It's an open thing, it ain't nothing to hide over here. The fans control it all.</p>
<p><strong>In addition to sports, you've also been delving into acting, with cameos in shows like </strong><strong><em>Atlanta</em></strong><strong>, </strong><strong><em>Star</em></strong><strong>, </strong><strong><em>Black-ish</em></strong><strong>, and </strong><strong><em>Ballers</em></strong><strong>. Earlier this year, you appeared as yourself in </strong><strong><em>Narcos: Mexico</em></strong><strong>. How did that opportunity come about? </strong></p>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<p>Narcos reached out. We [Migos] had this song called “Narcos” on the [<em>Culture II</em>] album and we went and shot [the video] in Miami and everybody thought it was a Narcos movie scene and it ended up being Madonna's house. So we just shot that there and then they reached out to us. I think Offset had a performance somewhere and Takeoff had to do something and I just ended up being free that day and I went and shot it in New Mexico. I had fun, I loved it.</p>
<div class="embedded-content" data-template="image"><script type="application/json">{"width":8736,"height":11648,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-2-1600747050-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-2-1600747050-488x650.jpg","width":488,"height":650},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-2-1600747050-1200x1600.jpg","width":1200,"height":1600},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-2-1600747050-1536x2048.jpg","width":1536,"height":2048},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/Quavo-Migos-FCF-Football-League-Interview-2-1600747050-2250x3000.jpg","width":2250,"height":3000}],"size":"full_width","alignment":"center","orientation":"portrait","id":"683829","caption":"","credit":"Courtesy of Biz 3 \/ FCF","altText":"","title":"Quavo-Migos-FCF-Football-League-Interview-2-1600747050"}</script></div>
<p><strong>Do you have plans to pursue any supporting or leading roles in film or television?</strong></p>
<p>Hell yeah, most definitely. I've been sitting down and having real great meetings with directors and people that got some movies in the works for 2021. I feel like I’ve got some good spots. I don't wanna tell it cause they’re gonna make some announcements. It's coming soon.</p>
<p><strong>It's been two years since you've released a solo project or one with the Migos. Can fans expect any new music from you anytime soon and what are your next plans on that front?</strong></p>
<p>Most definitely, hell yeah, we're shooting videos right now. We’re vaulting up a whole lot of videos so we can give you music and visuals at the same time. “Need It," the song came first and then the video. Right now, we wanna get a lot of videos and a lot records in the vault and smash [them] all at once 'cause it's been two years.</p>
<p><strong>Pop Smoke's passing was one of the more tragic events in rap in recent memory, but his debut album, which you appeared on throughout, has been one of the most successful and acclaimed projects of 2020. How has it been seeing how the album’s been received, especially after you and him developed such a bond in a short time? </strong></p>
<p>I'm happy. I'm proud of him, that was my partner. We did a lot of records, we spent a lot of time together and I feel like the album would've did even more with him being alive. A lot of people's album just go crazy when they die, I feel like his sh*t would've still went crazy. He had the momentum, he had the buzz. He was having fun. He was hot, he was fresh, he had everything ready.</p>
<p><em>This interview has been edited for length and clarity.</em></p>
</div>
<div class="article__bottom">
<div class="article__bottom-left">
<div class="article__tags">
<span class="article__tags-pre">In This Story:</span>
<ul class="article__tags-holder">
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;migos&#x2F;>Migos</a>, </li>
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;quavo&#x2F;>Quavo</a> </li>
</ul>
</div>
</div>
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa fa-facebook" data-pgm-share="facebook" data-pgm-title="Quavo&#x20;Is&#x20;Introducing&#x20;&#x27;Fan&#x20;Controlled&#x20;Football&#x27;&#x20;To&#x20;The&#x20;Culture" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;09&#x2F;quavo-fcf-league-interview" href="javascript:void(0);">
<span>FACEBOOK</span>
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa fa-twitter" data-pgm-share="twitter" data-pgm-title="Quavo&#x20;Is&#x20;Introducing&#x20;&#x27;Fan&#x20;Controlled&#x20;Football&#x27;&#x20;To&#x20;The&#x20;Culture" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;09&#x2F;quavo-fcf-league-interview" href="javascript:void(0);">
<span>TWITTER</span>
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa fa-envelope" data-pgm-title="Quavo&#x20;Is&#x20;Introducing&#x20;&#x27;Fan&#x20;Controlled&#x20;Football&#x27;&#x20;To&#x20;The&#x20;Culture" href="/cdn-cgi/l/email-protection#3f005d505b4602574b4b4f4c191c470c7e04191c470d7904191c470d79044848481149565d5a115c5052191c470d79040d0f0d0f191c470d79040f06191c470d79044e4a5e495012595c5912535a5e584a5a1256514b5a4d49565a48194c4a5d555a5c4b026e4a5e4950191c470d0f04764c191c470d0f0476514b4d505b4a5c565158191c470d0f04191c470d0804795e51191c470d0f047c50514b4d5053535a5b191c470d0f047950504b5d5e5353191c470d0804191c470d0f046b50191c470d0f046b575a191c470d0f047c4a534b4a4d5a">
<span>EMAIL ME</span>
</a>
</li>
</ul>
</div>
<div class="js-ad-pageTargeting">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json">
        {
                    }
        </script>
</div>
</article>
</section>
<section class="col-holder__right-col hide-small hide-medium" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
<div class="section-title-holder ">
<h2 class="section-title">
Popular
</h2>
</div>
<div class="feed feed--sidebar">
<div class="feed-post-sidebar
    
    feed-post--article
    ">
<a href="/2020/09/quavo-fcf-league-interview" alt="Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture" class="feed-post__image-holder feed-post-sidebar__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-300x169.jpg" srcset="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-300x169.jpg?1 300w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-602x339.jpg?1 602w" class="feed-post-sidebar__image" alt="">
</figure>
</a>
<div class="feed-post-sidebar__info">
<a href="/2020/09/quavo-fcf-league-interview" class="feed-post-sidebar__title-link">
<h2 class="feed-post-sidebar__title">
Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture
</h2>
</a>
</div>
</div>
</div>
</div>
<div class="email-subscribe-holder " data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="section-title-holder ">
<h2 class="section-title">
The Vibe Mix Newsletter
</h2>
</div>
<div class="email-subscribe  ">
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-article" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </section>
</div>
<div class="section-holder col-holder section-holder--next-up">
<section class="col-holder__left-col left-col--next-up">
<div class='ad_desktop dfp-ad dfp-ad-zergnet ' data-position="zergnet" data-dark-matter-is-processed="false">
</div>
<div class="section-title-holder section-title-holder--zergnet">
<h2 class="section-title">
From the Web
</h2>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="next-up-holder">
<div class="section-title-holder section-title-holder--next-up">
<h2 class="section-title">
More on Vibe
</h2>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/09/remembering-toots-hibbert" alt="Remembering Toots Hibbert">
<img src="https://static.vibe.com/files/2020/09/toots-hibbert-obituary-vibe-1600273680-e1600273871329-650x366.jpg" srcset="https://static.vibe.com/files/2020/09/toots-hibbert-obituary-vibe-1600273680-e1600273871329-650x366.jpg?1 650w, https://static.vibe.com/files/2020/09/toots-hibbert-obituary-vibe-1600273680-e1600273873510-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/09/toots-hibbert-obituary-vibe-1600273680-e1600273863929-768x432.jpg?1 768w, https://static.vibe.com/files/2020/09/toots-hibbert-obituary-vibe-1600273680-e1600273866835-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Photo of Toots HIBBERT">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__caption">Toots Hibbert performing at Hammersmith Palais, London in 1983.
</div>
<div class="media__credit">Photo by David Corio/Redferns</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Photo of Toots HIBBERT"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/09/remembering-toots-hibbert" class="article-next-up__link">
<h2 class="article-next-up__title">
Remembering Toots Hibbert
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>The best singers don’t need too many words to make their point. Otis Redding could let loose with a sad sad song like “Fa-fa-fa-fa-fa-fa-fa-fa-fa” and get you all in your feelings. Bob Marley got pulses pounding with his “Whoi-yoooo” rebel yell. Gregory Isaacs melted hearts with nothing more than a gentle sigh. Toots Hibbert, who died last Friday at the age of 77, could sing just about anything and make it sound good. One of the world's greatest vocalists in any genre, Toots paired his powerful voice with the understated harmonies of Raleigh Gordon and Jerry Mathias to form The Maytals, a vocal trinity that never followed fashion and remained relevant throughout the evolution of Jamaican music—from the ska era to rock steady straight through to reggae, a genre named after The Maytals' 1968 classic “Do The Reggay.”</p>
<p>Whether they were singing a sufferer’s selection (“Time Tough”), a churchical chant (“Hallelujah”), or the tender tale of a country wedding (“Sweet and Dandy”), The Maytals blew like a tropical storm raining sweat and tears. The lyrics to Six and Seven Books,” one of The Maytals' earliest hits, are pretty much just Toots listing the books of the Bible. “You have Genesis and Exodus,” he declares over a Studio One ska beat, “Leviticus and Numbers, Deuteronomy and Joshua, Judges and Ruth...” Having grown up singing in his parents' Seventh Day Adventist Church in the rural Jamaican town of May Pen, Toots knew the Good Book well.</p>
<p>The Maytals broke out worldwide in 1966 thanks to the song “Bam Bam,” which won Jamaica's first-ever Independence Festival Song Competition, held during the first week of August as the island nation celebrated both independence from Great Britain in 1862 and emancipation in 1834. They would go on to win the coveted title two more times, but “Bam Bam” was a singular song with a message every bit as powerful as Toots' voice. “I want you to know that I am the man," Toots sang. He was young and strong, ready to "fight for the right, not for the wrong." The trajectory of "Bam Bam" would not only transform Toots' life but make waves throughout popular music worldwide.</p>
<p>"Festival in Jamaica is very important to all Jamaicans," the veteran singer stated in a video interview this past summer while promoting his latest entry into the annual competition. "I must tell you that I won three festivals in Jamaica already, which is “Bam Bam,” “Sweet &amp; Dandy” and “Pomp &amp; Pride.” Toots described that first festival competition as a joyous occasion. "Everybody just want to hear a good song that their children can sing," he recalled. "Is like every artist could be a star."</p>
<p>In 2016, on the 50th anniversary of "Bam Bam" winning first place, Toots looked back over the legacy of the tune that made him a star. "I didn’t know what it means but it was a big deal," he told Boomshots. "You in the music business and you want to be on top and you write a good song and you go on this competition and if they like it then it becomes #1." After The Maytals won, the group was in demand not just all over the island, but all over the world. "We start fly out like a bird," he says with a laugh. "Fly over to London."</p>
<p>"Bam Bam" went on to inspire numerous cover versions, starting with Sister Nancy, Yellowman, and Pliers. It would also be sampled in numerous hip hop classics, and interpolated into Lauryn Hill's "Lost Ones." But according to Toots, he did not benefit financially from these endless cover versions. "People keep on singing it over and over and over, and they don’t even pay me a compliment," he told Boomshots. "I haven’t been collecting no money from that song all now."</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">“This man don’t trouble no one... but if you trouble this man it will bring a Bam Bam” Original Maytals Classic @tootsmaytalsofficial &#x1f3b6; All them a talk, them nuh bad like Niya Fiya Ball &#x2604;&#xfe0f;&#x1f525;&#x1f4a5; via @tonyspreadlove . &#x1f4a5;&#x1f4a3;&#x1f52b;#Boomshots</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Word Sound &amp; Power (@boomshots) on Sep 12, 2020 at 8:19am PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>When Toots began singing in his parents' church, music was not seen as a career prospect, and the profits were slim for Jamaican recording artists in the 1960s. "Those days we get 14 cents for the record to play on the radio," Toots said. "I get three shillings and five shillings for a number one record, which I had 31 number one record in Jamaica... It’s not about money for me. It’s about the quality that Jamaicans need to go back in the festival jamboree... You gotta talk to the children."</p>
<p>On the poignant “54-46 (Was My Number),” Toots recalls the dehumanization of his arrest and 18-month imprisonment at Jamaica's Richmond Farm Correctional Center for what he always insisted was a trumped-up ganja charge just as his music career was taking off. The song's crescendo comes two minutes in when Toots breaks into a scat solo that cannot be translated into any language known to man, delivered with palpable passion that made his message universal. During Toots' ecstatic stage performances he would follow this riff by commanding his band to “Give it to me... one time!” Then the 'd make 'em say Uh!  (Way before Master P!) “Give it to me... two times!” Uh! Uh! And so on and so forth until Toots worked the place into a frenzy.</p>
<p>The Maytals' live show was so explosive that Toots began touring all over the world, opening for rock megastars like The Rolling Stones and The Who. While Bob Marley richly deserved the title King of Reggae, his friend Toots was performing internationally before The Wailers, and remained a force to be reckoned with throughout his life, blazing a trail for generations of reggae artists to follow in his footsteps.</p>
<p>On his Grammy-winning 2004 album True Love, Toots recorded some of his greatest hits with a host of legendary artists, many of whom were also good friends, including Willie Nelson, Mick Jagger, Keith Richards, Bonnie Raitt, Sheryl Crow, and Eric Clapton. His 2006 cover of Radiohead's "Let Down" was a favorite of the band's, who used to play it on their tour bus. Radiohead guitarist Jonny Greenwood called Toots’ version “truly astounding,” according to Easy Star Records Michael Goldwasser.</p>
<p>Toots supported himself and his family by touring all over the world. During a 2013 show in Richmond, Virginia he was singing John Denver's "Take Me Home Country Roads" when a teenager in the crowd threw a vodka bottle at the stage and hit him on the head. He suffered a concussion and had to stop touring for several years. As his first album in a decade, Got To Be Tough was highly anticipated when it was released on Trojan Jamaica label August 28. On the cover the former boxer and lifelong fighter can be seen throwing a punch. Just a day after the album dropped, Toots came down with symptoms similar to COVID 19. Within a few days he was hospitalized where doctors placed him into a medically induced coma from which he never recovered. As his Tidal obituary pointed out, he passed away exactly 33 years after his old friend Peter Tosh died by gunfire.</p>
<p>Songs like "Just Brutal" from the hit different now, with Toots pleading for more love in a world gone wrong. "We were brought here," Toots sings. "Sold out. Victimized brutally. Every time I keep remembering what my grandfather said before he died."</p>
<p>“I’m feeling alright,” Toots said the last time we spoke, while he was still sidelined with stress issues due to the bottle-throwing incident. "I’m feeling alright. I’m feeling alright. I’m feeling just cool because is Jah works. You seet?" I asked him if the song "Bam Bam," was about him—a peaceful man who should not be provoked—or else. "Nooo don't trouble him," Toots said with a laugh. "It’s gonna be double trouble, triple trouble. A lot of trouble."</p>
</div>
<a class="article-next-up__continue" href="/2020/09/remembering-toots-hibbert">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/08/dj-cassidy-speaks-on-pass-the-mic-vol-2-ft-hip-hop-greats-ll-cool-j-rakim-salt-n-pepa-mc-lyte-and-30-more-mcs" alt="DJ Cassidy Speaks On &#039;Pass The Mic Vol. 2&#039; Ft. Hip-Hop Greats LL Cool J, Rakim, Salt-N-Pepa, MC Lyte And 30+ More MCs">
<img src="https://static.vibe.com/files/2020/08/Screen-Shot-2020-08-06-at-5.12.33-PM-1596750161-650x366.png" class=" main-media__image" alt="DJ Cassidy!">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">DJ Cassidy</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="DJ Cassidy!"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/08/dj-cassidy-speaks-on-pass-the-mic-vol-2-ft-hip-hop-greats-ll-cool-j-rakim-salt-n-pepa-mc-lyte-and-30-more-mcs" class="article-next-up__link">
<h2 class="article-next-up__title">
DJ Cassidy Speaks On &#039;Pass The Mic Vol. 2&#039; Ft. Hip-Hop Greats LL Cool J, Rakim, Salt-N-Pepa, MC Lyte And 30+ More MCs
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>With the COVID-19 pandemic wreaking havoc globally, 2020 has been a year filled with tragedy and uncertainty, as an innumerable amount of lives have been taken or affected as a result of the spread of the virus. The world of entertainment, which relies on ticket-holders and live spectators, is affected severely, with artists unable to tour, give live performances, interact with fans, or even create material by committee. This unprecedented blackout of sorts is a tough pill to swallow and threatens to forever alter the industry as we know it. However, as a culture and artform that built its history around making the best of times with minimal resources at its disposal, hip-hop is at the forefront of keeping the public entertained and butts moving, with various DJs, artists, and producers discovering new ways to stay in tune with the people.</p>
<p>While new, digital platforms like DJ D-Nice's "Club Quarantine" and Swizz Beatz and Timbaland's "Verzuz" battle series are ahead of the curve, the latest virtual experience to emerge is Pass The Mic, a live event created and hosted by legendary spinner DJ Cassidy. A native New Yorker, Cassidy, who made his name via the club circuit during the late '90s and early aughts, has a resume that rivals the most accomplished of DJs, having spun at high profile events such as the 2009 inauguration ball for Barack Obama, Obama's 50th birthday party, and the wedding of JAY-Z and Beyonce. Performing hundreds of shows on a yearly basis, Cassidy, whose touring schedule was halted due to the pandemic, was stuck at home when a conversation with legendary soul musician Verdine White of Earth, WInd &amp; Fire gave him an epiphany.</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">Thank you @revwon @kingdmc @llcoolj @mrchuckd_pe @therealdjchillwill @therealdougefresh @thegodrakim @mcshan1 @mcmilkdee @specialedmusic @emceeserch @mclyte @chipfu @erick_sermon @doitalldu @therealgrandpuba @djpremier @darealgregnice #smoothb @blacksheepdres @therealclsmooth @realpeterock darealmonielove @youngmc89 @chubblive @officialbigdaddykane @robbasemusic @kidfromkidnplay @the_playgroundz @darealpepa @saltnpepaofficial @speech__ @rasadon @eshe2xgrammy @treachtribe @unclevinrock &#x2764;&#xfe0f; You are my heroes. And to all 122,000 people that tuned in, I am truly grateful. &#x1f399;&#x1f451;&#x1f399;#PassTheMic @rockthebells @behindtherhymetv @twitch</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by DJ Cassidy (@djcassidy) on Aug 5, 2020 at 9:13pm PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>Cassidy explains: "In the heat of the pandemic, in the middle of the quarantine, I was facetiming with my good friend and mentor Verdine White of Earth, Wind &amp; Fire. Verdine has grown to be a close friend whom I truly admire, and he and I go to dinner every month or so and, obviously, we were not able to do that. So we were on a Facetime call catching up and while I was talking to him, his song, ‘That's The Way of the World,’ came on my speakers. And ‘That's The Way of The World’ is my favorite Earth, Wind &amp; Fire song and on a regular day, it sends a chill down my spine. But being that the world was in flux and everyone was in their homes, separate from each other, [and] being that I was looking into his eyes as I heard the song, a kind of special feeling came over me. And I said, 'You know, I'm very lucky that I have so many relationships with all of my heroes of music and I can hear their music in their company.' And I said, 'Wouldn't it be amazing if I could find some way to give that special feeling to other people around the world during this crazy time. And I said, 'Well, if I can connect my musical heroes from home to home, perhaps I can give people this feeling that I'm feeling right now. And perhaps I can use that as a way to pay homage to the heroes around the world fighting for health.' So therein lies the foundation of the whole idea."</p>
<p>That spark ultimately evolved into Pass The Mic Vol. 1, which saw some of the biggest R&amp;B stars of the late '70s and the '80s performing their greatest hits from the comfort of their homes, for the world to see. The event, which was streamed live on Twitch before being uploaded to Cassidy's Instagram page, was a big hit, amassing upwards of twenty thousand viewers, prompting the DJ to follow up with a second volume geared towards his first love: Hip-Hop. Airing this past Wednesday (Aug. 5), Pass The Mic Vol. 2 saw DJ Cassidy summoning a slew of his friends, who just happen to be among the greatest rap artists of all-time, to join him in a cipher of the most pivotal rap records of the '80s and early '90s. DJ Premier, of the legendary rap group Gang Starr, spoke on DJ Cassidy approaching him to be a part of the massive celebration. "When Cassidy texted me the links to VOLUME 1, I was blown away by the people he chose," Premier shares. "And it kept getting more and more exciting as the songs progressed to wonder who's next. Even the way he sequenced it..."</p>
<p>Beginning with Run of Run DMC performing "Sucker M.C.'s," the nearly forty minute set included appearances from the likes of LL Cool J, Chuck D, Rakim, Big Daddy Kane, MC Lyte, Kid N' Play and Naughty By Nature, all of whom tear the house down, albeit virtually from the comfort of their own. The session includes many magical moments and is filled with a love for one another, as well as the culture that brings us all together.</p>
<p>With the second volume in the series having took place, with many more to come, VIBE spoke with DJ Cassidy via phone about the genesis of Pass The Mic, what the process entailed putting the first two volumes together, the healing and unification of music, and how Black music has had an indelible impact on his life and career.</p>
<script type="application/json">{"width":812,"height":454,"extension":"png","mime_type":"image\/png","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.52.51-PM-1596747440-compressed.png","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.52.51-PM-1596747440-650x363.png","width":650,"height":363},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.52.51-PM-1596747440-compressed.png","width":812,"height":454},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.52.51-PM-1596747440-compressed.png","width":812,"height":454},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.52.51-PM-1596747440-compressed.png","width":812,"height":454}],"size":"one_half","alignment":"center","orientation":"landscape","id":"683043","caption":"","credit":"DJ Cassidy","altText":"","title":"DJ Cassidy & Rakim 3"}</script>
<p>VIBE: The first volume of Pass The Mic included appearances by Earth, Wind &amp; Fire, New Edition, Bobby Brown, Kool &amp; The Gang, Patrice Rushen, and other stars of the '70s '80s. What made you kick off the series celebrating that particular era?</p>
<p>DJ Cassidy: I think two main reasons come to mind. First of all, the Facetime call with Verdine White was really the genesis of the concept, so it was that call that inspired the whole idea. And it was that song, the first song on Vol. 1 that was playing, so to me, it was automatic that I should go to that era of music to set the project off. But the second reason is kind of a bigger picture, which is I really believe that that music is the most feel-good, uplifting music ever created. It is undeniably body-moving and for two-thirds of my life, I've traveled the world, making people dance and there is no music that uplifts, inspires people, makes people smile and makes people dance than the r&amp;b music of the '70s and the '80s. So when the world is going through what it's going through and people wanna smile and people wanna be uplifted and people wanna unite, there really was no greater music to channel to try to do such a thing, to achieve such a mission.</p>
<p>How would you describe an episode of Pass The Mic and what are some unique wrinkles users can expect?</p>
<p>Pass The Mic is an interactive mixtape delivered in a way that you've never experienced before. As I drop each record, you experience that record with the artist who recorded that record and you connect with those artists from home to home. And through that personal experience, you're left with an emotional experience of music unlike any before. And I'd be lying if I said I thought that all the way through when I started, I didn't. A lightbulb went off for me, I saw the big picture and I went for it, but I didn't quite understand how emotional the response would be until I premiered it.
</p>
<p>You've also mentioned how the times we're in, with the COVID-19 pandemic, was also a factor in you creating Pass The Mic. What are your thoughts on how other DJs and producers have been adapting to the climate we're in?</p>
<p>Well, I think the pandemic has been such a tough time for everyone around the world, yet it's also been a great time for DJs to be the best versions of themselves. At our core, we DJs unite people. At our foundation we bring people together through music and no one exemplified that better, bigger and faster than D-Nice. In the first week of the pandemic, he found a way to unite the world through DJing and it was truly beautiful to watch then and remains beautiful to watch now.
</p>
<p>You've been spinning professionally for upwards of two decades and have an expansive list of high-profile artists and musicians at your disposal. What has the recruiting process for Pass The Mic entailed and how would you describe the artists' reception to the idea of it all?</p>
<p>Well, the process has certainly evolved, I would say that's the best word to use. The recruitment process for Vol. 1 was entirely different from Vol. 2 'cause while recruiting artists for Vol.1, I had nothing to show. All I had was a crazy idea that some people understood and some people didn't, but what they did exhibit was a unanimous trust in me and for that, I was not only grateful, but extremely honored. We're talking about some of the most legendary r&amp;b artists of all time, they don't need to do my Pass The Mic idea. And they all took a leap of faith and they put their trust in me and I think they were all excited by the results and that really was the biggest reward. The recruiting process for Vol. 2 was entirely different because not only had many of the artists now seen Vol. 1, but for those who didn't I of course had Vol. 1 to show them. One of the greatest experiences was calling Big Daddy Kane, one of the greatest rappers of all-time.</p>
<p>Now, I haven't spoken to Kane on the phone in years. In fact, I might have never spoken to Kane on the phone before. I first developed a relationship when he performed at my birthday party in New York many years ago, over ten years ago. And every time we see him, it's all love and, of course, I admire, idolize and look up to him and I wasn't even sure if I had the right number I called, I got a voicemail, it wasn't his voice. I text him, I said 'Kane, it's Cassidy, is this still you?'  And he called me within five minutes and I picked up and go, 'Kane!' And his first words were, 'Look, if you're calling about something having to do with Pass The Mic, I'm in,' and that was one of the greatest phone calls I've ever had in my life. And I will never forget that one sentence. Big Daddy Kane, the great, the legend, the forefather, he not only saw it, but loved it, felt that's why I might be calling and was down to take part in whatever I was doing and there's really no words to describe that feeling. And that sentiment was common in many of my phone calls  that a lot of the artists I was calling had seen Vol. 1 and were really emotional in their response to it. So the recruiting process from Vol. 1 and 2 were very different, in that respect.
</p>
<script type="application/json">{"width":1053,"height":814,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/08\/Big-Daddy-KaneCassidy3-1596752237-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Big-Daddy-KaneCassidy3-1596752237-650x502.jpg","width":650,"height":502},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Big-Daddy-KaneCassidy3-1596752237-compressed.jpg","width":1053,"height":814},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Big-Daddy-KaneCassidy3-1596752237-compressed.jpg","width":1053,"height":814},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Big-Daddy-KaneCassidy3-1596752237-compressed.jpg","width":1053,"height":814}],"size":"one_half","alignment":"center","orientation":"landscape","id":"683050","caption":"","credit":"DJ Cassidy","altText":"","title":"Big-Daddy-KaneCassidy3"}</script>
<p>For the debut volume of Pass The Mic, you partnered with Twitch, a streaming platform that's been continuing to gain steam. What spurred you to use that particular platform and is that partnership official? </p>
<p>Firstly, what I was doing wasn't possible to present to people on Instagram. I love Instagram, it's the platform I use the most, it's how I share my life and times, but there was no way I could've presented Pass The Mic through Instagram. So I was looking for a platform that allowed for a live experience, one which I could treat as a live event and there were several: YouTube, Facebook and Twitch. And Twitch seemed like a great home for the launch, their platform, their technology, their fanbase. They're extremely forward thinking and it was a great place, but it was also a partnership with the Behind The Rhyme channel. Behind The Rhyme is a channel on Twitch that presents  lots of great content having to do with hip-hop and r&amp;b, specifically classic hip-hop and r&amp;b, but all kinds of hip-hop and r&amp;b. So it was a great kind of home for Vol. 1 and it worked out well, so I've chosen to host a live event for Vol. 2 there as well. And I've also partnered with Rock The Bells on this edition, they represent all things classic hip-hop so it's self-explanatory. The partnership is a no-brainer. LL Cool J and his brand represent everything that Pass The Mic Vol. 2 strives to represent, the beauty and inspiration of classic hip-hop.
</p>
<p>The second episode of Pass The Mic aired this past Wednesday (August 5), and saw you putting the focus on the golden era of hip-hop, with legends like LL Cool J, Run-DMC and Salt-N-Pepa all appearing on the show. How would you describe your relationship with that era of hip-hop and how the music inspired you as a DJ?  </p>
<p>Well, I grew up in that era of hip-hop. I grew up memorizing the words of the hip-hop records of the mid '80s, late '80s, and early '90s, that was my childhood.  Hip-Hop is my first love, hip-hop is why I became a DJ, hip-hop is why I asked my parents to buy me two turntables and a mixer for my birthday when I turned ten. And these artists, the artists who I've included in Pass The Mic Vol. 2 are my true heroes. They are the artists I looked up to as a child, they are the artists I idolized as a child and to this day, I hold them up on the highest of pedestal.  They define the way I walk, the way I talk, the way I danced, the way I dress, the way I fought, they gave me identity. Without these artists, I don't really know what my identity would be. I became who I am through this music, so this volume really meant a lot to me, the last twenty-one days have been surreal.</p>
<p>Yeah, for sure. The reason the past twenty-one days have been so surreal is not only because I got to Zoom with all of my heroes of hip-hop, but because after we knocked out what we had to do we stayed on for another half an hour or more talking. And sometimes I'd be on with some of these artists for an hour and I'd be asking them questions and they would tell me stories and I just heard the greatest anecdotes. And sometimes with those whom I had relationships with, we talked about stories that involved me and us and those were incredibly special, for obvious reasons, but all the stories were just, like, gems. They were just dropping gems on me. I have all that footage and I hope, at some point, there is another component of Pass The Mic where I share those stories.</p>
<p>What would you say are three records from that period that personally resonate with you?</p>
<p>"Sucker M.C.’s" is a very important song to me, as it is to hip-hop culture, as it is I believe, to pop culture. "Sucker MCs," in my opinion, is the archetype of a hip-hop record. It's so brilliantly simple and it's powerful because of its brilliant simplicity. All that's on there is a kick, a snare, a clap, and rhymes. There's no chorus, it's only four verses. And if you think about it, on paper, it's the simplest hip-hop record ever made and it's just so magical because if an alien came from out of space like, 'What is hip-hop?' I would play them “Sucker M.C.'s.” So, for me, it was really important for that reason, to set off this particular volume with that record.</p>
<p>Another record that's really important to me is Arrested Development "People Everyday." It's not only one of my favorite hip-hop records of all-time, it's one of my favorite records of all-time, it just simply exudes joy and celebration. And Speech is not only an incredible rapper, but an incredible singer and his voice is just simply something you can feel. He's uplifting, he's truly a unifying spirit and I'm so happy he was willing to get down 'cause he really brings the celebration to this.</p>
<p>"Hip Hop Hooray," which closes out Vol. 2, is really important to me. As a child, I worshipped the ground Treach walked on. I thought Treach was the coolest person to ever walk the face of this earth. And Treach and Vinnie are the sweetest guys, I've known them since I was a child and they've always been really supportive of me and my career and that song is special. No matter where you go in the world, no matter what music someone loves, no matter how old they are, no matter who they are, no matter where they are, everyone sings along to that chorus and knows exactly what to do with their hands. And there's something really beautiful about that so there's no better song to end this with.</p>
<p>The first two episodes of Pass The Mic have been geared towards celebrating Black icons in music, across various genres. In the age of Black Lives Matter and social injustice, what are your thoughts on how music and the performance of it can help bring forth unity and healing? </p>
<p>I think there is no greater unifying power than music and I think there is no greater healing force than soul music. And soul music doesn't just mean r&amp;b music, it means hip-hop, too, hip-hop comes from soul. And I think we're living in a time of divisiveness, bigotry and of separation and I think we, as humanity, can look to any one thing to uplift people and unify, it would be music. And you mentioned Black music, my life wouldn't be what it is without the music of Black artists, hip-hop and R&amp;B has defined my life in so many ways, and not only in my career. It's my source of inspiration, it's my source of culture, it's my source of style, it's really my source of happiness. And it's through the music of soul artists and hip-hop artists that I've been able to travel the world and make people dance and make people smile.</p>
<p>What do you see Pass The Mic evolving into moving forward and what do you hope viewers walk away with after viewing an episode of Pass The Mic?</p>
<p>I hope people walk away feeling uplifted, that's it. That's the goal, to uplift. And by sharing these records in a unique way, I've been able to uplift, then I've done my job. The magic is in the music and I'm just a messenger. What do I see for the future? Well, at this point, sky's the limit. I didn't anticipate quite an emotional response from people and it's been quite overwhelming. As I said, this was a little passion project to stay creative, to connect with my heroes and to put a smile on a few faces and it turned into something bigger than I could've ever imagined. There's certainly gonna be more volumes and what the future has in store, we shall see.</p>
<script type="application/json">{"width":862,"height":892,"extension":"png","mime_type":"image\/png","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.44.16-PM-1596747630-compressed.png","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.44.16-PM-1596747630-628x650.png","width":628,"height":650},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.44.16-PM-1596747630-compressed.png","width":862,"height":892},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.44.16-PM-1596747630-compressed.png","width":862,"height":892},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/Screen-Shot-2020-08-06-at-4.44.16-PM-1596747630-compressed.png","width":862,"height":892}],"size":"two_thirds","alignment":"center","orientation":"portrait","id":"683044","caption":"","credit":"DJ Cassidy","altText":"","title":"DJ Cassidy Pass The Mic 2"}</script>
</div>
<a class="article-next-up__continue" href="/2020/08/dj-cassidy-speaks-on-pass-the-mic-vol-2-ft-hip-hop-greats-ll-cool-j-rakim-salt-n-pepa-mc-lyte-and-30-more-mcs">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/08/jay-versace-interview" alt="Beats, Blackness, and Revolution: A Conversation With Jay Versace">
 <img src="https://static.vibe.com/files/2020/08/jay-versace-vibe-interview-1-1596471721-e1596472117475-650x366.jpg" srcset="https://static.vibe.com/files/2020/08/jay-versace-vibe-interview-1-1596471721-e1596472117475-650x366.jpg?1 650w, https://static.vibe.com/files/2020/08/jay-versace-vibe-interview-1-1596471721-e1596472119153-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/08/jay-versace-vibe-interview-1-1596471721-e1596472112228-768x432.jpg?1 768w, https://static.vibe.com/files/2020/08/jay-versace-vibe-interview-1-1596471721-e1596472115296-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="jay-versace-vibe-interview-1-1596471721">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Photo by Jax Teller (@_30onme)</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="jay-versace-vibe-interview-1-1596471721"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/08/jay-versace-interview" class="article-next-up__link">
<h2 class="article-next-up__title">
Beats, Blackness, and Revolution: A Conversation With Jay Versace
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Jay Versace doesn’t care who you thought he was. He never has, and never will. Since his influencer ascension through comedic skits via the now-defunct social media platform, Vine, in 2016, Jay has used his platform to amplify Black spirituality, Black creativity, and Black mental health. Through sharing resources to his large following on social media, he’s continuing to do so even now amid these trying times. One of the several things that he’s been doing to help maintain his inner peace as the country is enthralled in protest has been producing music.</p>
<p>Versace made his first beat in May of 2018, and it was actually met with contention from fans who were only familiar with his comedic side. “When I tweeted I was trying to make music, so many people were like, ‘This is what this is gonna sound like,’ and were sending the craziest gifs and memes and I was like, ‘Damn, y'all really think I have no taste,’” he says when recounting the first time he shared his music on social media. “(Laughs) It was very intense and overwhelming, but I was like you know what, f**k them and kept doing it, kept trying.” And he did exactly that, fine-tuned his beat-making craft by digging into the soulful music he was raised on. Thus, the biggest testament to his growth as a producer has definitely been his early 2020 appearance on Buffalo, New York rapper and Griselda collective member Westside Gunn’s latest critically acclaimed album Pray for Paris, where his beat on the self-titled track “Versace” found him in the production credits next to rap royalty like DJ Premier and Tyler, The Creator. Since this major moment in his music career, Jay has been active in both the studio and on the Internet, spreading awareness about Black rights.</p>
<p>There have been a lot of performative activism surrounding the most recent protests against police brutality following the murders of George Floyd, Ahmaud Arbery, Breonna Taylor, and countless other Black folk in this country. Brands—and some white allies alike—have cleared their conscience with a lukewarm effort, a solid week of Instagram story reshares of burning cop cars and picket signs, and empty PR promises to “stand by the Black community.” Jay recognizes this and believes white allies need to protest in their own communities first before leaving to go protest in others’. “They go to our neighborhood to protest their neighborhood (Laughs). Like, nah, go to your neighborhood to protest. That’s why I really want to see white people using their own in their own spaces that we can’t get to because of their privilege.”</p>
<p>Jay always speaks his mind across his social media platforms, and he remains jovial, yet candid in our conversation about his criticism on certain people profiting from Black culture and the Black plight. His stance is very clear: if you profit off the Black dollar, then you have an obligation to speak up for Black rights. “You have to realize, if you benefit off the Black community, this is how you give them back all that they’ve given you,” Jay says. “If you’re sitting in a mansion and just sitting on the Black dollar based on what you’ve been doing, then this is how you contribute.”</p>
<p>As a 22-year-old queer Black man, he realizes he has to fight for his rights not only in a racist American society but also in a hip-hop space that is often plagued with homophobia. “I really have to work extra hard to find my own style and my own taste and just perfect what I’m doing because people see somebody that’s queer and they automatically don’t want to associate themselves,” Jay says when asked about carving out his own space in the music world. “Because they’re homophobic, or because they don’t want to be saying ‘Oh, what was you doing working with him? What were y’all doing in the studio?’” Despite this, Jay’s individuality has never faltered and he has turned his personality into one of his most endearing qualities. A close friendship with the ethereal Erykah Badu has also helped him maintain a deep relationship with his ancestry and spirituality, and he prides himself on how much he’s grown into his Blackness.</p>
<p>Even over Zoom, Jay’s energy and spirit erased our digital distance. Despite him living in California now, the lighthearted—often misunderstood —sarcasm that only two people from Jersey can understand blended immediately between us. He is deeply rooted in his beliefs, unapologetically himself, and simultaneously still growing into his newly discovered goals and ambitions. In a conversation with VIBE, Jay Versace talks about the current revolution for Black rights, how his spiritual roots have influenced his soulful beats, and why his future looks all-Black.</p>
<script type="application/json">{"width":2000,"height":2997,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-2-1596471750-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-2-1596471750-434x650.jpg","width":434,"height":650},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-2-1596471750-1068x1600.jpg","width":1068,"height":1600},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-2-1596471750-1367x2048.jpg","width":1367,"height":2048},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-2-1596471750-compressed.jpg","width":2000,"height":2997}],"size":"full_width","alignment":"center","orientation":"portrait","id":"682939","caption":"","credit":"Photo by Jax Teller (@_30onme)","altText":"","title":"jay-versace-vibe-interview-2-1596471750"}</script>
<p>What are your feelings like surrounding the current revolution taking place?</p>
<p>It’s mixed emotions. There’s so much good stuff happening, there’s so much bad stuff happening. There’s so much of just both happening at the same time. I’m worried about my mental health and just how I’m, like, trying to be a better version of me so that I can continue to be a voice or some type of spokesperson for people. So half of me is super into it, I’m ready to unpack. I’m ready to change and make everything all-Black, and then on the other side I’m like, “Okay, let me get my mental health together.”</p>
<p>And speaking of things being all-Black, you’re one of the few influencers who have always really advocated for Black rights on your platform. What are your thoughts on a lot of the performative activism we’ve been seeing from brands and influencers lately?</p>
<p>Something told me something like this was going to happen before. A couple of years ago, something told me it’s going to be some people and some brands, and I’ve already just seen it. This type of stuff’s been kind of happening, where brands or people or influencers don’t really care about the Black community, but they know it’s a crowd they need to have a grasp on in order to get them to where they're trying to go in their career. It’s very selfish. It’s something you really just have to analyze. Like, who’s actually trying to contribute towards change, and who’s trying to just contribute towards their change.</p>
<p>I hate it, and that’s why I’ve been calling brands out. So many brands benefit off of Black people and the Black community, and yet they don’t actually help Black people or they don’t actually go into the community and see what needs help. They actually make it worse. They actually make the community worse by the image that they show Black people as.</p>
<p>I think you are the leader of a vanguard of budding Black creatives, personalities, and young people. How have you seen people our age mobilizing right now, and what do you want to see more of?</p>
<p>I see people our age just using their voice. We’re in a completely different time period, where, like, our ancestors gave us the knowledge. They gave us books, they gave us interviews, they spoke out. So I really see people around me, and influencers using their voice but it’s way more powerful and it’s way more impactful now because we have social media where everybody can hear and see everything, and that’s what’s kind of scary. It’s like, I’m not sure if things are worse or better than what our ancestors went through, because they didn’t have cameras to film everything. So now we’re in a time where everybody has their camera out, everybody's using their voices, like every 5-minutes it’s a viral video. That’s what I appreciate about what’s going on right now, we can actually document every single thing.</p>
<p>And what we need to do more of, I feel like it’s a group effort. It’s some stuff that white people need to do more, like, it’s some stuff that white people need to do more of! (Laughs) And then with Black people, we have to organize. We really have to come together and organize better, but just as far as white people I feel like they need to leave us alone and they need to go to their neighborhoods and make changes within their community.</p>
<p>Have you been able to get out and march at all?</p>
<p>No, I haven’t gone out to protest because the way my anxiety is set up. I’m just seeing so much going on with the police. It’s like wars out there, they going back-and-forth, they throwing gas at people, they shooting rubber bullets, and that’s just something that my anxiety won’t let me participate in. I’ve been protesting online.</p>
<p>And people are finally starting to talk about it now, but all the Black trauma does such damaging things to the Black psyche as well.</p>
<p>That’s another thing, I want to add to what I want to see more of. I want to see Black people take care of their mental health because, that first week when things were really hectic, we don’t know how our minds are going to process that within the next couple of months and years. It’s stuff from when I was a little kid that I didn’t realize was traumatic to me, and it’s just now processing. So we really need to take advantage of what we need to do with our mental health because that’s eventually going to take its toll. And even right now it’s wearing down on people’s minds and I just really want people to see that mental health is important.</p>
<p>You’ve always been really transparent about your struggles with anxiety. What’s been helping you keep your peace during these super trying times?</p>
<p>I’ve been making music, I’ve been telling my friends 'cause my friends have been calling me stressed out. I’m like, “Just make music.” Make music because if you think about the other time period where this kind of happened before, with Malcolm X and Martin Luther King, there was a lot of music that was being based on what was going on. I feel like everybody was creating. If you’re an artist, whatever you do, you can contribute to what’s going on by using your skills. So I’ve just been trying to do whatever I do best, and that zens me out.</p>
<p>Do you think artists have an obligation to use their platform to talk about social issues?</p>
<p>Yes, just yes. You have to realize, if you benefit off the Black community, this is how you give them back all that they’ve given you. If you’re sitting in a mansion and just sitting on the Black dollar based on what you’ve been doing, then this is how you contribute. These people need you, these people give to you so give back to them. I don’t understand how that’s so hard. Like, I understand taking some time out to process it and then speak out, but to not speak out at all; I feel like that’s kind of messed up. These people are actually paying your bills, so there is a responsibility to use your voice because not everybody has that following where they can get points across, so we need that. We need people to speak up for us.</p>
<p>The LGBTQ+ Community has always been deeply rooted in social activism. Can you talk about any experiences you’ve had fighting for your voice to be heard as not only a Black man but also a Black queer man in this music space?</p>
<p>I feel like, one thing about music is that being someone that’s queer in music is very difficult. It’s so much homophobia. That’s really the genre I’m going into, that underground hip-hop is so homophobic. So it’s like, I really have to work extra hard to find my own style and my own taste and just perfect what I’m doing because people see somebody that’s queer and they automatically don’t want to associate themselves. Because they’re homophobic, or because they don’t want to be saying, “Oh, what was you doing working with him, what were y’all doing in the studio.”Like, every time I work in the studio with somebody and it comes up it’s like: “Oh, what was y’all doing. What did you have to do for that.” And I’m like, “Yo, we can’t just be two creative people? It has to be something about sexuality?” So it’s like, just what I’m going through right now and trying to make music and being in this homophobic-ass genre, it’s very stressful.</p>
<p>But I feel like it’s changing a lot. A lot of people are coming to their senses and feeling more comfortable with their own sexuality and not having to intimidate other people.</p>
<p></p>
JAYVERSACE · CROSSMYMIND
<p>You’re also boldly independent, I think that’s one of your strongest personality traits. When navigating this music space, how valuable do you think that trait is?</p>
<p>It’s very important just to be stern with what you believe in. I just also feel like, not everything you want to do is worth doing. Not everybody is worth working with. Not everybody deserves to be in your creative space. I know people really want opportunities to come to them, but not every opportunity is worth it. Like sometimes, and definitely as a queer person, if know you’re working with somebody that’s homophobic, is it really worth it? I think about my kids, what do I want to do to set an example for my kids. I want my kids to feel like, whatever sexuality they are, they walk into whatever room or situation as they are and they won’t change for nobody. They will only allow certain sh*t around them, so that’s what I’ve really been trying to do. Yeah, I play sometimes, but as far as allowing certain things to happen around me, I won’t allow. Because you’ll get run over.</p>
<p>I also want to touch on your other Instagram for a minute too, Jayversay. I like to call it your Sprinsta(spiritual Instagram). You’re deeply in touch with your roots, can you talk about how that plays a part in the messages you spread on your platform and your beats? </p>
<p>My spirituality, just where I come from, my family, everybody was just super Black. And even though I grew up around people who were celebratory of being Black, I also did not want to be Black. I grew up not wanting to be Black. I grew up looking at people on magazines, looking at people on TV, looking at certain Black skin tones. I always felt like I was not accepted.</p>
<p>But now, a couple of years ago, I just started to realize, like, look at my history. I started to really dive deep into these books that my family used to always read and just go deep into my history. I’m like, damn. It just made me very angry, that I had all this kept from me for so long. First I got angry, I went through those emotions, then I just got more proud. I wanted to celebrate it, so I’ve always been about Black culture, Black music, all of that since. And since I first started making videos I’ve just tried to help Black people.</p>
<p>Can you talk about the beautiful relationship you have with the ethereal Erykah Badu? How has she helped guide you in your spiritual journey?</p>
<p>Yeah, Erykah Badu helped me make my ancestor altar, she’s the one who told me I needed one. She’s really, as far as my spiritual journey, made me feel comfortable. She made me feel like, okay I’m not going too far. Cause I was really diving deep into my spirituality, but she was like, “Keep going.” Ever since we first came in contact, she’s always just been trying to help me with everything I’ve been doing. She still hits me up every other week, just asking if I’m good. She’s just a very good person, besides her being a celebrity. Just one of the most beautiful humans I’ve ever come across. I really love and appreciate all the help she’s given me. I don’t know where I would be without her right now.</p>
<p>You were on one of the best rap tapes that dropped this year, and you also have a really expansive knowledge of music, even a brief scrolling of your SoundCloud reflects that. That Clark Sisters sample for “Versace” was beautiful. What got you into listening to the classics? </p>
<p>Just how I was raised listening to soulful music. My grandparents, my parents, grew up around rappers and singers and it just stuck with me. I don’t really know, I guess it was always a part of me because anything I remember from liking music has always been the same type of music. I think it’s just built inside of me to like a certain type of style of music, like classic stuff.</p>
<script type="application/json">{"width":2000,"height":2997,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-3-1596471774-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-3-1596471774-434x650.jpg","width":434,"height":650},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-3-1596471774-1068x1600.jpg","width":1068,"height":1600},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-3-1596471774-1367x2048.jpg","width":1367,"height":2048},{"path":"https:\/\/static.vibe.com\/files\/2020\/08\/jay-versace-vibe-interview-3-1596471774-compressed.jpg","width":2000,"height":2997}],"size":"full_width","alignment":"center","orientation":"portrait","id":"682940","caption":"","credit":"Photo by Jax Teller (@_30onme)","altText":"","title":"jay-versace-vibe-interview-3-1596471774"}</script>
<p>There’s a funny tweet of yours about how people are so obsessed with 808’s nowadays. What do you try to avoid when making your beats?</p>
<p>I feel people use 808’s and that same snare because that’s louder than their voice, so people hide under drums because they know they not saying anything. Like, they know if they actually said it out loud without rapping it, it would not make any sense. It would sound corny, so people hide behind 808’s and those same drums because it sounds good, but that’s about it.</p>
<p>I try to avoid sounding like people that I’m compared to. I try to avoid sounding like: “Oh, this is like that!” If I hear that, I’m like, “Okay, bet I’m never going to make music like this again because whatever people hear from me, we already have that.” Don’t compare me to anything, I want to be my own person. So I let people tell me “what I sound like,” so I can not sound like that.</p>
<p>Can you speak on the work you’ve been doing with Freddie Gibbs? You said you were working on a project with him.</p>
<p>Freddie Gibbs is a crackhead, so whatever we’re working on is going to take some time. (Laughs) I’ve sent him beats he’s said he’s writing to, but he stays writing to them and I look on his [Instagram] story and he’s on a boat. I sent him the beats and I’m like, “You know what? I don’t know when I’ma expect a project.” I just know I sent him the beats and he hit me up every now and then like, “Yeah, I wrote to this,” and I’m like “Alright.” So I really don’t know, that’s Freddie Gibbs so I really don’t know. The ball is in his court.</p>
<p>Thoughts on Alfredo?</p>
<p>I loved the album. I actually had the same sample as one of the songs on that album.</p>
<p>Really? Which one?</p>
<p>The one where he was like “Babies &amp; Fools." I sampled that the exact same way and was going to send it to Freddie and I’m glad I didn’t cause Alchemist did it.</p>
<p>I mean, the fact that you and Alchemist are thinking on the same wavelength is impressive as hell.</p>
<p>Yeah, that’s what I keep thinking! I’m like, “Hmm, maybe I’m about to get the next Grammy.” (Laughs) Because me and Alchemist made the same beat by accident, that’s insane to me.</p>
<p>I know you’ve also been in the lab with J.I.D and saw somewhere Ari Lennox too, what’s up with that?</p>
<p>We're just working. Me and J.I.D, we damn near made a whole tape. I’ve never heard this side of J.I.D in my life, so I don’t know what’s about to happen when this gets released because this is like, some of the best music I’ve made. Just with J.I.D and how he’s articulating his words and telling stories, he literally brings the beats to life. He creates stories, it’s some crazy sh*t that we made.</p>
<p></p>
JAYVERSACE · KOOL-AID JAMMERS
<p>Ari Lennox, I don’t know how she works so fast, but she’s like Walt Disney. She works very fast, so I’m excited to work with her.</p>
<p>What’s a dream collaboration of yours?</p>
<p>Damn, that’s so loaded. (Laughs) I would love to work with Jay-Z. Jay-Z or Kendrick [Lamar], I would love to work with either of them. Just how much they inspire me and how my beats sound. I literally make beats for them, so I would love to work with them.</p>
<p>You made one of your first beats on May 14, 2018. Now, over 2 years later, what are you most proud of in your growth as a producer?</p>
<p>Oh my God! I didn’t even know that. I’m most proud of myself for continuing to do it because when I tweeted I was trying to make music, so many people were like, “This is what this is gonna sound like” and were sending the craziest GIF’s and memes and I was like, “Damn, y'all really think I have no taste?” (Laughs) It was very intense and overwhelming, but I was like you know what, f**k them and kept doing it, kept trying. Kept trying new styles and sounds out, and the fact that I kept going and it’s gotten me this far and now I can say that this is my job, that’s what I’m most proud of. Just listening to my own voice.</p>
<p>You said that Donald Glover, Tyler, the Creator, A$AP Rocky, and Drake started everything really in terms of helping shape our generation. I know you’re just getting started, but when you’re just an old head from Jersey, what is the most important thing you want to leave behind?</p>
<p>Damn, I don’t know. I want to leave behind everything. I want my whole journey to be analyzed, from beginning to end. I don’t want nothing to be left out, I want the whole thing to be seen and experienced so that people can get inspired and do whatever they want to do. That’s the only reason why we’re on this planet, to show other people how to be on this planet. So I want to leave behind my whole experience.</p>
<p>I remember you talked in a Fader interview about how layered you are. I don’t think making beats is something new for you, I think it’s just a new part of yourself that you’re sharing. If you made your first beat a little over 2 years ago, and just got featured on Pray for Paris, where do you hope to be 2 years from now?</p>
<p>Two years from now, I expect for me to have a successful production company, successful music career, modeling, acting, architecture. Any type of thing that I want to do. Everything just thriving, and Blackness all over the f**king place.</p>
<script type="application/json">{"nid":"612679","type":"post","title":"Jay Versace Explains How He Raided Shaq&#x27;s Closet For Vintage Reebok Threads","relative_path":"\/2018\/10\/jay-versace-shaq-raided-reebok-closet-interview\/","media":{"width":640,"height":411,"extension":"png","mime_type":"image\/png","type":"image","path":"https:\/\/static.vibe.com\/files\/2018\/10\/Jay-Versace-Shaq-1-1540825551-compressed.png","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2018\/10\/Jay-Versace-Shaq-1-1540825551-156x88.png","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2018\/10\/Jay-Versace-Shaq-1-1540825551-320x180.png","width":320,"height":180}],"orientation":"landscape","id":"612862","caption":null,"credit":null}}</script>
</div>
<a class="article-next-up__continue" href="/2020/08/jay-versace-interview">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
</div>
</section>
<section class="col-holder__right-col" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</section>
</div>
<div class="section-holder">
<div class="section-title-holder ">
<h2 class="section-title">
Top Stories
</h2>
</div>
<div class="feed feed--one-third feed--footer-recommended">
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/09/quavo-fcf-league-interview/" alt="Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-240x135.jpg" srcset="https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-240x135.jpg?1 240w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-602x339.jpg?1 602w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-320x180.jpg?1 320w, https://static.vibe.com/files/2020/09/Quavo-Migos-FCF-Football-League-Interview-5-1600748277-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features&#x2F;>Features</a> </h3>
<span class="feed-post-third__date">
5h ago
</span>
<a href="/2020/09/quavo-fcf-league-interview/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Quavo Is Introducing &#039;Fan Controlled Football&#039; To The Culture
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/09/barack-obama-announces-release-date-for-a-promised-land-memoir/" alt="Barack Obama Announces Release Date For ‘A Promised Land’ Memoir" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2019/04/john-singleton-barack-obama-remembers-legendary-filmmaker-1556662118-240x135.jpg" srcset="https://static.vibe.com/files/2019/04/john-singleton-barack-obama-remembers-legendary-filmmaker-1556662118-240x135.jpg?1 240w, https://static.vibe.com/files/2019/04/john-singleton-barack-obama-remembers-legendary-filmmaker-1556662118-602x339.jpg?1 602w, https://static.vibe.com/files/2019/04/john-singleton-barack-obama-remembers-legendary-filmmaker-1556662118-320x180.jpg?1 320w, https://static.vibe.com/files/2019/04/john-singleton-barack-obama-remembers-legendary-filmmaker-1556662118-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news&#x2F;>News</a> </h3>
<span class="feed-post-third__date">
4d ago
</span>
<a href="/2020/09/barack-obama-announces-release-date-for-a-promised-land-memoir/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Barack Obama Announces Release Date For ‘A Promised Land’ Memoir
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/09/tory-lanez-sued-alleged-attack-miami-nightclub/" alt="Tory Lanez Sued For Alleged Attack In Miami Nightclub" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/08/tory-lanez-GettyImages-926565644-1596601422-240x135.jpg" srcset="https://static.vibe.com/files/2020/08/tory-lanez-GettyImages-926565644-1596601422-240x135.jpg?1 240w, https://static.vibe.com/files/2020/08/tory-lanez-GettyImages-926565644-1596601422-602x339.jpg?1 602w, https://static.vibe.com/files/2020/08/tory-lanez-GettyImages-926565644-1596601422-320x180.jpg?1 320w, https://static.vibe.com/files/2020/08/tory-lanez-GettyImages-926565644-1596601422-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news&#x2F;>News</a> </h3>
<span class="feed-post-third__date">
3d ago
</span>
<a href="/2020/09/tory-lanez-sued-alleged-attack-miami-nightclub/" class="feed-post-third__title-link">
 <h2 class="feed-post-third__title">
Tory Lanez Sued For Alleged Attack In Miami Nightclub
</h2>
</a>
</div>
</div>
</div>
</div>
</main>
<div class="ad-container footerboard footerboard--bottom">
<div class="footerboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-footerboard_ad ' data-position="footerboard_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<footer class="page-footer">
<div class="container">
<div class="footer__header">
<div class="footer__social-holder">
<ul class="footer__social-links">
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<a href="/" class="footer__logo-holder">
</a>
</div>
<ul class="footer__main-menu">
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news>News</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features>Features</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style>Style</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen>Vixen</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva>Viva</a> </li>
<li class="footer__main-menu-link-holder">
<a href=mailto&#x3A;tips&#x40;vibe.com>Contact Us</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;static.vibe.com&#x2F;files&#x2F;2020&#x2F;08&#x2F;VIBE_SELL_SHEET_070120_v5-1596657403.pdf>ADVERTISING</a> </li>
</ul>
<p class="footer__member">
Vibe.com is an affiliate site of Billboard, a subsidiary of Prometheus Global Media, LLC. </p>
<ul class="footer__secondary-menu">
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;privacy-policy&#x2F;>Privacy Policy</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;about-our-ads&#x2F;>Ad Choices</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;copyright&#x2F;>Copyright</a> </li>
<li class="footer__secondary-menu-link-holder">

<a id="ot-sdk-btn" class="ot-sdk-show-settings copyright__link copyright__link--ot" style="">Cookie Settings</a>

</li>
</ul>
<ul class="footer__site-links">
<li class="footer__site-links-link-holder">
<a href="https://www.billboard.com/" target="_blank">Billboard</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a>
</li>
<li class="footer__site-links--mobile-separator"></li>
<li class="footer__site-links-link-holder">
<a href="https://www.spin.com/" target="_blank">SPIN</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.vibe.com/">VIBE</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.stereogum.com/" target="_blank">Stereogum</a>
</li>
</ul>
</div>
<container>
<div class='ad_desktop dfp-ad dfp-ad-adhesion ' data-position="adhesion" data-dark-matter-is-processed="false">
</div>
</container>
<script>
        window.geofeed = function(options) {
            // string two digit continent code EU, NA, OC, AS, SA, AF
            var continent = options.continent.toString();
            // string two digit ISO country code
            var country = options.country.toString();
            // string two digit state code
            var state = options.state.toString();
            if (state == 'CA') {
                document.getElementById("ot-sdk-btn").style.visibility = "visible";
            } else {
                document.getElementById("ot-sdk-btn").style.visibility = "hidden";
            }
            // similar logic can be included for country level and state level users.
        }
    </script>
<script type="text/javascript">
        PGM.createScriptTag("//geolocation.onetrust.com/cookieconsentpub/v1/geo/location/geofeed", {charset: "UTF-8", id: "geofeedid"});
    </script>
</footer>
<div class='ad_desktop dfp-ad dfp-ad-promo ' data-position="promo" data-dark-matter-is-processed="false">
</div>

<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    var darkMatterCMD = function() {
        this.darkMatterCall(function () {

            var keywords = [];

                        if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

            var pageMeta = {
                    pageKeywordData: keywords,
                    iuData: {
                        iu: '6419/valence.vibe/%%device%%/',
                        site_code: 'valence.vibe/%%device%%',
                        zone: 'features'
                    }
                },
                region = this.getUtilities().getSetCookie('PGMCC') || '';

                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "ptype=article",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "url=23d18f43",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "PID=683822",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "keywords=features,music,migos,quavo",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.vibe.com",
                    paths: "",
                    positions: "all"
                });
            
            keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            });

            this.setMetaDataFromPage(pageMeta);
        })
    };

    window.top.DarkMatter.cmd.push([darkMatterCMD]);

    CLARITY.push({
        use: ['ads', 'cookies', 'header'],
        run: function(Ads, cookies, header) {
            // @TODO can remove try/catch after this release; wrapping it for now in site/Clarity deploys are out of
            // sync.
            try {
                // Since we have the ad unit available, let Clarity know about it so we don't have to keep passing that
                // in.
                header.setAdUnit('6419/valence.vibe/%%device%%/');
            } catch(err) {
            }
            Ads.site_code = "valence.vibe/%%device%%";
            Ads.zone = "features";
            var keywords = [];
            var region = cookies.get('PGMCC') ? cookies.get('PGMCC') : '';
            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }
                        keywords.push({
                keywords: "",
                keyvalues: "env=prod",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "ptype=article",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "url=23d18f43",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "PID=683822",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "keywords=features,music,migos,quavo",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "domain=www.vibe.com",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            })
            Ads.keywords = keywords;
                                }
    });

        
</script>
<script src="/assets/js/vendors_/article_/fee_06ff0549.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js/default_/article_/fee_3c36d112.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js//article.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script>
<script type="text/javascript" src="/assets/js/legacy.js?c9882160987783148cf8"></script>
</body>
</html>
