<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<title>
                            Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America
                    </title>
<meta name="article:modified_time" property="article:modified_time" content="2020-10-13T10:11:39-04:00" />
<meta name="article:published_time" property="article:published_time" content="2020-10-13T10:00:52-04:00" />
<meta name="description" property="description" content="The Memphis native releases her new single, &quot;T.H.U.G.,&quot; inspired by the racially-charged incidents dividing the country." />
<meta name="og:description" property="og:description" content="The Memphis native releases her new single, &quot;T.H.U.G.,&quot; inspired by the racially-charged incidents dividing the country." />
<meta name="og:image" property="og:image" content="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-1950x1097.jpg" />
<meta name="og:image:height" property="og:image:height" content="1097" />
<meta name="og:image:width" property="og:image:width" content="1950" />
<meta name="og:title" property="og:title" content="Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Video Places The Mirror In Front of America" />
<meta name="og:type" property="og:type" content="article" />
<meta name="og:url" property="og:url" content="https://www.vibe.com/2020/10/jucee-froot-thug-music-video" />
<meta name="twitter:card" property="twitter:card" content="summary_large_image" />
<meta name="twitter:description" property="twitter:description" content="The Memphis native releases her new single, &quot;T.H.U.G.,&quot; inspired by the racially-charged incidents dividing the country." />
<meta name="twitter:image" property="twitter:image" content="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-1950x1097.jpg" />
<meta name="twitter:title" property="twitter:title" content="Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America" />
<meta name="twitter:site" content="@vibemagazine" />
<meta property="og:site_name" content="Vibe" />
<link href="https://fonts.googleapis.com/css?family=Barlow+Condensed:400,500,600|Barlow:400,700|Lora:400,400i,700,700i" rel="stylesheet">
<link rel="canonical" href="https://www.vibe.com/2020/10/jucee-froot-thug-music-video">
<link rel="amphtml" href="https://www.vibe.com/amp/2020/10/jucee-froot-thug-music-video">
<link rel="icon" href="/assets/images/favicon.ico?c9882160987783148cf8" />
<link rel="shortcut icon" href="/assets/images/favicon.ico?c9882160987783148cf8" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="/assets/images/favicon152.png?c9882160987783148cf8">
<link rel="dns-prefetch" href="https://www.google-analytics.com/">
<link rel="dns-prefetch" href="https://www.googletagservices.com/">
<link rel="dns-prefetch" href="https://www.googletagmanager.com/">
<link rel="dns-prefetch" href="https://www.instagram.com/">
<link rel="dns-prefetch" href="https://www.zergnet.com/">
<link rel="dns-prefetch" href="https://players.brightcove.net/">
<link rel="dns-prefetch" href="https://platform.zig.com/">
<link rel="dns-prefetch" href="https://www.googleadservices.com">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com/">
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net/">
<link rel="dns-prefetch" href="https://cdn.krxd.net/">
<link rel="dns-prefetch" href="https://beacon.krxd.net/">
<link rel="dns-prefetch" href="https://a.quora.com/">
<link rel="dns-prefetch" href="https://connect.facebook.net/">
<link rel="dns-prefetch" href="https://s0.2mdn.net/">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com">
<link rel="dns-prefetch" href="https://sejs.moatads.com/">
<link rel="dns-prefetch" href="https://mb.moatads.com/">
<link rel="dns-prefetch" href="https://tags.bluekai.com/">
<link rel="dns-prefetch" href="https://platform.twitter.com/">
<link rel="dns-prefetch" href="https://analytics.twitter.com/">
<link rel="dns-prefetch" href="https://lib.pgmcdn.com">
<script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": "https://www.vibe.com/2020/10/jucee-froot-thug-music-video",
            "headline": "Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America"
                            ,
                "image": {
                    "@type": "ImageObject",
                    "url": "https://static.vibe.com/files2020/10/jucee-froot-thug-music-video1-1602596049.jpg",
                    "height": 1382,
                    "width": 2456
                }
                        ,
            "publisher": {
                "@type": "Organization",
                "name": ""
                            },
            "author": [
                                    {
                    "@type": "Person",
                    "name": "Preezy Brown"
                    }
                            ],
            "datePublished": "2020-10-13T10:00:52-04:00",
            "dateModified": "2020-10-13T10:11:39-04:00",
            "description": "The Memphis native releases a new single and video, inspired by the racially-charged incidents dividing the country."
                    }
    </script>
<script type="text/javascript">
        var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        assetHost: "/assets",
        contentHost: "https://www.vibe.com",
        sailthruCustomerId: ""
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.resolveOptAnon = (function() {
        var q = [], roa = function resolveOptAnon() { q.push(arguments) };
        roa.dump = function() {return q;};
        return roa;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.enableDeferredAds = false;
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "";
    PGM.blockScripts = false;

        PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1064px)"
    };
    PGM.social = {"facebook":{"site_name":"Vibe","account":"vibe"},"instagram":{"account":"vibemagazine"},"pinterest":{"account":"vibemagazine"},"snapchat":{"account":"vibemagazine"},"twitter":{"account":"vibemagazine"},"youtube":{"account":"vibemedia"}};

    PGM.greCaptchaSiteKey = "6Lfc66MUAAAAAA3lW9bTwbc_vy17EsFlueLHQjze";
</script>
<script src="https://lib.pgmcdn.com/advertisement.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js" async defer></script>

<script type="text/javascript">
    window.top.DarkMatter = window.top.DarkMatter || {};
    window.top.DarkMatter.cmd = window.top.DarkMatter.cmd || [];

            window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"valence.vibe\/%%device%%","zone":"music","single_request_mode":true};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//darkmatter.billboard.com/wp-content/uploads/ad-tech/dark-matter-vibe-com.js'; s.parentNode.insertBefore(ns, s);
})();
</script>


<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = null;
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":1125911414,"default_player":"default"};

window.CLARITY = window.CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){

        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>

<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                                        , 'contentId': '684298'
                                                , 'contentType': 'article'
                                                , 'author': 'Preezy Brown'
                                                , 'category': 'Music'
                                                , 'tags': 'jucee-froot'
                                                , 'publishDate': '2020101310'
                        
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-W3TLHV');
    </script>


<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<link rel="stylesheet" type="text/css" href="/assets/css/article.css?c9882160987783148cf8">
<script type='text/javascript'>
                        var VB = VB || {};
            VB.config = VB.config || {
                contentHost: "https://www.vibe.com",
                mediaHost: "https://static.vibe.com/files"
            };
        </script>
</head>
<body class="page--article">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<div class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="/assets/images/logo/white.svg?c9882160987783148cf8" alt="Vibe">
<span class="site-header__brand-name">Vibe</span>
</a>
</div>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header__nav-link>News</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header__subnav-link>Entertainment</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header__subnav-link>National</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header__subnav-link>Sports</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header__subnav-link>Events</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header__subnav-link>Movies &amp; TV</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed active site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header__nav-link>Music</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
 <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header__subnav-link>Videos</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header__subnav-link>New Releases</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header__subnav-link>Live Reviews</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header__subnav-link>Album Reviews</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header__subnav-link>Music Premieres</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header__nav-link>Features</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header__subnav-link>Digital Covers</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header__subnav-link>Opinion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header__subnav-link>Lists</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style class=site-header__nav-link>Style</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;fashion class=site-header__subnav-link>Fashion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lifestyle class=site-header__subnav-link>Lifestyle</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen class=site-header__nav-link>Vixen</a>
<span class="carat"></span>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva class=site-header__nav-link>Viva</a>
<span class="carat"></span>

</li>
</ul>
<div class="site-header-search site-header-search--mobile js-search-form">
<form class="site-header-search__form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header-search__input js-search-input" placeholder="Search For..." name="keys" maxlength="255">
<input type="submit" value="GO" id="site-header-search__submit" class="site-header-search__submit js-search-submit">
</form>
</div>
<div class="site-header__follow-newsletter-holder">
<div class="site-header-follow">
<h3 class="site-header-follow__title">Follow Vibe</h3>
<ul class="header__social-links">
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<div class="email-subscribe-holder email-subscribe--wide" data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="email-subscribe email-subscribe--wide email-subscribe--has-title">
<h3 class="email-subscribe__title">
The Vibe Mix Newsletter
</h3>
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-menu" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </div>
</div>
</nav>
<form class="site-header__search-form site-header__search-form--main js-search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input js-search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit js-search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
<nav class="site-header-links">
<div class="site-header-links__contents">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header-links__label>Music</a>
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header-links__link>Videos</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header-links__link>New Releases</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header-links__link>Live Reviews</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header-links__link>Album Reviews</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header-links__link>Music Premieres</a> </div>
</nav>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-leaderboard_ad ' data-position="leaderboard_ad" data-dark-matter-is-processed="false">
</div>
<div class='ad_desktop dfp-ad dfp-ad-out_of_page ' data-position="out_of_page" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<main id="main" class="container container--article">
<div class="section-holder col-holder">
<section class="main-well col-holder__left-col js-mainWell">
<article class="article__content-well js-main-article-content article__content-well--  js-revarticle url-breadcrumb is-active  " data-id="684298" data-url-breadcrumb="/2020/10/jucee-froot-thug-music-video" data-content-type="article" data-page-title="Premiere&#x3A;&#x20;Jucee&#x20;Froot&#x27;s&#x20;&quot;T.H.U.G.&quot;&#x20;Places&#x20;The&#x20;Mirror&#x20;In&#x20;Front&#x20;of&#x20;America" data-canonical="https://www.vibe.com/2020/10/jucee-froot-thug-music-video" data-chartbeatSection="" data-analytics-category="Music" data-analytics-tags="Jucee Froot">
<figure class="main-media main-media--videoEmbed  main-media--" data-media-type="videoEmbed" data-media-id="" data-content-type="expandableImage">
<div class="main-media__video-embed">
<iframe width="560" height="315" data-src="https://www.youtube.com/embed/m0PFHQ0kJSs" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</figure>
<div class="article__header">
<h1 class="article__headline">Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America</h1>
<p class="article__meta">
<span class="article__publish-date-and-by">
<span class="js-publish-date article__publish-date" data-pubdate-value="2020101310">
October 13, 2020 - 10:00 am
</span>
<span class="article__by">
by
</span>
</span>
<span class="js-authors-list">
<span class="author"><a href="/author/preezy-brown" class="article__author-link">Preezy Brown</a></span> <span class="social-share">
<span class="social-share__item">
<a class="social-share__link social-share__link--twitter fa fa-twitter" target="_blank" href="https://www.twitter.com/crooklynsdodger">
<span>TWITTER</span>
</a>
</span>
</span>
</span>
</p>
</div>
<div class="article__body article-overlay-handle js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<div class="article__deck">
The Memphis native releases a new single and video, inspired by the racially-charged incidents dividing the country.
</div>
<p>In a time of social unrest within America, a multitude of rap artists has stepped up to the plate with music that channels the pain, frustration, and despair of minorities while chastising the powers that be. Memphis rapper <strong>Jucee Froot</strong>, the creator of the theme to the Starz hit TV show, <em>P-Valley</em>, is the latest artist to address these pressing matters with the visual to her latest release, "T.H.U.G.," inspired by the ongoing police brutality and racially-charged incidents dividing the country.</p>
<p>Shot in Atlanta, in the midst of the COVID-19 pandemic, the Orson Swells-directed video captures her holding court from a podium on the community's frontlines in between black-and-white clips of local riots. The song, inspired by the late Tupac Shakur's acronym for ‘The Hate U Give,’ captures the grim reality that comes with being a person of color in America. Contemplating "[if] you can't call police on police, who gon' save us," Jucee Froot—who felt compelled to address the elephant in the room as a mother of young black men herself—puts forth a powerful statement in "T.H.U.G." that doubles as a sign of the times and a testament to the range of her artistry.</p>
<p>And with a follow-up to her last full-length release, <em>Black Sheep</em>, on the way, "T.H.U.G." could be the calm before the storm as the Atlantic Records signee looks ready to take the next step in her evolution.</p>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<p>Join us for a live Q&amp;A with Jucee Froot tomorrow, October 14 at 9 pm ET on <a href="https://www.instagram.com/vibemagazine" target="_blank" rel="noopener">VIBE's official Instagram page</a>.</p>
</div>
<div class="article__bottom">
<div class="article__bottom-left">
<div class="article__tags">
<span class="article__tags-pre">In This Story:</span>
<ul class="article__tags-holder">
</ul>
</div>
</div>
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa fa-facebook" data-pgm-share="facebook" data-pgm-title="Premiere&#x3A;&#x20;Jucee&#x20;Froot&#x27;s&#x20;&quot;T.H.U.G.&quot;&#x20;Places&#x20;The&#x20;Mirror&#x20;In&#x20;Front&#x20;of&#x20;America" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;10&#x2F;jucee-froot-thug-music-video" href="javascript:void(0);">
<span>FACEBOOK</span>
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa fa-twitter" data-pgm-share="twitter" data-pgm-title="Premiere&#x3A;&#x20;Jucee&#x20;Froot&#x27;s&#x20;&quot;T.H.U.G.&quot;&#x20;Places&#x20;The&#x20;Mirror&#x20;In&#x20;Front&#x20;of&#x20;America" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;10&#x2F;jucee-froot-thug-music-video" href="javascript:void(0);">
<span>TWITTER</span>
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa fa-envelope" data-pgm-title="Premiere&#x3A;&#x20;Jucee&#x20;Froot&#x27;s&#x20;&quot;T.H.U.G.&quot;&#x20;Places&#x20;The&#x20;Mirror&#x20;In&#x20;Front&#x20;of&#x20;America" href="/cdn-cgi/l/email-protection#fac598959e83c7928e8e8a89dcd982c9bbc1dcd982c8bcc1dcd982c8bcc18d8d8dd48c93989fd4999597dcd982c8bcc1c8cac8cadcd982c8bcc1cbcadcd982c8bcc1908f999f9fd79c8895958ed78e928f9dd7978f899399d78c939e9f95dc898f98909f998ec7aa889f97939f889fdcd982c9bbc1dcd982c8cac1b08f999f9fdcd982c8cac1bc8895958edcd982c8cdc189dcd982c8cac1dc8b8f958ec1aed4b2d4afd4bdd4dc8b8f958ec1dcd982c8cac1aa969b999f89dcd982c8cac1ae929fdcd982c8cac1b79388889588dcd982c8cac1b394dcd982c8cac1bc8895948edcd982c8cac1959cdcd982c8cac1bb979f8893999b">
<span>EMAIL ME</span>
</a>
</li>
</ul>
</div>
<div class="js-ad-pageTargeting">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json">
        {
                    }
        </script>
</div>
</article>
</section>
<section class="col-holder__right-col hide-small hide-medium" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
<div class="section-title-holder ">
<h2 class="section-title">
Popular
</h2>
</div>
<div class="feed feed--sidebar">
<div class="feed-post-sidebar
    
    feed-post--article
    feed-post--has-hero-video">
<a href="/2020/10/jucee-froot-thug-music-video" alt="Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America" class="feed-post__image-holder feed-post-sidebar__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-300x169.jpg" srcset="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-300x169.jpg?1 300w, https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-602x339.jpg?1 602w" class="feed-post-sidebar__image" alt="">
</figure>
<div class="feed-post__video-icon">
<span class="feed-post__icon-cta">Watch Video</span>
</div>
</a>
<div class="feed-post-sidebar__info">
<a href="/2020/10/jucee-froot-thug-music-video" class="feed-post-sidebar__title-link">
<h2 class="feed-post-sidebar__title">
Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America
</h2>
</a>
</div>
</div>
</div>
</div>
<div class="email-subscribe-holder " data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="section-title-holder ">
<h2 class="section-title">
The Vibe Mix Newsletter
</h2>
</div>
<div class="email-subscribe  ">
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-article" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </section>
</div>
<div class="section-holder col-holder section-holder--next-up">
<section class="col-holder__left-col left-col--next-up">
<div class='ad_desktop dfp-ad dfp-ad-zergnet ' data-position="zergnet" data-dark-matter-is-processed="false">
</div>
<div class="section-title-holder section-title-holder--zergnet">
<h2 class="section-title">
From the Web
</h2>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="next-up-holder">
<div class="section-title-holder section-title-holder--next-up">
<h2 class="section-title">
More on Vibe
</h2>
</div>
<div class="article-next-up">
<figure class="main-media main-media--videoEmbed  main-media--" data-media-type="videoEmbed" data-media-id="">
<div class="main-media__video-embed">
<iframe width="560" height="315" data-src="https://www.youtube.com/embed/BSZRPv_eVZs" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</figure>
<div class="article-next-up__header">
<a href="/2020/10/elephant-man-skankers-music-video" class="article-next-up__link">
<h2 class="article-next-up__title">
Elephant Man&#039;s &quot;Skankers&quot; Video Rides A Soul Train Line Straight To Jamaica
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>"All of us put in work to try leave the ghetto," said Elephant Man as he made his debut in the pages of VIBE back in April 1998. "That's a feeling that really can't leave you." Posing in the photoshoot with an iced-out pachyderm pendant dangling from his neck, Elly and his bredrens from the Scare Dem Crew—Boom Dandimite, Harry Toddler, and Nitty Kutchie—made it all the way from Seaview Gardens, one of Kingston's hardest neighborhoods, to a full-page write up in VIBE's NEXT section, the magazine's showcase for "People on the Verge." It was a good day—but Elephant was just getting started.</p>
<p>The legendary dancehall icon would go on to share stages with Usher and Chris Brown, collab with Missy Elliott and Lil Jon, perform live on the nationally televised VIBE Awards, and sign a deal with Puff Daddy's Bad Boy Records. Throughout it all, he kept a strong link to Jamaica. They say an Elephant never forgets.</p>
<p>"We all grew in Seaview," Elephant Man told Reshma B in a Boomshots interview years later. "Me, Bounty Killer, Angel Doolas, Bramwell, Daily Bread, Nico Man, Sugar Slick, Jason Sweetness—everybody, we all one big family." Their dream was to get inside the gates of King Jammy's studio in nearby Waterhouse—the same studio that "buss" Shabba Ranks, whom Elly calls "our ghetto superstar."</p>
<p>Getting their start as Bounty Killer's dancehall Junior M.A.F.I.A., the Scare Dem Crew eventually parted ways to pursue solo careers. "From I was in Scare Dem Crew, I was so energetic," Elephant Man remembers. "There's so many big stars—Buju Banton, Bounty Killer...—I wanna be seen, I wanna be heard. I want people to say, 'Yo look! This is no joke thing.'" His greatest gift was his infectious energy on stage, earning Elly the title "Energy God."</p>
<p>That energy would carry Elephant Man to solo stardom as he dropped dancehall anthems like "Pon Di River Pon Di Bank" and "Signal Di Plane." Many of his songs referenced popular moves born at street dances in Kingston and shouted out the dancers who created them, turning more ghetto youths into celebrities. Usain Bolt even broke into a "Gully Creeper" after setting an Olympic sprinting record.</p>
<p>Today, VIBE and Boomshots proudly present the world premiere of Elephant Man's latest music video "Skankers," produced by Downsound Entertainment and directed by Jamaica's visual top shotta Jay Will. "Elephant said he loved Snoop's 'Sensual Seduction' video," Jay recalls. (It's no secret that Elly loves Snoop, and is always saying "Shizzle.") "I pitched him the concept of doing a 'Skankers' Soul Train line with all the dancers he shouts out on the song." Jay was a bright idea that turned into a major production with dancehall star Cecile in project manager mode working with stylist Ayana Rivière to hold fittings and dress rehearsals for a who's who of Jamaican street dance, from Shelly Belly, John Hype, and Marvin Di Beast to TC, Daniboo, Dancing Rebel, and Dolly Body—not to mention crews like Black Dice, Team Royal, and Exclusive Dancers.</p>
<p>Rocking an afro wig and vintage fashions, Walshy Fire of Major Lazer plays the smooth host Don Marvelous and, of course, the multitalented Elephant Man plays the keytar and the talk box as he comes with the crazy musical melodies—interpolating an '80s pop throwback by the English band Cutting Crew over a space-age dancehall track. So push the furniture back, turn the sound up, and start your own socially distanced dancehall Soul Train line. It might be just what the world needs to get over a year like 2020. Like the songs says, Elephant's music is designed to "Make the dance happy, no dancer can sad."</p>
</div>
<a class="article-next-up__continue" href="/2020/10/elephant-man-skankers-music-video">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class="article-next-up">
<figure class="main-media main-media--videoEmbed  main-media--" data-media-type="videoEmbed" data-media-id="">
<div class="main-media__video-embed">
<iframe width="560" height="315" data-src="https://www.youtube.com/embed/kiIyP3hBKxs" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div>
</figure>
<div class="article-next-up__header">
<a href="/2020/10/the-mecca-nas-remy-ma-ghostface-killah-radhamusprime-single" class="article-next-up__link">
<h2 class="article-next-up__title">
Nas, Dave East, Remy Ma, Ghostface Killah, Styles P Join RadhaMUSprime On &quot;The Mecca&quot;
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Dreams really do come true. In conjunction with the premiere of hip-hop lover, TV writer and playwright Radha Blank's new film, The Forty-Year-Old Version, Nas, Dave East, Styles P, Remy Ma, and Ghostface Killah join forces on "The Mecca."</p>
<p>Produced by Bushwick, Brooklyn's own Da Beatminerz, the head-noddin' single serves as the first track off what may be a sneak peek into the official soundtrack for newly released Netflix original film. From Harlem to Queens to Brooklyn to Staten Island and The Bronx, each artist unleashes their 16 bars in true '90s hip-hop fashion, reminiscing on the hard life that made them in the Concrete Jungle aka New York City.</p>
<p>In an interview with VIBE, Blank shared how she went about making musical decisions for her new film, which brings that '90s flava to the motion picture. "I got to work with Guy Routte who is not only my music supervisor, he’s one of my closest friends, and he would go out and find this stuff for me," she shared. "I said I wanted it to feel like D [the character] produces music for Sean Price or Heltah Skeltah and he knew just who to get—Da Beatminerz and Khrysis. I’m not saying a 22-year-old hip-hop producer couldn’t make these sounds, but these sounds have fat on them. They’re thick and they’re grown."</p>
<p>And you hear just that on the new ode, "The Mecca." No word on whether an actual soundtrack for The Forty-Film-Version film will hit streaming platforms. In the meantime, get into this new heat.</p>
<script type="application/json">{"nid":"684228","type":"post","title":"How Radha Blank\u2019s &#x27;40-Year-Old Version&#x27; Found Its Beat","relative_path":"\/2020\/10\/radha-blanks-40-year-old-version-netflix-interview\/","media":{"width":5704,"height":3803,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/10\/Radha-Blank-Forty-Year-Old-Version-1-1602251450-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/10\/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252684904-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/10\/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252675564-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"684231","caption":null,"credit":null}}</script>
</div>
<a class="article-next-up__continue" href="/2020/10/the-mecca-nas-remy-ma-ghostface-killah-radhamusprime-single">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/10/premiere-papoose-gets-suited-and-explains-how-maturity-focuses-on-new-album-endangered-species" alt="Premiere: Papoose Gets Suited And Explains How &quot;Maturity&quot; Focuses On New Album: Endangered Species">
<img src="https://static.vibe.com/files/2020/10/Screen-Shot-2020-10-09-at-1.58.54-AM-1602223442-e1602266649764-650x366.png" srcset="https://static.vibe.com/files/2020/10/Screen-Shot-2020-10-09-at-1.58.54-AM-1602223442-e1602266649764-650x366.png?1 650w, https://static.vibe.com/files/2020/10/Screen-Shot-2020-10-09-at-1.58.54-AM-1602223442-e1602266645151-768x432.png?1 768w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Papoose &amp; Remy Ma">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Papoose</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Papoose &amp; Remy Ma"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/10/premiere-papoose-gets-suited-and-explains-how-maturity-focuses-on-new-album-endangered-species" class="article-next-up__link">
<h2 class="article-next-up__title">
Premiere: Papoose Gets Suited And Explains How &quot;Maturity&quot; Focuses On New Album: Endangered Species
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Amid these wild times of break-ups and no make-ups, we fortunately get to see more visions of #BlackLove with the likes of the happily married union of rap/tv stars Remy Ma and Papoose. Surviving some of the rough experiences that their early courting to locked-in relationship endured, Papoose in some ways, fell back from going super hard with his burgeoning rap career in supporting his wife and family from the sidelines. Let's be clear through, his rapid fire, high level bar game was and is always on deck and he proves this with the release of his newest single, "Maturity," from his long-awaited album, Endangered Species, dropping today (Oct. 9th).</p>
<p>Papoose explains what he feels is a true coming to terms with his current life status, as the video and song blend perfectly. "'Maturity,' is one of my favorite songs on the album! The time in a man's life when he matures is life changing," he states. "It is the moment that he treats his woman like a Queen, remains loyal, faithful...and puts his family first!"</p>
<p>Looking at the time period production of the video, you can tell this was a different experience for Pap, especially since the leading lady in it is his real life leading lady. "Shooting this maturity video was so much fun. The classical sound of the instruments played in this track reminded me of the 1920's/30's era," he continues with ampness. "My wife once gave me a 1920's themed birthday party. It was the best birthday of my life. I wanted to relive that moment. That's why I shot this video in black and white. 1920's style. Black love."</p>
<p>&nbsp;</p>
<p>Although it's all love in his life, the troubling  times we are enduring as a people weighs heavy on Pap as well. Always one to lyrically depict the days and times, this new work does just that, but with Pap at his socially sharpest (especially on the heart wrenching track, "Tribute"). "Real artists are an endangered species! Due to police brutality, this pandemic and so much injustice. Our people are also an endangered species.  I didn't choose this album title, it chose me," he states strongly. "I used all live instruments because real musicians are also rare and [they are] endangered species these days. Brady Watt played all the live instruments. He's a true musician."</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">NEW LP AT MIDNIGHT... "ENDANGERED SPECIES" @papoosepapoose and @bradywattbass have been plotting this album since THIS DAY in February... COVID tried to shut it down but they PUSHED THRU... ENTIRELY PRODUCED BY BRADY WATT...</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by @ djpremier on Oct 8, 2020 at 3:01pm PDT</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>Getting to the main frame of rapping for the people again, Papoose's energy is in attack mode. You'll hear it on the album, but also see it in how he's active in the streets again. Check him tearing up Funk Flex's new freestyle format series, Block Work. He's still got a way with that alphabetical and numerical slaughter.</p>
</div>
<a class="article-next-up__continue" href="/2020/10/premiere-papoose-gets-suited-and-explains-how-maturity-focuses-on-new-album-endangered-species">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
</div>
</section>
<section class="col-holder__right-col" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</section>
</div>
<div class="section-holder">
<div class="section-title-holder ">
<h2 class="section-title">
Top Stories
</h2>
</div>
<div class="feed feed--one-third feed--footer-recommended">
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/10/jucee-froot-thug-music-video/" alt="Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-240x135.jpg" srcset="https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-240x135.jpg?1 240w, https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-602x339.jpg?1 602w, https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-320x180.jpg?1 320w, https://static.vibe.com/files/2020/10/jucee-froot-thug-music-video1-1602596049-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music&#x2F;>Music</a> </h3>
<span class="feed-post-third__date">
12h ago
</span>
<a href="/2020/10/jucee-froot-thug-music-video/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Premiere: Jucee Froot&#039;s &quot;T.H.U.G.&quot; Places The Mirror In Front of America
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/10/scarface-begins-process-for-kidney-transplant/" alt="Scarface Begins Process For Kidney Transplant After Surviving COVID-19" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/03/scarface-GettyImages-464781187-1585274765-240x135.jpg" srcset="https://static.vibe.com/files/2020/03/scarface-GettyImages-464781187-1585274765-240x135.jpg?1 240w, https://static.vibe.com/files/2020/03/scarface-GettyImages-464781187-1585274765-602x339.jpg?1 602w, https://static.vibe.com/files/2020/03/scarface-GettyImages-464781187-1585274765-320x180.jpg?1 320w, https://static.vibe.com/files/2020/03/scarface-GettyImages-464781187-1585274765-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news&#x2F;>News</a> </h3>
<span class="feed-post-third__date">
3d ago
</span>
<a href="/2020/10/scarface-begins-process-for-kidney-transplant/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Scarface Begins Process For Kidney Transplant After Surviving COVID-19
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/10/radha-blanks-40-year-old-version-netflix-interview/" alt="How Radha Blank’s &#039;40-Year-Old Version&#039; Found Its Beat" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/10/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252683859-240x135.jpg" srcset="https://static.vibe.com/files/2020/10/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252683859-240x135.jpg?1 240w, https://static.vibe.com/files/2020/10/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252692819-602x339.jpg?1 602w, https://static.vibe.com/files/2020/10/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252675564-320x180.jpg?1 320w, https://static.vibe.com/files/2020/10/Radha-Blank-Forty-Year-Old-Version-1-1602251450-e1602252687392-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv&#x2F;>Movies &amp; TV</a> </h3>
<span class="feed-post-third__date">
4d ago
</span>
<a href="/2020/10/radha-blanks-40-year-old-version-netflix-interview/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
How Radha Blank’s &#039;40-Year-Old Version&#039; Found Its Beat
</h2>
</a>
</div>
</div>
</div>
</div>
</main>
<div class="ad-container footerboard footerboard--bottom">
<div class="footerboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-footerboard_ad ' data-position="footerboard_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<footer class="page-footer">
<div class="container">
<div class="footer__header">
<div class="footer__social-holder">
<ul class="footer__social-links">
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<a href="/" class="footer__logo-holder">
</a>
</div>
<ul class="footer__main-menu">
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news>News</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features>Features</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style>Style</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen>Vixen</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva>Viva</a> </li>
<li class="footer__main-menu-link-holder">
<a href=mailto&#x3A;tips&#x40;vibe.com>Contact Us</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;static.vibe.com&#x2F;files&#x2F;2020&#x2F;08&#x2F;VIBE_SELL_SHEET_070120_v5-1596657403.pdf>ADVERTISING</a> </li>
</ul>
<p class="footer__member">
Vibe.com is an affiliate site of Billboard, a subsidiary of Prometheus Global Media, LLC. </p>
<ul class="footer__secondary-menu">
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;privacy-policy&#x2F;>Privacy Policy</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;about-our-ads&#x2F;>Ad Choices</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;copyright&#x2F;>Copyright</a> </li>
<li class="footer__secondary-menu-link-holder">

<a id="ot-sdk-btn" class="ot-sdk-show-settings copyright__link copyright__link--ot" style="">Cookie Settings</a>

</li>
</ul>
<ul class="footer__site-links">
<li class="footer__site-links-link-holder">
<a href="https://www.billboard.com/" target="_blank">Billboard</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a>
</li>
<li class="footer__site-links--mobile-separator"></li>
<li class="footer__site-links-link-holder">
<a href="https://www.spin.com/" target="_blank">SPIN</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.vibe.com/">VIBE</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.stereogum.com/" target="_blank">Stereogum</a>
</li>
</ul>
</div>
<container>
<div class='ad_desktop dfp-ad dfp-ad-adhesion ' data-position="adhesion" data-dark-matter-is-processed="false">
</div>
</container>
<script>
        window.geofeed = function(options) {
            // string two digit continent code EU, NA, OC, AS, SA, AF
            var continent = options.continent.toString();
            // string two digit ISO country code
            var country = options.country.toString();
            // string two digit state code
            var state = options.state.toString();
            if (state == 'CA') {
                document.getElementById("ot-sdk-btn").style.visibility = "visible";
            } else {
                document.getElementById("ot-sdk-btn").style.visibility = "hidden";
            }
            // similar logic can be included for country level and state level users.
        }
    </script>
<script type="text/javascript">
        PGM.createScriptTag("//geolocation.onetrust.com/cookieconsentpub/v1/geo/location/geofeed", {charset: "UTF-8", id: "geofeedid"});
    </script>
</footer>
<div class='ad_desktop dfp-ad dfp-ad-promo ' data-position="promo" data-dark-matter-is-processed="false">
</div>
<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    var darkMatterCMD = function() {
        this.darkMatterCall(function () {

            var keywords = [];

                        if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

            var pageMeta = {
                    pageKeywordData: keywords,
                    iuData: {
                        iu: '6419/valence.vibe/%%device%%/',
                        site_code: 'valence.vibe/%%device%%',
                        zone: 'music'
                    }
                },
                region = this.getUtilities().getSetCookie('PGMCC') || '';

                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "ptype=article",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "url=f54ae8a5",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "PID=684298",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "keywords=music,videos,jucee-froot",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.vibe.com",
                    paths: "",
                    positions: "all"
                });
            
            keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            });

            this.setMetaDataFromPage(pageMeta);
        })
    };

    window.top.DarkMatter.cmd.push([darkMatterCMD]);

    CLARITY.push({
        use: ['ads', 'cookies', 'header'],
        run: function(Ads, cookies, header) {
            // @TODO can remove try/catch after this release; wrapping it for now in site/Clarity deploys are out of
            // sync.
            try {
                // Since we have the ad unit available, let Clarity know about it so we don't have to keep passing that
                // in.
                header.setAdUnit('6419/valence.vibe/%%device%%/');
            } catch(err) {
            }
            Ads.site_code = "valence.vibe/%%device%%";
            Ads.zone = "music";
            var keywords = [];
            var region = cookies.get('PGMCC') ? cookies.get('PGMCC') : '';
            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }
                        keywords.push({
                keywords: "",
                keyvalues: "env=prod",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "ptype=article",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "url=f54ae8a5",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "PID=684298",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "keywords=music,videos,jucee-froot",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "domain=www.vibe.com",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            })
            Ads.keywords = keywords;
                                }
    });

        
</script>
<script src="/assets/js/vendors_/article_/fee_06ff0549.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js/default_/article_/fee_3c36d112.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js//article.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script>
<script type="text/javascript" src="/assets/js/legacy.js?c9882160987783148cf8"></script>
</body>
</html>
