<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">
<title>
                            Lil Wayne Shares Cryptic Message Amid Rumors Girlfriend Dumped Him After Donald Trump Endorsement
                    </title>
<meta name="article:modified_time" property="article:modified_time" content="2020-11-04T22:26:30-05:00" />
<meta name="article:published_time" property="article:published_time" content="2020-11-04T22:26:30-05:00" />
<meta name="description" property="description" content="Rumor has it that Lil Wayne’s apparent girlfriend, Denise Bidot, broke up with him after he publicly endorsed Donald Trump." />
<meta name="og:description" property="og:description" content="Rumor has it that Lil Wayne’s apparent girlfriend, Denise Bidot, broke up with him after he publicly endorsed Donald Trump." />
<meta name="og:image" property="og:image" content="https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-1950x1360.jpg" />
<meta name="og:image:height" property="og:image:height" content="1360" />
<meta name="og:image:width" property="og:image:width" content="1950" />
<meta name="og:title" property="og:title" content="Lil Wayne Shares Cryptic Message Amid Rumors Girlfriend Dumped Him After Trump Endorsement" />
<meta name="og:type" property="og:type" content="article" />
<meta name="og:url" property="og:url" content="https://www.vibe.com/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement" />
<meta name="twitter:card" property="twitter:card" content="summary_large_image" />
<meta name="twitter:description" property="twitter:description" content="Rumor has it that Lil Wayne’s apparent girlfriend, Denise Bidot, broke up with him after he publicly endorsed Donald Trump." />
<meta name="twitter:image" property="twitter:image" content="https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-1950x1360.jpg" />
<meta name="twitter:title" property="twitter:title" content="Lil Wayne Shares Cryptic Message Amid Rumors Girlfriend Dumped Him After Donald Trump Endorsement" />
<meta name="twitter:site" content="@vibemagazine" />
<meta property="og:site_name" content="Vibe" />
<link href="https://fonts.googleapis.com/css?family=Barlow+Condensed:400,500,600|Barlow:400,700|Lora:400,400i,700,700i" rel="stylesheet">
<link rel="canonical" href="https://www.vibe.com/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement">
<link rel="amphtml" href="https://www.vibe.com/amp/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement">
<link rel="icon" href="/assets/images/favicon.ico?c9882160987783148cf8" />
<link rel="shortcut icon" href="/assets/images/favicon.ico?c9882160987783148cf8" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="/assets/images/favicon152.png?c9882160987783148cf8">
<link rel="dns-prefetch" href="https://www.google-analytics.com/">
<link rel="dns-prefetch" href="https://www.googletagservices.com/">
<link rel="dns-prefetch" href="https://www.googletagmanager.com/">
<link rel="dns-prefetch" href="https://www.instagram.com/">
<link rel="dns-prefetch" href="https://www.zergnet.com/">
<link rel="dns-prefetch" href="https://players.brightcove.net/">
<link rel="dns-prefetch" href="https://platform.zig.com/">
<link rel="dns-prefetch" href="https://www.googleadservices.com">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com/">
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net/">
<link rel="dns-prefetch" href="https://cdn.krxd.net/">
<link rel="dns-prefetch" href="https://beacon.krxd.net/">
<link rel="dns-prefetch" href="https://a.quora.com/">
<link rel="dns-prefetch" href="https://connect.facebook.net/">
<link rel="dns-prefetch" href="https://s0.2mdn.net/">
<link rel="dns-prefetch" href="https://c.amazon-adsystem.com">
<link rel="dns-prefetch" href="https://sejs.moatads.com/">
<link rel="dns-prefetch" href="https://mb.moatads.com/">
<link rel="dns-prefetch" href="https://tags.bluekai.com/">
<link rel="dns-prefetch" href="https://platform.twitter.com/">
<link rel="dns-prefetch" href="https://analytics.twitter.com/">
<link rel="dns-prefetch" href="https://lib.pgmcdn.com">
<script type="application/ld+json">
            {
            "@context": "http://schema.org",
            "@type": "NewsArticle",
            "mainEntityOfPage": "https://www.vibe.com/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement",
            "headline": "Lil Wayne Shares Cryptic Message Amid Rumors Girlfriend Dumped Him After Donald Trump Endorsement"
                            ,
                "image": {
                    "@type": "ImageObject",
                    "url": "https://static.vibe.com/files2020/01/GettyImages-1203119837-1580485471.jpg",
                    "height": 2790,
                    "width": 4000
                }
                        ,
            "publisher": {
                "@type": "Organization",
                "name": ""
                            },
            "author": [
                                    {
                    "@type": "Person",
                    "name": "VIBE Staff"
                    }
                            ],
            "datePublished": "2020-11-04T22:26:30-05:00",
            "dateModified": "2020-11-04T22:26:30-05:00",
            "description": "Tunechi tweeted that he&#039;s a &quot;lover&quot; but &quot;not a lighter because they burn out.&quot;"
                    }
    </script>
<script type="text/javascript">
        var PGM = window.PGM || {};
    PGM.config = PGM.config || {
        assetHost: "/assets",
        contentHost: "https://www.vibe.com",
        sailthruCustomerId: ""
    };
    (function(PGM) {
        var debug_queue = [];
        PGM.debug = function() {debug_queue.push(arguments);};
        PGM.debug.dump = function() {return debug_queue;}
        PGM.debug.initialCategories = {
                    };
    })(PGM);

    PGM.events = (function() {
        var events_queue = [];
        return {
            trigger: function() {events_queue.push(arguments); },
            get: function() { return events_queue; }
        };
    })();

    PGM.createScript = (function() {
        var q = [], cs = function createScript() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.createScriptTag = (function() {
        var q = [], cs = function createScriptTag() { q.push(arguments) };
        cs.dump = function() {return q;};
        return cs;
    })();

    PGM.resolveOptAnon = (function() {
        var q = [], roa = function resolveOptAnon() { q.push(arguments) };
        roa.dump = function() {return q;};
        return roa;
    })();

        PGM.tests = [];
    PGM.ads = PGM.ads || {};
    PGM.ads.adUnit = '/';
    PGM.ads.enableDeferredAds = false;
    PGM.ads.slots = PGM.ads.slots || {};

    PGM.gtmTrackerName = "";
    PGM.blockScripts = false;

        PGM.mediaQueries = {
        medium: "only screen and (min-width: 768px)",
        large: "only screen and (min-width: 1064px)"
    };
    PGM.social = {"facebook":{"site_name":"Vibe","account":"vibe"},"instagram":{"account":"vibemagazine"},"pinterest":{"account":"vibemagazine"},"snapchat":{"account":"vibemagazine"},"twitter":{"account":"vibemagazine"},"youtube":{"account":"vibemedia"}};

    PGM.greCaptchaSiteKey = "6Lfc66MUAAAAAA3lW9bTwbc_vy17EsFlueLHQjze";
</script>
<script src="https://lib.pgmcdn.com/advertisement.js"></script>
<script data-src="https://www.google.com/recaptcha/api.js" async defer></script>

<script type="text/javascript">
    window.top.DarkMatter = window.top.DarkMatter || {};
    window.top.DarkMatter.cmd = window.top.DarkMatter.cmd || [];

            window.CLARITY_GPT_DELAY = 0.01 * 1000;
	
			clarityPageData = {"site_code":"valence.vibe\/%%device%%","zone":"news","single_request_mode":true};
	
    (function(){
    window.CLARITY = window.CLARITY || [];
    var ns = document.createElement('script'), s = document.getElementsByTagName('script')[0];
    ns.async = true; ns.type = 'text/javascript'; ns.src = '//darkmatter.billboard.com/wp-content/uploads/ad-tech/dark-matter-vibe-com.js'; s.parentNode.insertBefore(ns, s);
})();
</script>


<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];

var PGM = PGM || {};
PGM.ads = PGM.ads || {};
PGM.ads.data = null;
PGM.ads.slots = PGM.ads.slots || {};
PGM.brightcove = {"account_id":1125911414,"default_player":"default"};

window.CLARITY = window.CLARITY || [];

CLARITY.push({
    use: ["ads", "jquery"],
    run: function(Ads, $){

        if( typeof Krux !== 'undefined' ) {
            Ads.addKeyVal("all", "ksg", Krux.segments);
            Ads.addKeyVal("all", "kuid", Krux.user);
        }

        var $embeddedVideos = $('.embedded-content[data-template="video"]');
        if($embeddedVideos.length) {
            // Wish we could do this in the module but it's too late by then
            // for now all embedded videos are autoplay
            Ads.addKeyVal("all", "video", "autoplay");
        } else {
            // Else check if it's one of our autoplay videos
            $('video').each(function () {
                var $vid = $(this),
                    player = $vid.data('player'),
                    account = $vid.data('account');

                if (PGM.brightcove.autoplayers.indexOf(player) >= 0) {
                    // If there are any auto-play vids stop
                    Ads.addKeyVal("all", "video", "autoplay");
                    return false;
                } else if (account) {
                    Ads.addKeyVal("all", "video", "click-to-play");
                    // if there are click-to-plays there could still be an auto-play somewhere, continue
                }
            });
        }
    }
});
</script>

<script type="text/javascript">
        var dataLayer = dataLayer || [];
        dataLayer.push({
            'fireGTM': 'on'
                                        , 'contentId': '684923'
                                                , 'contentType': 'article'
                                                , 'author': 'VIBE Staff'
                                                , 'category': 'News'
                                                , 'tags': 'lil-wayne'
                                                , 'publishDate': '2020110422'
                        
        });
        dataLayer.push({'gtm.start':new Date().getTime(),event:'gtm.js'});
        PGM.createScript('//www.googletagmanager.com/gtm.js?id=GTM-W3TLHV');
    </script>


<script>
    var _comscore = _comscore || [];
    var comscoreVars = {
        c1: "2"
        ,c2: "7395269"
        ,c3: ""
        };
    _comscore.push(comscoreVars);
    </script>
<script type="text/javascript" data-src="https://sb.scorecardresearch.com/beacon.js"></script>
<noscript>
    <img src="http://b.scorecardresearch.com/p?c1=2&c2=7395269&cv=2.0&cj=1" />
</noscript>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<link rel="stylesheet" type="text/css" href="/assets/css/article.css?c9882160987783148cf8">
<script type='text/javascript'>
                        var VB = VB || {};
            VB.config = VB.config || {
                contentHost: "https://www.vibe.com",
                mediaHost: "https://static.vibe.com/files"
            };
        </script>
</head>
<body class="page--article">
<div class="header-wrapper ">
<header id="site-header" class="site-header " role="banner">
<div class="site-header__background">
<div class="site-header__contents">
<div class="site-header__bar">
<button class="site-header__nav-toggle"><i class="fa fa-bars"></i></button>
<div class="site-header__brand">
<a class="site-header__brand-link" href="/">
<img class="site-header__brand-logo" src="/assets/images/logo/white.svg?c9882160987783148cf8" alt="Vibe">
<span class="site-header__brand-name">Vibe</span>
</a>
</div>
<button class="site-header__search-toggle"><i class="fa fa-search"></i></button>
</div>
<nav class="site-header__nav">
<div class="site-header__nav-inner">
<ul class="site-header__nav-items">
<li class="site-header__nav-item collapsed active site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header__nav-link>News</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header__subnav-link>Entertainment</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header__subnav-link>National</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header__subnav-link>Sports</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header__subnav-link>Events</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header__subnav-link>Movies &amp; TV</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music class=site-header__nav-link>Music</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;videos class=site-header__subnav-link>Videos</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;new-releases class=site-header__subnav-link>New Releases</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;live-reviews class=site-header__subnav-link>Live Reviews</a>
<span class="carat"></span>
</li>
 <li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;album-reviews class=site-header__subnav-link>Album Reviews</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music-premieres class=site-header__subnav-link>Music Premieres</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features class=site-header__nav-link>Features</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;digital-covers class=site-header__subnav-link>Digital Covers</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;opinion class=site-header__subnav-link>Opinion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lists class=site-header__subnav-link>Lists</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item collapsed  site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style class=site-header__nav-link>Style</a>
<span class="carat"></span>
<ul class="site-header__subnav-items site-header__subnav-items__child">
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;fashion class=site-header__subnav-link>Fashion</a>
<span class="carat"></span>
</li>
<li class="site-header__subnav-item   site-header__subnav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;lifestyle class=site-header__subnav-link>Lifestyle</a>
<span class="carat"></span>
</li>
</ul>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen class=site-header__nav-link>Vixen</a>
<span class="carat"></span>
</li>
<li class="site-header__nav-item   site-header__nav-item__parent">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva class=site-header__nav-link>Viva</a>
<span class="carat"></span>
</li>
</ul>
<div class="site-header-search site-header-search--mobile js-search-form">
<form class="site-header-search__form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header-search__input js-search-input" placeholder="Search For..." name="keys" maxlength="255">
<input type="submit" value="GO" id="site-header-search__submit" class="site-header-search__submit js-search-submit">
</form>
</div>
<div class="site-header__follow-newsletter-holder">
<div class="site-header-follow">
<h3 class="site-header-follow__title">Follow Vibe</h3>
<ul class="header__social-links">
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="header__social-links-link-holder">
<a class="header__social-links-link header__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<div class="email-subscribe-holder email-subscribe--wide" data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="email-subscribe email-subscribe--wide email-subscribe--has-title">
<h3 class="email-subscribe__title">
The Vibe Mix Newsletter
</h3>
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-menu" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </div>
</div>
</nav>
<form class="site-header__search-form site-header__search-form--main js-search-form" method="get" accept-charset="UTF-8" action="/search/">
<input class="site-header__search-input js-search-input" placeholder="Search..." name="keys" maxlength="255">
<button id="site-header__search-submit" class="site-header__search-submit js-search-submit"><i class="fa fa-times"></i></button>
</form>
</div>
</div>
</header>
<div class="header-wrapper__secondary-header">
 <nav class="site-header-links">
<div class="site-header-links__contents">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news class=site-header-links__label>News</a>
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;entertainment class=site-header-links__link>Entertainment</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;national class=site-header-links__link>National</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;sports class=site-header-links__link>Sports</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;events class=site-header-links__link>Events</a> <a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv class=site-header-links__link>Movies &amp; TV</a> </div>
</nav>
</div>
</div>
<div class="site-header__placeholder"></div>
<div class="ad-container leaderboard leaderboard--top">
<div class="leaderboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-leaderboard_ad ' data-position="leaderboard_ad" data-dark-matter-is-processed="false">
</div>
<div class='ad_desktop dfp-ad dfp-ad-out_of_page ' data-position="out_of_page" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<main id="main" class="container container--article">
<div class="section-holder col-holder">
<section class="main-well col-holder__left-col js-mainWell">
<article class="article__content-well js-main-article-content article__content-well--landscape  js-revarticle url-breadcrumb is-active  " data-id="684923" data-url-breadcrumb="/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement" data-content-type="article" data-page-title="Lil&#x20;Wayne&#x20;Shares&#x20;Cryptic&#x20;Message&#x20;Amid&#x20;Rumors&#x20;Girlfriend&#x20;Dumped&#x20;Him&#x20;After&#x20;Donald&#x20;Trump&#x20;Endorsement" data-canonical="https://www.vibe.com/2020/11/lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement" data-chartbeatSection="" data-analytics-category="News" data-analytics-tags="lil wayne">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="" data-content-type="expandableImage">
<div class="main-media__image-holder">
<img src="https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-650x366.jpg" srcset="https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-650x366.jpg?1 650w, https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-768x432.jpg?1 768w, https://static.vibe.com/files/2020/01/GettyImages-1203119837-1580485471-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class="main-media__image--expandable main-media__image" alt="Lil Wayne">
</div>
<figcaption class="media__details-text">
<div class="media__caption">Lil Wayne performs onstage during the EA Sports Bowl at Bud Light Super Bowl Music Fest on January 30, 2020 in Miami, Florida.
</div>
<div class="media__credit">Kevin Winter/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Lil Wayne"></div> </figure>
<div class="article__header">
<h1 class="article__headline">Lil Wayne Shares Cryptic Message Amid Rumors Girlfriend Dumped Him After Donald Trump Endorsement</h1>
<p class="article__meta">
<span class="article__publish-date-and-by">
<span class="js-publish-date article__publish-date" data-pubdate-value="2020110422">
November 4, 2020 - 10:26 pm
</span>
<span class="article__by">
by
</span>
</span>
<span class="js-authors-list">
<span class="author">
VIBE Staff
</span> <span class="social-share">
</span>
</span>
</p>
</div>
<div class="article__body article-overlay-handle js-fitvids-content">
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<div class="article__deck">
Tunechi tweeted that he's a "lover" but "not a lighter because they burn out."
</div>
<p>Rumors have been swirling that Lil Wayne’s apparent girlfriend, Denise Bidot, broke up with him after he <a href="https://www.vibe.com/2020/10/lil-wayne-endorses-donald-trump" target="_blank" rel="noopener">publicly endorsed Donald Trump</a>.</p>
<p>Tunechi seemingly addressed the breakup with a cryptic rant about love. “I live the way I love and love the way I live,” he <a href="https://twitter.com/LilTunechi/status/1324017302787002368" target="_blank" rel="noopener">wrote</a> on Wednesday (Nov. 4). “I’m a lover not a lighter [because] they burn out. I am an eternal fire and burning love, either leave with a tan, a [third] degree burn, or stay and die in love. You’re sweating. Sincerely, the fireman.”</p>
<div class="embedded-content" data-template="readmore" data-amp-enabled="1"><script type="application/json">{"nid":"680343","type":"post","title":"Listen To Lil Wayne Interview Eminem On Young Money Radio","relative_path":"\/2020\/05\/lil-wayne-interview-eminem-young-money-radio\/","media":{"width":3264,"height":3030,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/05\/lil-wayne-eminem-getty-1588998526.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/lil-wayne-eminem-getty-1588998526-e1588998625828-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/05\/lil-wayne-eminem-getty-1588998526-e1588998621823-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"680346","caption":null,"credit":null}}</script></div>
<p>According to <a href="https://www.lovebscott.com/lil-waynes-girlfriend-broke-endorsed-donald-trump" target="_blank" rel="noopener"><em>Love B Scott</em></a>, Weezy’s Trump devotion played a part in the alleged split. A source reportedly told the site that Bidot was “shocked” and “disappointed” by Wayne’s political declaration.</p>
<p>The model supposedly confirmed the break up on her Instagram Story writing, “Sometimes love just isn’t enough,” before going live on Instagram. Additional <a href="https://www.hotnewhiphop.com/lil-waynes-gf-denise-bidot-deletes-ig-and-denies-breaking-up-with-him-news.120688.html" target="_blank" rel="noopener">reports</a> allege that Weezy was the one who called things off.</p>
<p>Whatever the case, Bidot reportedly denied the split on Twitter and she and Tunechi still follow each other on the bird app. Bidot’s Instagram account has since been deleted.</p>
</div>
<div class="article__bottom">
<div class="article__bottom-left">
<div class="article__tags">
<span class="article__tags-pre">In This Story:</span>
<ul class="article__tags-holder">
<li class="article__tag">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;tag&#x2F;lil-wayne&#x2F;>lil wayne</a> </li>
</ul>
</div>
</div>
<ul class="social-share social-share--bottom">
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--facebook fa fa-facebook" data-pgm-share="facebook" data-pgm-title="Lil&#x20;Wayne&#x20;Shares&#x20;Cryptic&#x20;Message&#x20;Amid&#x20;Rumors&#x20;Girlfriend&#x20;Dumped&#x20;Him&#x20;After&#x20;Donald&#x20;Trump&#x20;Endorsement" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;11&#x2F;lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement" href="javascript:void(0);">
<span>FACEBOOK</span>
</a>
</li>
<li class="social-share__item">
<a class="js-pgm-social-share social-share__link social-share__link--twitter fa fa-twitter" data-pgm-share="twitter" data-pgm-title="Lil&#x20;Wayne&#x20;Shares&#x20;Cryptic&#x20;Message&#x20;Amid&#x20;Rumors&#x20;Girlfriend&#x20;Dumped&#x20;Him&#x20;After&#x20;Donald&#x20;Trump&#x20;Endorsement" data-pgm-url="https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;2020&#x2F;11&#x2F;lil-wayne-rumored-split-girlfriend-dumped-him-trump-endorsement" href="javascript:void(0);">
<span>TWITTER</span>
</a>
</li>
<li class="social-share__item">
<a class="social-share__link social-share__link--email fa fa-envelope" data-pgm-title="Lil&#x20;Wayne&#x20;Shares&#x20;Cryptic&#x20;Message&#x20;Amid&#x20;Rumors&#x20;Girlfriend&#x20;Dumped&#x20;Him&#x20;After&#x20;Donald&#x20;Trump&#x20;Endorsement" href="/cdn-cgi/l/email-protection#ac93cec3c8d591c4d8d8dcdf8a8fd49fed978a8fd49eea978a8fd49eea97dbdbdb82dac5cec982cfc3c18a8fd49eea979e9c9e9c8a8fd49eea979d9d8a8fd49eea97c0c5c081dbcdd5c2c981ded9c1c3dec9c881dfdcc0c5d881cbc5dec0cadec5c9c2c881c8d9c1dcc9c881c4c5c181d8ded9c1dc81c9c2c8c3dedfc9c1c9c2d88adfd9cec6c9cfd891e0c5c08a8fd49e9c97fbcdd5c2c98a8fd49e9c97ffc4cddec9df8a8fd49e9c97efded5dcd8c5cf8a8fd49e9c97e1c9dfdfcdcbc98a8fd49e9c97edc1c5c88a8fd49e9c97fed9c1c3dedf8a8fd49e9c97ebc5dec0cadec5c9c2c88a8fd49e9c97e8d9c1dcc9c88a8fd49e9c97e4c5c18a8fd49e9c97edcad8c9de8a8fd49e9c97e8c3c2cdc0c88a8fd49e9c97f8ded9c1dc8a8fd49e9c97e9c2c8c3dedfc9c1c9c2d8">
<span>EMAIL ME</span>
</a>
</li>
</ul>
</div>
<div class="js-ad-pageTargeting">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/json">
        {
                    }
        </script>
</div>
</article>
</section>
<section class="col-holder__right-col hide-small hide-medium" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
<div class="section-title-holder ">
<h2 class="section-title">
Popular
</h2>
</div>
<div class="feed feed--sidebar">
<div class="feed-post-sidebar
    
    feed-post--article
    ">
<a href="/2020/11/dababy-older-brother-dies-reported-suicide" alt="DaBaby’s Brother Reportedly Commits Suicide" class="feed-post__image-holder feed-post-sidebar__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/11/GettyImages-1206613437-1604452224-300x169.jpg" srcset="https://static.vibe.com/files/2020/11/GettyImages-1206613437-1604452224-300x169.jpg?1 300w, https://static.vibe.com/files/2020/11/GettyImages-1206613437-1604452224-602x339.jpg?1 602w" class="feed-post-sidebar__image" alt="">
</figure>
</a>
<div class="feed-post-sidebar__info">
<a href="/2020/11/dababy-older-brother-dies-reported-suicide" class="feed-post-sidebar__title-link">
<h2 class="feed-post-sidebar__title">
DaBaby’s Brother Reportedly Commits Suicide
</h2>
</a>
</div>
</div>
</div>
</div>
<div class="email-subscribe-holder " data-content-type="emailSubscribe">
<div class="g-recaptcha-container"></div>
<div class="section-title-holder ">
<h2 class="section-title">
The Vibe Mix Newsletter
</h2>
</div>
<div class="email-subscribe  ">
<div class="email-subscribe__content-holder">
<div class="email-subscribe__copy">
<strong>All things VIBE.</strong>
Daily - Straight to your inbox.
</div>
<div class="email-subscribe__error-holder">
<div class="email-subscribe__error-message"></div>
</div>
<form class="email-subscribe__form" novalidate action="">
<input class="email-subscribe__input--email js-subscribe-email" type="email" placeholder="Email Address" name="email" autocomplete="off">
<button class="email-subscribe__submit" type="submit">SIGN UP</button>
<input type="hidden" name="lists" value="vibe-master-list" />
<input type="hidden" name="source" value="web-vibe-article" />
</form>
<div class="email-subscribe__t-and-c">
By subscribing, I agree to the <br /><a href="/p/terms-of-use" target="_blank">Terms of Use</a> and <a href="/p/privacy-policy" target="_blank">Privacy Policy</a>.
</div>
<div class="email-subscribe__success-message">
<div class="copy-holder">
<strong>All things VIBE.</strong>
You have signed up and will start receiving the Vibe Mix Newsletter immediately.
</div>
</div>
</div>
</div>
</div> </section>
</div>
<div class="section-holder col-holder section-holder--next-up">
<section class="col-holder__left-col left-col--next-up">
<div class='ad_desktop dfp-ad dfp-ad-zergnet ' data-position="zergnet" data-dark-matter-is-processed="false">
</div>
<div class="section-title-holder section-title-holder--zergnet">
<h2 class="section-title">
From the Web
</h2>
</div>
<div class="zergnet-holder" data-placement="article"></div>
<div class="next-up-holder">
<div class="section-title-holder section-title-holder--next-up">
<h2 class="section-title">
More on Vibe
</h2>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/11/tlc-documentary-to-debut-on-ae-next-year" alt="TLC Documentary Special To Debut On A&amp;E Next Year">
<img src="https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-650x366.jpg" srcset="https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-650x366.jpg?1 650w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-768x432.jpg?1 768w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="TLC-GettyImages-607377712-1604550826">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Ron Davis/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="TLC-GettyImages-607377712-1604550826"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/11/tlc-documentary-to-debut-on-ae-next-year" class="article-next-up__link">
<h2 class="article-next-up__title">
TLC Documentary Special To Debut On A&amp;E Next Year
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>A documentary about TLC has officially been greenlit at A&amp;E, the cable network announced last Thursday (Oct. 29). The two-hour special, which is apart of A&amp;E's Biography series, chronicles the “journey of the top-selling American female group of all time who led the way with their music, message, and style.”</p>
<p>TLC’s Tionne “T-Boz” Watkins, Rozanda “Chili” Thomas are executive producers on the special alongside Emmy-winners Roger Ross Williams, and Geoff Martz, through their production company, One Story Up. In addition to executive producing, Chili and T-Boz will share their story for the first time in a feature documentary. British director Matt Kay will helm the project.</p>
<script type="application/json">{"nid":"646895","type":"post","title":"TLC&#x27;s Chilli On National Concert Week And Why Bruno Mars Leads Her Collab Wishlist","relative_path":"\/2019\/05\/tlcs-chilli-national-concert-week-bruno-mars\/","media":{"width":3842,"height":2561,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/05\/GettyImages-1135181490-1556992309.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/05\/GettyImages-1135181490-1556992309-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/05\/GettyImages-1135181490-1556992309-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"646915","caption":null,"credit":null}}</script>
<p>The multi-platinum selling group, who were the focus of the 2013 VH1 biopic, CrazySexyCool, originally consisted of T-Boz, Chili, and the late Lisa “Left Eyes Lopes.” Lopes perished in a car accident in 2002, and although T-Boz and Chili attempted to find a new member on the VH1 reality show R U the Girl, T-Boz and Chili have been performing as a duo for more than a decade.</p>
<p>“As someone who has long been in awe of TLC and their musical and cultural impact, I am thrilled to be a part of bringing the story of their music, their journey, and their continuing reverence to the screen,” Williams said. “I am grateful for the opportunity to work with A&amp;E, as well as filmmaker Matthew Kay, to bring this film to life. We hope this film illuminates a side of this incredible group and Tionne “T-Boz” Watkins, Lisa “Left Eye” Lopes, and Rozonda “Chili” Thomas that longtime fans and viewers alike have not seen before.”</p>
</div>
<a class="article-next-up__continue" href="/2020/11/tlc-documentary-to-debut-on-ae-next-year">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
 <a href="/2020/11/baltimore-elects-its-youngest-mayor-ever" alt="Baltimore Elects Its Youngest Mayor Ever In Landslide Victory">
<img src="https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-650x366.jpg" srcset="https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-650x366.jpg?1 650w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-768x432.jpg?1 768w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Voters Go The Polls On Election Day In Baltimore">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit"> J. Countess/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Voters Go The Polls On Election Day In Baltimore"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/11/baltimore-elects-its-youngest-mayor-ever" class="article-next-up__link">
<h2 class="article-next-up__title">
Baltimore Elects Its Youngest Mayor Ever In Landslide Victory
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>The voters have spoken. Politician Brandon Scott won his mayoral bid on Tuesday (Nov. 3) becoming the youngest mayor (in more than a  century), and youngest Black mayor, to hold office in the city.</p>
<p>"I see this as the opportunity for rebirth,” Scott, 36, told Baltimore’s WBAL-TV 11 News following the big win. “The rebirth is going to come when we all have to work together each and every day and do that tough work to make Baltimore a better place.</p>
<p>“I am not the savior,” he continued. “We have to work together as a city unified to make Baltimore better. One person cannot fix things. [These] problems have existed longer than I been alive.”</p>
<script type="application/json">{"nid":"679150","type":"post","title":"Baltimore Cop Under Investigation For Intentionally Coughing At Residents In Public Housing Complex","relative_path":"\/2020\/04\/baltimore-cop-investigation-intentionally-coughing-at-residents-public-housing\/","media":{"width":6000,"height":4000,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2019\/05\/former-baltimore-police-sergant-planted-evidence-1558627530.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2019\/05\/former-baltimore-police-sergant-planted-evidence-1558627530-e1558628350276-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2019\/05\/former-baltimore-police-sergant-planted-evidence-1558627530-e1558628343677-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"650576","caption":null,"credit":null}}</script>
<p dir="ltr" lang="en">@CouncilPresBMS addresses the crowd after receiving the concession call from Bob Wallace in the race for #BaltimoreMayor. Click link for full video. #Election2020 #BaltimoreCityVoteshttps://t.co/xkzI2Lvv2p pic.twitter.com/Bd1YgzeWIT</p>
<p>— FOX Baltimore (@FOXBaltimore) November 4, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
Nabbing just over 71% of the vote, Scott bested opponent Bob Wallace who trailed with 20.11%. Wallace called Brandon to concede late Tuesday.</p>
<p>The historic election follows the resignation of former Baltimore Mayor Catherine Pugh who stepped down last year  amid a book scandal. Jack Young took over as an interim mayor.</p>
<p>Taking to Twitter on Wednesday (Nov. 4), Scott thanked everyone who helped secure the win. “I’m proud, energized and humbled by your [belief] in me and what we can accomplish together,” he tweeted. “We could not have made it without your support.”</p>
<p dir="ltr" lang="en">From the bottom of my heart, I want to thank everyone who made calls, sent texts, put up signs &amp; shared information with friends/family. I’m proud, energized and humbled by your belief in me and what we can accomplish together. We could not have made it here without your support. pic.twitter.com/VvSHCLpAmc</p>
<p>— Brandon M. Scott (@CouncilPresBMS) November 4, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Scott, who is currently Baltimore’s City Council President, called winning the election “the honor of a lifetime,” and vowed to lead fellow Baltimore residents in embarking on a “new way forward for our city.”</p>
</div>
<a class="article-next-up__continue" href="/2020/11/baltimore-elects-its-youngest-mayor-ever">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
<div class='ad_desktop dfp-ad dfp-ad-contentwell_ad ' data-position="contentwell_ad" data-dark-matter-is-processed="false">
</div>
<div class="article-next-up">
<figure class="main-media main-media--image  main-media--landscape" data-media-type="image" data-media-id="">
<div class="main-media__image-holder">
<a href="/2020/11/busta-rhymes-performs-voters-apollo-theater-election-day" alt="Busta Rhymes Performs For Voters Outside Apollo Theater On Election Day">
<img src="https://static.vibe.com/files/2020/11/GettyImages-669039080-1604468234-650x366.jpg" srcset="https://static.vibe.com/files/2020/11/GettyImages-669039080-1604468234-650x366.jpg?1 650w, https://static.vibe.com/files/2020/11/GettyImages-669039080-1604468234-1500x844.jpg?1 1500w, https://static.vibe.com/files/2020/11/GettyImages-669039080-1604468234-768x432.jpg?1 768w, https://static.vibe.com/files/2020/11/GettyImages-669039080-1604468234-1536x864.jpg?1 1536w" sizes="(max-width: 1023px) 100vw, (min-width: 1024px) 650px" class=" main-media__image" alt="Busta Rhymes -- World Ski And Snowboard Festival">
</a>
</div>
<figcaption class="media__details-text">
<div class="media__credit">Andrew Chin/Getty Images</div>
</figcaption>
<div class="expanded-image__target" data-sources='[]' data-alt-text="Busta Rhymes -- World Ski And Snowboard Festival"></div> </figure>
<div class="article-next-up__header">
<a href="/2020/11/busta-rhymes-performs-voters-apollo-theater-election-day" class="article-next-up__link">
<h2 class="article-next-up__title">
Busta Rhymes Performs For Voters Outside Apollo Theater On Election Day
</h2>
</a>
</div>
<div class="article-next-up__body">
<div class="article-next-up__intro-holder">
<div class="article-next-up__intro">
<p>Busta Rhymes hit up the Apollo Theater to spread a little “joy” to voters on Election Day.  The 48-year-old rapper, who is promoting his latest album Extinction Level Event 2: The Wrath of God, joined Funk Master Flex for a pop-up show in Harlem on Tuesday (Nov. 3).</p>
<p>The live performances were apart of Joy to the Polls, a nonpartisan movement spearheaded by the Election Defenders — a group of volunteers that include community organizers, and faith leaders — to help end voter suppression.</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">PULL UP AND RIDE OUT WITH IS RIGHT NOW!!! @funkflex &amp; The Dragon &#x1f409; WE’RE ABOUT TO GET BUSY AT THE POLLING SITE IN HARLEM AT AN UNDISCLOSED LOCATION!! &#x1f440;&#x1f440;&#x1f440;&#x1f440;IF YOU KNOW WHERE TO BE SEE YOU THERE!!! &#x1f92f;&#x1f92f;&#x1f92f;&#x1f92f;&#x1f92f;&#x1f92f;&#x1f92f;&#x1f92f; #ELE2THEWRATHOFGODRELOADED AVAILABLE AND STREAMING EVERYWHERE RIGHT NOW WITH 4 MORE BANGERS ADDED TO THE ALBUM!!!!! THE PROPHECY IS BEING FULFILLED!!!! Click link in Bio&#x203c;&#xfe0f;&#x203c;&#xfe0f;&#x203c;&#xfe0f;&#x203c;&#xfe0f;&#x203c;&#xfe0f;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Busta Rhymes (@bustarhymes) on Nov 3, 2020 at 11:50am PST</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
<p dir="ltr" lang="en">On my way home from reporting on #Elections2020 , I ran into @BustaRhymes. Yes, THAT Busta! pic.twitter.com/R3pC8ZxD03</p>
<p>— Joyce Philippe (@JoyceMeetsWorld) November 3, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p dir="ltr" lang="en">It’s @BustaRhymes bringing #JoyToThePolls in Harlem! #ElectionDefenders pic.twitter.com/aQFgfQX3XQ</p>
<p>— #JoyToThePolls (@JoyToThePolls) November 3, 2020</p>
<p><script async data-src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<script type="application/json">{"nid":"683640","type":"post","title":"Busta Rhymes &amp; Trippie Redd Connect, Conway The Machine Transforms #fktg, Alyx Ander &amp; Mya Link and staHHr Loves Black Men","relative_path":"\/2020\/09\/busta-rhymes-trippie-redd-connect-conway-the-machine-transforms-fktg-alyxander-mya-link-and-stahhr-loves-black-men\/","media":{"width":2291,"height":1535,"extension":"jpg","mime_type":"image\/jpeg","type":"image","path":"https:\/\/static.vibe.com\/files\/2020\/09\/unnamed-3-1599861643-compressed.jpg","sizes":[{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/unnamed-3-1599861643-156x88.jpg","width":156,"height":88},{"path":"https:\/\/static.vibe.com\/files\/2020\/09\/unnamed-3-1599861643-320x180.jpg","width":320,"height":180}],"orientation":"landscape","id":"683654","caption":null,"credit":null}}</script>
<p>Following a short performance, Busta shared a lengthy message on Instagram encouraging Black voters to think beyond the polls. “Salute to everyone that is doing [their] part today but what we actually have to do is much deeper than voting!!! We need to empower [ourselves] mind, body, spirit &amp; economically, so that these politicians will have to properly negotiate with us for our dollars and our vote!!”</p>
<p>&nbsp;</p>
View this post on Instagram
<p>&nbsp;</p>
<p style="margin: 8px 0 0 0; padding: 0 4px;">TODAY ON THIS ELECTION DAY I STAND WITH MY PEOPLE AND FOR MY PEOPLE!!! SALUTE TO EVERYONE THAT IS DOING THERE PART TODAY BUT WHAT WE ACTUALLY HAVE TO DO IS MUCH DEEPER THAN VOTING!!! WE NEED TO EMPOWER OURSELF MIND, BODY, SPIRIT &amp; ECONOMICALLY SO THAT THESE POLITICIANS WILL HAVE TO PROPERLY NEGOTIATE WITH US FOR OUR DOLLARS AND OUR VOTE!! WE ARE TRULY LIVING IN THE EYE OF THE STORM OF A REAL EXTINCTION LEVEL EVENT WHEN IT COMES TO OUR PEOPLE AND ALL THE SHIT THAT THEY HAVE BEEN TRYING TO DO TO US SINCE THE BEGINNING OF TIME!! BE GREAT MY BEAUTIFUL, POWERFUL &amp; RESILIENT BLACK PEOPLE AND LET’S MAKE SURE THEY FEEL THE WRATH OF GOD!! #ELE2THEWRATHOFGODRELOADED AVAILABLE AND STREAMING EVERYWHERE RIGHT NOW!!! Click link in Bio &#x203c;&#xfe0f;&#x203c;&#xfe0f;&#x203c;&#xfe0f;&#x203c;&#xfe0f; HARLEM I SALUTE Y’ALL!! Salute @funkflex &amp; @joejaxson @spliffstar_mrlewis @djscratchator</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Busta Rhymes (@bustarhymes) on Nov 3, 2020 at 1:45pm PST</p>
<p><script async data-src="//www.instagram.com/embed.js"></script></p>
<p>Joy to the Polls urges voters to stay in line by turning voting into a celebration with music and dancing at polling locations around the country. Offset and Big Daddy Kane were among the rappers who participated in the grassroots movement, which includes Spotify playlists curated by Aloe Blacc, Black Thought, DJ Jazzy Jeff, Lin-Manuel Miranda, QuestLove, and more.</p>
<p>“In the face of a global pandemic, threats of violence and long lines designed to suppress the vote, the people are fighting back with joy,” Joy to the Polls creator and Election Defenders campaign manager, Nelini Stamp, told BET.com. “Together, we will make voting more accessible for all.”</p>
</div>
<a class="article-next-up__continue" href="/2020/11/busta-rhymes-performs-voters-apollo-theater-election-day">
<div class="article-next-up__continue-button">Continue Reading</div>
</a>
</div>
</div>
</div>
</div>
</section>
<section class="col-holder__right-col" data-content-type="stickySidebar">
<div class="sidebar-sticky-holder">
<div class="sidebar-ad-holder">
<div class='ad_desktop dfp-ad dfp-ad-rightrail_ad ' data-position="rightrail_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</section>
</div>
<div class="section-holder">
<div class="section-title-holder ">
<h2 class="section-title">
Top Stories
</h2>
</div>
<div class="feed feed--one-third feed--footer-recommended">
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/11/interview-t-i-talks-activism-verzuz-battle-and-his-desire-to-produce-a-biopic-on-his-life-before-fame/" alt="T.I. Talks Activism, Verzuz Battle, And Wanting To Produce A Biopic On His Story" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/11/Screen-Shot-2020-11-03-at-5.02.27-PM-1604441012-240x135.png" srcset="https://static.vibe.com/files/2020/11/Screen-Shot-2020-11-03-at-5.02.27-PM-1604441012-240x135.png?1 240w, https://static.vibe.com/files/2020/11/Screen-Shot-2020-11-03-at-5.02.27-PM-1604441012-602x339.png?1 602w, https://static.vibe.com/files/2020/11/Screen-Shot-2020-11-03-at-5.02.27-PM-1604441012-320x180.png?1 320w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features&#x2F;>Features</a> </h3>
<span class="feed-post-third__date">
2d ago
</span>
<a href="/2020/11/interview-t-i-talks-activism-verzuz-battle-and-his-desire-to-produce-a-biopic-on-his-life-before-fame/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
T.I. Talks Activism, Verzuz Battle, And Wanting To Produce A Biopic On His Story
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
 <a href="/2020/11/baltimore-elects-its-youngest-mayor-ever/" alt="Baltimore Elects Its Youngest Mayor Ever In Landslide Victory" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-240x135.jpg" srcset="https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-240x135.jpg?1 240w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-602x339.jpg?1 602w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-320x180.jpg?1 320w, https://static.vibe.com/files/2020/11/GettyImages-1283730465-1604541520-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news&#x2F;>News</a> </h3>
<span class="feed-post-third__date">
22h ago
</span>
<a href="/2020/11/baltimore-elects-its-youngest-mayor-ever/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
Baltimore Elects Its Youngest Mayor Ever In Landslide Victory
</h2>
</a>
</div>
</div>
<div class="feed-post-third
    
    feed-post--article
    ">
<a href="/2020/11/tlc-documentary-to-debut-on-ae-next-year/" alt="TLC Documentary Special To Debut On A&amp;E Next Year" class="feed-post__image-holder feed-post-third__image-holder">
<figure class="feed-post__media--landscape">
<img src="https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-240x135.jpg" srcset="https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-240x135.jpg?1 240w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-602x339.jpg?1 602w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-320x180.jpg?1 320w, https://static.vibe.com/files/2020/11/TLC-GettyImages-607377712-1604550826-650x366.jpg?1 650w" class="feed-post-third__image" alt="">
</figure>
</a>
<div class="feed-post-third__info">
<h3 class="feed-post-third__category">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;movies-tv&#x2F;>Movies &amp; TV</a> </h3>
<span class="feed-post-third__date">
19h ago
</span>
<a href="/2020/11/tlc-documentary-to-debut-on-ae-next-year/" class="feed-post-third__title-link">
<h2 class="feed-post-third__title">
TLC Documentary Special To Debut On A&amp;E Next Year
</h2>
</a>
</div>
</div>
</div>
</div>
</main>
<div class="ad-container footerboard footerboard--bottom">
<div class="footerboard-wrapper">
<div class="ad_desktop_placeholder">
<div class="ad_desktop_wrapper">
<div class='ad_desktop dfp-ad dfp-ad-footerboard_ad ' data-position="footerboard_ad" data-dark-matter-is-processed="false">
</div>
</div>
</div>
</div>
</div>
<footer class="page-footer">
<div class="container">
<div class="footer__header">
<div class="footer__social-holder">
<ul class="footer__social-links">
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--facebook" href="https://www.facebook.com/vibe" target="_blank">
<span class="fa fa-facebook"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--twitter" href="https://www.twitter.com/vibemagazine" target="_blank">
<span class="fa fa-twitter"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--instagram" href="https://www.instagram.com/vibemagazine" target="_blank">
<span class="fa fa-instagram"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--youtube" href="https://www.youtube.com/user/vibemedia" target="_blank">
<span class="fa fa-youtube"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--snapchat" href="https://www.snapchat.com/add/vibemagazine" target="_blank">
<span class="fa fa-snapchat-ghost"></span>
</a>
</li>
<li class="footer__social-links-link-holder">
<a class="footer__social-links-link footer__social-links-link--pinterest" href="https://www.pinterest.com/vibemagazine" target="_blank">
<span class="fa fa-pinterest"></span>
</a>
</li>
</ul>
</div>
<a href="/" class="footer__logo-holder">
</a>
</div>
<ul class="footer__main-menu">
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;news>News</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;music>Music</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;features>Features</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;style>Style</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;vixen>Vixen</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;category&#x2F;viva>Viva</a> </li>
<li class="footer__main-menu-link-holder">
<a href=mailto&#x3A;tips&#x40;vibe.com>Contact Us</a> </li>
<li class="footer__main-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;static.vibe.com&#x2F;files&#x2F;2020&#x2F;08&#x2F;VIBE_SELL_SHEET_070120_v5-1596657403.pdf>ADVERTISING</a> </li>
</ul>
<p class="footer__member">
Vibe.com is an affiliate site of Billboard, a subsidiary of Prometheus Global Media, LLC. </p>
<ul class="footer__secondary-menu">
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;privacy-policy&#x2F;>Privacy Policy</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;about-our-ads&#x2F;>Ad Choices</a> </li>
<li class="footer__secondary-menu-link-holder">
<a href=https&#x3A;&#x2F;&#x2F;www.vibe.com&#x2F;copyright&#x2F;>Copyright</a> </li>
<li class="footer__secondary-menu-link-holder">

<a id="ot-sdk-btn" class="ot-sdk-show-settings copyright__link copyright__link--ot" style="">Cookie Settings</a>

</li>
</ul>
<ul class="footer__site-links">
<li class="footer__site-links-link-holder">
<a href="https://www.billboard.com/" target="_blank">Billboard</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.hollywoodreporter.com/" target="_blank">The Hollywood Reporter</a>
</li>
<li class="footer__site-links--mobile-separator"></li>
<li class="footer__site-links-link-holder">
<a href="https://www.spin.com/" target="_blank">SPIN</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.vibe.com/">VIBE</a>
</li>
<li class="footer__site-links-link-holder">
<a href="https://www.stereogum.com/" target="_blank">Stereogum</a>
</li>
</ul>
</div>
<container>
<div class='ad_desktop dfp-ad dfp-ad-adhesion ' data-position="adhesion" data-dark-matter-is-processed="false">
</div>
</container>
<script>
        window.geofeed = function(options) {
            // string two digit continent code EU, NA, OC, AS, SA, AF
            var continent = options.continent.toString();
            // string two digit ISO country code
            var country = options.country.toString();
            // string two digit state code
            var state = options.state.toString();
            if (state == 'CA') {
                document.getElementById("ot-sdk-btn").style.visibility = "visible";
            } else {
                document.getElementById("ot-sdk-btn").style.visibility = "hidden";
            }
            // similar logic can be included for country level and state level users.
        }
    </script>
<script type="text/javascript">
        PGM.createScriptTag("//geolocation.onetrust.com/cookieconsentpub/v1/geo/location/geofeed", {charset: "UTF-8", id: "geofeedid"});
    </script>
</footer>
<div class='ad_desktop dfp-ad dfp-ad-promo ' data-position="promo" data-dark-matter-is-processed="false">
</div>
<script>
    window.CLARITY = window.CLARITY || [];
</script>
<div class="ad_clarity" data-out-of-page="true" style="display: none;"></div>
<script>
    var darkMatterCMD = function() {
        this.darkMatterCall(function () {

            var keywords = [];

                        if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }

            var pageMeta = {
                    pageKeywordData: keywords,
                    iuData: {
                        iu: '6419/valence.vibe/%%device%%/',
                        site_code: 'valence.vibe/%%device%%',
                        zone: 'news'
                    }
                },
                region = this.getUtilities().getSetCookie('PGMCC') || '';

                            keywords.push({
                    keywords: "",
                    keyvalues: "env=prod",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "ptype=article",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "url=616d4ef6",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "PID=684923",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "keywords=news,lil-wayne",
                    paths: "",
                    positions: "all"
                });
                            keywords.push({
                    keywords: "",
                    keyvalues: "domain=www.vibe.com",
                    paths: "",
                    positions: "all"
                });
            
            keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            });

            this.setMetaDataFromPage(pageMeta);
        })
    };

    window.top.DarkMatter.cmd.push([darkMatterCMD]);

    CLARITY.push({
        use: ['ads', 'cookies', 'header'],
        run: function(Ads, cookies, header) {
            // @TODO can remove try/catch after this release; wrapping it for now in site/Clarity deploys are out of
            // sync.
            try {
                // Since we have the ad unit available, let Clarity know about it so we don't have to keep passing that
                // in.
                header.setAdUnit('6419/valence.vibe/%%device%%/');
            } catch(err) {
            }
            Ads.site_code = "valence.vibe/%%device%%";
            Ads.zone = "news";
            var keywords = [];
            var region = cookies.get('PGMCC') ? cookies.get('PGMCC') : '';
            // Keyword injection
            if (typeof(global_keywords) !== "undefined") {
                keywords = global_keywords;
            }
                        keywords.push({
                keywords: "",
                keyvalues: "env=prod",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "ptype=article",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "url=616d4ef6",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "PID=684923",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "keywords=news,lil-wayne",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "domain=www.vibe.com",
                paths: "",
                positions: "all"
            });
                        keywords.push({
                keywords: "",
                keyvalues: "region=" + region,
                paths: "",
                positions: "all"
            })
            Ads.keywords = keywords;
                                }
    });

        
</script>
<script src="/assets/js/vendors_/article_/fee_06ff0549.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js/default_/article_/fee_3c36d112.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script><script src="/assets/js//article.bundle.js?70698c2a50e6e10de2bc?c9882160987783148cf8"></script>
<script type="text/javascript" src="/assets/js/legacy.js?c9882160987783148cf8"></script>
</body>
</html>
